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Summary of DDD

The purpose of a debugger such asddd is to allow you to see what is going on “inside” another
program while it executes—or what another program was doing at the moment it crashed.

ddd can do four main kinds of things (plus other things in support of these) to help you catch
bugs in the act:

• Start your program, specifying anything that might affect its behavior.

• Make your program stop on specified conditions.

• Examine what has happened, when your program has stopped.

• Change things in your program, so you can experiment with correcting the effects of one bug
and go on to learn about another.

Technically speaking,ddd is a front-end to a command-line debugger (calledinferior debugger,
because it lies at the layer beneathddd). ddd supports the following inferior debuggers:

• To debugexecutable binaries, you can useddd with gdb, dbx, Ladebug, or xdb.

− gdb, thegnu debugger, is the recommended inferior debugger forddd. gdb supports
native executables binaries originally written in C, C++, Java, Modula-2, Modula-3, Pas-
cal, Chill, Ada, and FORTRAN. (seesection “Usinggdb with Different Languages” in
Debugging with gdb, for information on language support ingdb.)

− As an alternative togdb, you can useddd with thedbx debugger, as found on several
unix systems. Mostdbx incarnations offer fewer features thangdb, and some of the
more advanceddbx features may not be supported byddd. However, usingdbx may be
useful ifgdb does not understand or fully support the debugging information as generated
by your compiler.

− As an alternative togdb anddbx, you can useddd with Ladebug, as found on Com-
paq and DEC systems. Ladebug offers fewer features thangdb, and some of the more
advanced Ladebug features may not be supported byddd. However, using Ladebug may
be useful ifgdb or dbx do not understand or fully support the debugging information as
generated by your compiler.1

− As another alternative togdb, you can useddd with the xdb debugger, as found on
hp-ux systems.2.

• To debugJava byte code programs, you can useddd with jdb, the Java debugger, as ofjdk
1.1 and later. (ddd has been tested withjdk 1.1 andjdk 1.2.)

• To debugPython programs, you can useddd with pydb, a Python debugger.

• To debugPerl programs, you can useddd with thePerl debugger, as of Perl 5.003 and later.

• To debugBash programs, you need a version Bash that supports extended debugging support.
To get this enhanced version seehttp://bashdb.sourceforge.net . You will need
version 2.05b-debugger-0.32 or later to work withddd.

SeeSection 2.1.1 [Choosing an Inferior Debugger], page 15, for choosing the appropriate infe-
rior debugger. SeeChapter 1 [Sample Session], page 5, for getting a first impression ofddd.

1 Within ddd (and this manual), Ladebug is considered adbx variant. Hence, everything said fordbx also
applies to Ladebug, unless stated otherwise.

2 xdb will no longer be maintained in futureddd releases. Use a recentgdb version instead.

http://bashdb.sourceforge.net
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About this Manual

This manual comes in several formats:

• The Info format is used for browsing on character devices; it comes without pictures. You
should have a local copy installed, which you can browse via Emacs, the stand-aloneinfo
program, or fromddd via ‘Help ⇒ ddd Reference ’.

Theddd source distribution ‘ddd-3.3.9.tar.gz ’ contains this manual as pre-formatted
info files; you can also download them from
theddd www page.

• ThePostScriptformat is used for printing on paper; it comes with pictures as well.

Theddd source distribution ‘ddd-3.3.9.tar.gz ’ contains this manual as pre-formatted
PostScript file; you can also download it from
theddd www page.

• The PDF format is used for printing on paper as well as for online browsing; it comes with
pictures as well.

Theddd source distribution ‘ddd-3.3.9.tar.gz ’ contains this manual as pre-formatted
PDF file; you can also download it from
theddd www page.

• The HTML format is used for browsing on bitmap devices; it includes several pictures. You
can view it using a HTML browser, typically from a local copy.

A pre-formatted HTML version of this manual comes in a separateddd package
‘ddd-3.3.9-html-manual.tar.gz ’; you can browse and download it via
theddd www page.

The manual itself is written in TEXinfo format; its source code ‘ddd.texi ’ is contained in the
ddd source distribution ‘ddd-3.3.9.tar.gz ’.

The picture sources come in a separate package ‘ddd-3.3.9-pics.tar.gz ’; you need this
package only if you want to re-create the PostScript, HTML, or PDF versions.

Typographic conventions

〈Ctrl+A〉 The name for a key on the keyboard (or multiple keys pressed simultaneously)

run A sequence of characters to be typed on the keyboard.

‘~/.ddd/init ’
A file.

‘Help ’ A graphical control element, such as a button or menu item.

‘File ⇒ Open Program ’
A sequence of menu items, starting at the top-level menu bar.

argc - 1 Program code or debugger command.

‘ -g ’ A command-line option.

$ System prompt.

(gdb) Debugger prompt.

http://www.gnu.org/software/ddd/
http://www.gnu.org/software/ddd/
http://www.gnu.org/software/ddd/
http://www.gnu.org/software/ddd/
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_ Cursor position.

version A metasyntactic variable; something that stands for another piece of text.

definition A definition.

caution Emphasis.

A warning Strong emphasis.

ddd An acronym.

Here’s an example. ‘break location ’ is a typed command at the ‘(gdb) ’ prompt; the meta-
syntactic variable ‘location ’ would be replaced by the actual location. ‘_’ is the cursor position after
entering the command.

(gdb) break location
Breakpoint number at location
(gdb) _

Free software

ddd is free; this means that everyone is free to use it and free to redistribute it on a free basis.
ddd is not in the public domain; it is copyrighted and there are restrictions on its distribution, but
these restrictions are designed to permit everything that a good cooperating citizen would want to
do. What is not allowed is to try to prevent others from further sharing any version ofddd that
they might get from you. The precise conditions are found in thegnu General Public License that
comes withddd; SeeAppendix G [License], page 187, for details.

The easiest way to get a copy ofddd is from someone else who has it. You need not ask for
permission to do so, or tell any one else; just copy it.

Getting DDD

If you have access to the Internet, you can get the latest version ofddd from the anonymousftp
server ‘ftp.gnu.org ’ in the directory ‘/gnu/ddd ’. This should contain the following files:

‘ ‘ddd- version.tar.gz’ ’
Theddd source distribution. This should be all you need.

‘ ‘ddd- version-html-manual.tar.gz’ ’
Theddd manual in HTML format. You need this only if you want to install a local
copy of theddd manual in HTML format.

‘ ‘ddd- version-pics.tar.gz’ ’
Sources of images included in theddd manual. You need this only if you want to
recreate theddd manual.

ddd can also be found at numerous other archive sites around the world; check the file
‘ANNOUNCE’ in a ddd distribution for the latest known list.

Contributors to DDD

Dorothea Lütkehaus and Andreas Zeller were the original authors ofddd. Many others have
contributed to its development. The files ‘ChangeLog ’ and ‘THANKS’ in the ddd distribution
approximates a blow-by-blow account.
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History of DDD

The history ofddd is a story of code recycling. The oldest parts ofddd were written in 1990,
whenAndreas Zellerdesignedvsl, a box-based visual structure language for visualizing data and
program structures. Thevsl interpreter and the Box library became part of Andreas’ Diploma
Thesis, a graphical syntax editor based on the Programming System Generatorpsg.

In 1992, thevsl and Box libraries were recycled for thenora project. Fornora, an experi-
mental inference-based software development tool set, Andreas wrote a graph editor (based onvsl
and the Box libraries) and facilities for inter-process knowledge exchange. Based on these tools,
Dorothea Lütkehaus(nowDorothea Krabiell) realizedddd as her Diploma Thesis, 1994.

The originalddd had no source window; this was added by Dorothea during the winter of
1994–1995. In the first quarter of 1995, finally, Andreas completedddd by adding command and
execution windows, extensions fordbx and remote debugging as well as configuration support for
several architectures. Since then, Andreas has further maintained and extendedddd, based on the
comments and suggestions of severalddd users around the world. See the comments in theddd
source for details.

Major ddd events:

April, 1995 ddd 0.9: Firstddd beta release.

May, 1995 ddd 1.0: First publicddd release.

December, 1995
ddd 1.4: Machine-level debugging, glyphs, Emacs integration.

October, 1996
ddd 2.0: Color displays,xdb support, genericdbx support, command tool.

May, 1997 ddd 2.1: Alias detection, button tips, status displays.

November, 1997
ddd 2.2: Sessions, display shortcuts.

June, 1998 ddd 3.0: Icon tool bar, Java support,jdb support.

December, 1998
ddd 3.1: Data plotting, Perl support, Python support, Undo/Redo.

January, 2000
ddd 3.2: New manual, Readline support, Ladebug support.

January, 2001
ddd 3.3: Data themes, JDB 1.2 support, VxWorks support.

November, 2002
ddd 3.3.2: Bash support.

March, 2003
ddd 3.3.3: Better Bash support. Compiles using modern tools thanks to Daniel Schep-
ler.
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1 A Sample DDD Session

You can use this manual at your leisure to read all aboutddd. However, a handful of features
are enough to get started using the debugger. This chapter illustrates those features.

The sample program ‘sample.c ’ (seeSection 1.1 [Sample Program], page 14) exhibits the fol-
lowing bug. Normally,sample should sort and print its arguments numerically, as in the following
example:

$ ./sample 8 7 5 4 1 3
1 3 4 5 7 8
$ _

However, with certain arguments, this goes wrong:

$ ./sample 8000 7000 5000 1000 4000
1000 1913 4000 5000 7000
$ _

Although the output is sorted and contains the right number of arguments, some arguments are
missing and replaced by bogus numbers; here,8000 is missing and replaced by1913 .1

Let us useddd to see what is going on. First, you must compile ‘sample.c ’ for debugging
(seeSection 4.1 [Compiling for Debugging], page 73), giving the ‘-g ’ flag while compiling:

$ gcc -g -o sample sample.c
$ _

Now, you can invokeddd (seeChapter 2 [Invocation], page 15) on thesample executable:

$ ddd sample

1 Actual numbers and behavior on your system may vary.
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After a few seconds,ddd comes up. TheSource Window contains the source of your debugged
program; use theScroll Bar to scroll through the file.

Source Window

Debugger Console

Status Line

Scroll Bar

Command Tool

Initial DDD Window

Argument Field

The Debugger Console (at the bottom) containsddd version information as well as agdb
prompt.1

GNU DDD Version 3.3.9, by Dorothea Lütkehaus and Andreas Zeller.
Copyright c© 1995-1999 Technische Universität Braunschweig, Germany.
Copyright c© 1999-2001 Universität Passau, Germany.
Copyright c© 2001-2004 Universität des Saarlandes, Germany.
Reading symbols from sample...done.
(gdb) _

The first thing to do now is to place aBreakpoint (seeSection 5.1 [Breakpoints], page 81),
making sample stop at a location you are interested in. Click on the blank space left to the
initialization ofa. TheArgument field ‘ (): ’ now contains the location (‘sample.c:31 ’). Now,
click on ‘Break ’ to create a breakpoint at the location in ‘() ’. You see a little red stop sign appear
in line 31.

1 Re-invokeddd with ‘ --gdb ’, if you do not see a ‘(gdb) ’ prompt here (seeSection 2.1.1 [Choosing an
Inferior Debugger], page 15)
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The next thing to do is to actuallyexecute the program, such that you can examine its behavior
(seeChapter 6 [Running], page 91). Select ‘Program ⇒ Run’ to execute the program; the ‘Run
Program ’ dialog appears.

Running the Program

Arguments

Breakpoint

Click here to run

In ‘Run with Arguments ’, you can now enter arguments for thesample program. Enter the
arguments resulting in erroneous behavior here—that is, ‘8000 7000 5000 1000 4000 ’. Click
on ‘Run’ to start execution with the arguments you just entered.

gdb now startssample . Execution stops after a few moments as the breakpoint is reached.
This is reported in the debugger console.

(gdb) break sample.c:31
Breakpoint 1 at 0x8048666: file sample.c, line 31.
(gdb) run 8000 7000 5000 1000 4000
Starting program: sample 8000 7000 5000 1000 4000

Breakpoint 1, main (argc=6, argv=0xbffff918) at sample.c:31
(gdb) _

The current execution line is indicated by a green arrow.
⇒ a = (int *)malloc((argc - 1) * sizeof(int));

You can now examine the variable values. To examine a simple variable, you can simply move
the mouse pointer on its name and leave it there. After a second, a small window with the variable
value pops up (seeSection 7.1 [Value Tips], page 105). Try this with ‘argc ’ to see its value (6).
The local variable ‘a’ is not yet initialized; you’ll probably see0x0 or some other invalid pointer
value.
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To execute the current line, click on the ‘Next ’ button on the command tool. The arrow ad-
vances to the following line. Now, point again on ‘a’ to see that the value has changed and that ‘a’
has actually been initialized.

Viewing Values in DDD

Execution Position

Value Tip

To examine the individual values of the ‘a’ array, enter ‘a[0] ’ in the argument field (you can
clear it beforehand by clicking on ‘(): ’) and then click on the ‘Print ’ button. This prints the
current value of ‘() ’ in the debugger console (seeSection 7.2 [Printing Values], page 106). In our
case, you’ll get

(gdb) print a[0]
$1 = 0
(gdb) _

or some other value (note that ‘a’ has only been allocated, but the contents have not yet been
initialized).

To see all members of ‘a’ at once, you must use a specialgdb operator. Since ‘a’ has been
allocated dynamically,gdb does not know its size; you must specify it explicitly using the ‘@’
operator (seeSection 7.3.2.1 [Array Slices], page 117). Enter ‘a[0]@(argc - 1) ’ in the argument
field and click on the ‘Print ’ button. You get the firstargc - 1 elements of ‘a’, or

(gdb) print a[0]@(argc - 1)
$2 = {0, 0, 0, 0, 0}
(gdb) _
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Rather than using ‘Print ’ at each stop to see the current value of ‘a’, you can alsodisplay
‘a’, such that its is automatically displayed. With ‘a[0]@(argc - 1) ’ still being shown in the
argument field, click on ‘Display ’. The contents of ‘a’ are now shown in a new window, theData
Window. Click on ‘Rotate ’ to rotate the array horizontally.

Data Window

Display Button

Data Window

Now comes the assignment of ‘a’’s members:
⇒ for (i = 0; i < argc - 1; i++)

a[i] = atoi(argv[i + 1]);

You can now click on ‘Next ’ and ‘Next ’ again to see how the individual members of ‘a’ are
being assigned. Changed members are highlighted.

To resume execution of the loop, use the ‘Until ’ button. This makesgdb execute the program
until a line greater than the current is reached. Click on ‘Until ’ until you end at the call of
‘shell_sort ’ in

⇒ shell_sort(a, argc);

At this point, ‘a’’s contents should be ‘8000 7000 5000 1000 4000 ’. Click again on ‘Next ’
to step over the call to ‘shell_sort ’. ddd ends in

⇒ for (i = 0; i < argc - 1; i++)
printf("%d ", a[i]);

and you see that after ‘shell_sort ’ has finished, the contents of ‘a’ are ‘1000, 1913, 4000,
5000, 7000 ’—that is, ‘shell_sort ’ has somehow garbled the contents of ‘a’.

To find out what has happened, execute the program once again. This time, you do not skip
through the initialization, but jump directly into the ‘shell_sort ’ call. Delete the old breakpoint
by selecting it and clicking on ‘Clear ’. Then, create a new breakpoint in line 35 before the call to
‘shell_sort ’. To execute the program once again, select ‘Program ⇒ Run Again ’.

Once more,ddd ends up before the call to ‘shell_sort ’:
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⇒ shell_sort(a, argc);

This time, you want to examine closer what ‘shell_sort ’ is doing. Click on ‘Step ’ to step
into the call to ‘shell_sort ’. This leaves your program in the first executable line, or

⇒ int h = 1;

while the debugger console tells us the function just entered:

(gdb) step
shell_sort (a=0x8049878, size=6) at sample.c:9
(gdb) _

This output that shows the function where ‘sample ’ is now suspended (and its arguments)
is called astack frame display. It shows a summary of the stack. You can use ‘Status ⇒
Backtrace ’ to see where you are in the stack as a whole; selecting a line (or clicking on ‘Up’ and
‘Down’) will let you move through the stack. Note how the ‘a’ display disappears when its frame
is left.

Backtrace

The DDD Backtrace

Let us now check whether ‘shell_sort ’’s arguments are correct. After returning to the lowest
frame, enter ‘a[0]@size ’ in the argument field and click on ‘Print ’:

(gdb) print a[0] @ size
$4 = {8000, 7000, 5000, 1000, 4000, 1913}
(gdb) _

Surprise! Where does this additional value1913 come from? The answer is simple: The array
size as passed in ‘size ’ to ‘ shell_sort ’ is too large by one—1913 is a bogus value which
happens to reside in memory after ‘a’. And this last value is being sorted in as well.

To see whether this is actually the problem cause, you can now assign the correct value to ‘size ’
(seeSection 7.3.3 [Assignment], page 119). Select ‘size ’ in the source code and click on ‘Set ’.
A dialog pops up where you can edit the variable value.
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Select variable in the source

Set Button

Edit value

Setting a Value

Change the value of ‘size ’ to 5 and click on ‘OK’. Then, click on ‘Finish ’ to resume execu-
tion of the ‘shell_sort ’ function:

(gdb) set variable size = 5
(gdb) finish
Run till exit from #0 shell_sort (a=0x8049878, size=5) at sample.c:9
0x80486ed in main (argc=6, argv=0xbffff918) at sample.c:35
(gdb) _
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Success! The ‘a’ display now contains the correct values ‘1000, 4000, 5000, 7000,
8000 ’.

Changed values

Changed Values after Setting

You can verify that these values are actually printed to standard output by further executing the
program. Click on ‘Cont ’ to continue execution.

(gdb) cont
1000 4000 5000 7000 8000

Program exited normally.
(gdb) _

The message ‘Program exited normally. ’ is from gdb; it indicates that thesample
program has finished executing.

Having found the problem cause, you can now fix the source code. Click on ‘Edit ’ to edit
‘sample.c ’, and change the line

shell_sort(a, argc);

to the correct invocation
shell_sort(a, argc - 1);

You can now recompilesample

$ gcc -g -o sample sample.c
$ _

and verify (via ‘Program ⇒ Run Again ’) that sample works fine now.
(gdb) run
‘sample’ has changed; re-reading symbols.
Reading in symbols...done.
Starting program: sample 8000 7000 5000 1000 4000
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1000 4000 5000 7000 8000

Program exited normally.
(gdb) _

All is done; the program works fine now. You can end thisddd session with ‘Program ⇒
Exit ’ or Ctrl +Q.
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1.1 Sample Program

Here’s the source ‘sample.c ’ of the sample program.� �
/* sample.c -- Sample C program to be debugged with ddd

*/

#include <stdio.h>
#include <stdlib.h>

static void shell_sort(int a[], int size)
{

int i, j;
int h = 1;
do {

h = h * 3 + 1;
} while (h <= size);
do {

h /= 3;
for (i = h; i < size; i++)
{

int v = a[i];
for (j = i; j >= h && a[j - h] > v; j -= h)

a[j] = a[j - h];
if (i != j)

a[j] = v;
}

} while (h != 1);
}

int main(int argc, char *argv[])
{

int *a;
int i;

a = (int *)malloc((argc - 1) * sizeof(int));
for (i = 0; i < argc - 1; i++)

a[i] = atoi(argv[i + 1]);

shell_sort(a, argc);

for (i = 0; i < argc - 1; i++)
printf("%d ", a[i]);

printf("\n");

free(a);
return 0;

}
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2 Getting In and Out of DDD

This chapter discusses how to startddd, and how to get out of it. The essentials are:

• Type ‘ddd ’ to startddd (seeSection 2.1 [Invoking], page 15).

• Use ‘File ⇒ Exit ’ or Ctrl +Qto exit (seeSection 2.2 [Quitting], page 28).

2.1 Invoking DDD

Normally, you can runddd by invoking the programddd .

You can also runddd with a variety of arguments and options, to specify more of your debug-
ging environment at the outset.

The most usual way to startddd is with one argument, specifying an executable program:

ddd program
If you usegdb, dbx, Ladebug, orxdb as inferior debuggers, you can also start with both an
executable program and a core file specified:

ddd program core
You can, instead, specify a process ID as a second argument, if you want to debug a running

process:

ddd program 1234

would attachddd to process1234 (unless you also have a file named ‘1234 ’; ddd does check for
a core file first).

You can further controlddd by invoking it with specificoptions. To get a list ofddd options,
invokeddd as

ddd --help

Most important are the options to specify the inferior debugger (seeSection 2.1.1 [Choosing an
Inferior Debugger], page 15), but you can also customize several aspects ofddd upon invocation
(seeSection 2.1.2 [Options], page 16).

ddd also understands the usual X options such as ‘-display ’ or ‘ -geometry ’. SeeSec-
tion 2.1.3 [X Options], page 24, for details.

All arguments and options that are not understood byddd are passed to the inferior debug-
ger; SeeSection 2.1.4 [Inferior Debugger Options], page 24, for a survey. To pass an option to
the inferior debugger that conflicts with an X option, or with addd option listed here, use the
‘ --debugger ’ option (seeSection 2.1.2 [Options], page 16).

2.1.1 Choosing an Inferior Debugger

The most frequently required options are those to choose a specific inferior debugger.

Normally, the inferior debugger is determined by the program to analyze:

• If the program requires a specific interpreter, such as Java, Python, Perl or Bash, then you
should use ajdb, pydb, Perl, or Bash inferior debugger.

Use

ddd --jdb program
ddd --pydb program
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ddd --perl program
ddd --bash program
ddd --interpreter=’ path-to-debugger-bash--debugger’ program

to runddd with jdb, pydb, Perl, or Bash as an inferior debugger.

• If the program is an executable binary, you should usegdb, dbx, Ladebug, orxdb. In general,
gdb (or its HP variant,wdb) provides the most functionality of these debuggers.

Use

ddd --gdb program
ddd --wdb program
ddd --dbx program
ddd --ladebug program
ddd --xdb program

to runddd with gdb, wdb, dbx, Ladebug, orxdb as inferior debugger.

If you invokeddd without any of these options, but give aprogram to analyze, thenddd will
automatically determine the inferior debugger:

• If program is a Python program, a Perl script, or a Java class,ddd will invoke the appropriate
debugger.

• If program is an executable binary,ddd will invoke its default debugger for executables (usu-
ally gdb).

SeeSection 2.5 [Customizing Debugger Interaction], page 34, for more details on determining
the inferior debugger.

2.1.2 DDD Options

You can further control howddd starts up using the following options. All options may be
abbreviated, as long as they are unambiguous; single dashes ‘- ’ instead of double dashes ‘-- ’ may
also be used. Almost all options control a specificddd resource or resource class (seeSection 3.6
[Customizing], page 60).

‘ --attach-windows ’
Attach the source and data windows to the debugger console, creating one single big
ddd window. This is the default setting.

Giving this option is equivalent to setting theddd ‘Separate ’ resource class to
‘off ’. SeeSection 3.6.4.2 [Window Layout], page 65, for details.

‘ --attach-source-window ’
Attach only the source window to the debugger console.

Giving this option is equivalent to setting theddd ‘separateSourceWindow ’
resource to ‘off ’. SeeSection 3.6.4.2 [Window Layout], page 65, for details.

‘ --attach-data-window ’
Attach only the source window to the debugger console.

Giving this option is equivalent to setting theddd ‘separateDataWindow ’ re-
source to ‘off ’. SeeSection 3.6.4.2 [Window Layout], page 65, for details.
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‘ --automatic-debugger ’
Determine the inferior debugger automatically from the given arguments.

Giving this option is equivalent to setting theddd ‘autoDebugger ’ resource to
‘on ’. SeeSection 2.5 [Customizing Debugger Interaction], page 34, for details.

‘ --button-tips ’
Enable button tips.

Giving this option is equivalent to setting theddd ‘buttonTips ’ resource to ‘on ’.
SeeSection 3.6.2 [Customizing Help], page 61, for details.

‘ --configuration ’
Print theddd configuration settings on standard output and exit.

Giving this option is equivalent to setting theddd ‘showConfiguration ’ resource
to ‘on ’. SeeSection B.5 [Diagnostics], page 170, for details.

‘ --check-configuration ’
Check theddd environment (in particular, the X configuration), report any possible
problem causes and exit.

Giving this option is equivalent to setting theddd ‘checkConfiguration ’ re-
source to ‘on ’. SeeSection B.5 [Diagnostics], page 170, for details.

‘ --data-window ’
Open the data window upon start-up.

Giving this option is equivalent to setting theddd ‘openDataWindow ’ resource to
‘on ’. SeeSection 3.6.4.4 [Toggling Windows], page 70, for details.

‘ --dbx ’ Run dbx as inferior debugger.

Giving this option is equivalent to setting theddd ‘debugger ’ resource to ‘dbx ’.
SeeSection 2.5 [Customizing Debugger Interaction], page 34, for details.

‘ --debugger name ’
Invoke the inferior debuggername. This is useful if you have several debugger versions
around, or if the inferior debugger cannot be invoked under its usual name (i.e.gdb ,
wdb, dbx , xdb , jdb , pydb , or perl ).

This option can also be used to pass options to the inferior debugger that would oth-
erwise conflict withddd options. For instance, to pass the option ‘-d directory ’ to
xdb, use:

ddd --debugger "xdb -d directory"

If you use the ‘--debugger ’ option, be sure that the type of inferior debugger
is specified as well. That is, use one of the options ‘--gdb ’, ‘ --dbx ’, ‘ --xdb ’,
‘ --jdb ’, ‘ --pydb ’, or ‘ --perl ’ (unless the default setting works fine).

Giving this option is equivalent to setting theddd ‘debuggerCommand ’ resource
to name. SeeSection 2.5 [Customizing Debugger Interaction], page 34, for details.

‘ --debugger-console ’
Open the debugger console upon start-up.

Giving this option is equivalent to setting theddd ‘openDebuggerConsole ’ re-
source to ‘on ’. SeeSection 3.6.4.4 [Toggling Windows], page 70, for details.
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‘ --disassemble ’
Disassemble the source code. See also the ‘--no-disassemble ’ option, below.

Giving this option is equivalent to setting theddd ‘disassemble ’ resource to ‘on ’.
SeeSection 4.4 [Customizing Source], page 77, for details.

‘ --exec-window ’
Run the debugged program in a specially created execution window. This is useful
for programs that have special terminal requirements not provided by the debugger
window, as raw keyboard processing or terminal control sequences. SeeSection 6.2
[Using the Execution Window], page 93, for details.

Giving this option is equivalent to setting theddd ‘separateExecWindow ’ re-
source to ‘on ’. SeeSection 6.2.1 [Customizing the Execution Window], page 94, for
details.

‘ --font fontname ’
‘ -fn fontname ’

Usefontname as default font.

Giving this option is equivalent to setting theddd ‘defaultFont ’ resource to
‘ fontname ’. SeeSection 3.6.4.3 [Customizing Fonts], page 67, for details.

‘ --fonts ’
Show the font definitions used byddd on standard output.

Giving this option is equivalent to setting theddd ‘showFonts ’ resource to ‘on ’.
SeeSection B.5 [Diagnostics], page 170, for details.

‘ --fontsize size ’
Set the default font size tosize (in 1/10 points). To makeddd use 12-point fonts, say
‘ --fontsize 120 ’.

Giving this option is equivalent to setting theddd ‘FontSize ’ resource class to
‘size ’. SeeSection 3.6.4.3 [Customizing Fonts], page 67, for details.

‘ --fullname ’
‘ -f ’ Enable thetty interface, taking additional debugger commands from standard input

and forwarding debugger output on standard output. Current positions are issued in
gdb ‘ -fullname ’ format suitable for debugger front-ends. By default, both the
debugger console and source window are disabled. SeeSection 10.2 [TTY mode],
page 150, for a discussion.

Giving this option is equivalent to setting theddd ‘TTYMode’ resource class to ‘on ’.
SeeSection 10.2 [TTY mode], page 150, for details.

‘ --gdb ’ Run gdb as inferior debugger.

Giving this option is equivalent to setting theddd ‘debugger ’ resource to ‘gdb ’.
SeeSection 2.5 [Customizing Debugger Interaction], page 34, for details.

‘ --glyphs ’
Display the current execution position and breakpoints as glyphs. See also the
‘ --no-glyphs ’ option, below.

Giving this option is equivalent to setting theddd ‘displayGlyphs ’ resource to
‘on ’. SeeSection 4.4 [Customizing Source], page 77, for details.
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‘ --help ’
‘ -h ’
‘ -? ’ Give a list of frequently used options. Show options of the inferior debugger as well.

Giving this option is equivalent to setting theddd ‘showInvocation ’ resource to
‘on ’. SeeSection B.5 [Diagnostics], page 170, for details.

‘ --host hostname ’
‘ --host username@hostname ’

Invoke the inferior debugger directly on the remote hosthostname. If username is
given and the ‘--login ’ option is not used, useusername as remote user name. See
Section 2.4.2 [Remote Debugger], page 32, for details.

Giving this option is equivalent to setting theddd ‘debuggerHost ’ resource to
hostname. SeeSection 2.4.2 [Remote Debugger], page 32, for details.

‘ --jdb ’ Run jdb as inferior debugger.

Giving this option is equivalent to setting theddd ‘debugger ’ resource to ‘gdb ’.
SeeSection 2.5 [Customizing Debugger Interaction], page 34, for details.

‘ --ladebug ’
Run Ladebug as inferior debugger.

Giving this option is equivalent to setting theddd ‘debugger ’ resource to
‘ ladebug ’. See Section 2.5 [Customizing Debugger Interaction], page 34, for
details.

‘ --lesstif-hacks ’
Equivalent to ‘--lesstif-version 999 ’. Deprecated.

Giving this option is equivalent to setting theddd ‘ lessTifVersion ’ resource to
999 . SeeSection C.8 [LessTif], page 179, for details.

‘ --lesstif-version version ’
Enable some hacks to makeddd run properly with LessTif. SeeSection C.8 [LessTif],
page 179, for a discussion.

Giving this option is equivalent to setting theddd ‘ lessTifVersion ’ resource to
version. SeeSection C.8 [LessTif], page 179, for details.

‘ --license ’
Print theddd license on standard output and exit.

Giving this option is equivalent to setting theddd ‘showLicense ’ resource toon.
SeeSection B.5 [Diagnostics], page 170, for details.

‘ --login username ’
‘ -l username ’

Useusername as remote user name. SeeSection 2.4.2 [Remote Debugger], page 32,
for details.

Giving this option is equivalent to setting theddd ‘debuggerHostLogin ’ resource
to username. SeeSection 2.4.2 [Remote Debugger], page 32, for details.

‘ --maintenance ’
Enable the top-level ‘Maintenance ’ menu with options for debuggingddd. See
Section 3.1.9 [Maintenance Menu], page 49, for details.
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Giving this option is equivalent to setting theddd ‘maintenance ’ resource toon.
SeeSection 3.1.9 [Maintenance Menu], page 49, for details.

‘ --manual ’
Print theddd manual on standard output and exit.

Giving this option is equivalent to setting theddd ‘showManual ’ resource toon.
SeeSection B.5 [Diagnostics], page 170, for details.

‘ --news ’ Print theddd news on standard output and exit.

Giving this option is equivalent to setting theddd ‘showNews’ resource toon. See
Section B.5 [Diagnostics], page 170, for details.

‘ --no-button-tips ’
Disable button tips.

Giving this option is equivalent to setting theddd ‘buttonTips ’ resource to ‘off ’.
SeeSection 3.6.2 [Customizing Help], page 61, for details.

‘ --no-data-window ’
Do not open the data window upon start-up.

Giving this option is equivalent to setting theddd ‘openDataWindow ’ resource to
‘off ’. SeeSection 3.6.4.4 [Toggling Windows], page 70, for details.

‘ --no-debugger-console ’
Do not open the debugger console upon start-up.

Giving this option is equivalent to setting theddd ‘openDebuggerConsole ’ re-
source to ‘off ’. SeeSection 3.6.4.4 [Toggling Windows], page 70, for details.

‘ --no-disassemble ’
Do not disassemble the source code.

Giving this option is equivalent to setting theddd ‘disassemble ’ resource to
‘off ’. SeeSection 4.4 [Customizing Source], page 77, for details.

‘ --no-exec-window ’
Do not run the debugged program in a specially created execution window; use the
debugger console instead. Useful for programs that have little terminal input/output,
or for remote debugging. SeeSection 6.2 [Using the Execution Window], page 93, for
details.

Giving this option is equivalent to setting theddd ‘separateExecWindow ’ re-
source to ‘off ’. SeeSection 6.2.1 [Customizing the Execution Window], page 94, for
details.

‘ --no-glyphs ’
Do not use glyphs; display the current execution position and breakpoints as text char-
acters.

Giving this option is equivalent to setting theddd ‘displayGlyphs ’ resource to
‘off ’. SeeSection 4.4 [Customizing Source], page 77, for details.

‘ --no-lesstif-hacks ’
Equivalent to ‘--lesstif-version 1000 ’. Deprecated.

Giving this option is equivalent to setting theddd ‘ lessTifVersion ’ resource to
1000 . SeeSection C.8 [LessTif], page 179, for details.
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‘ --no-maintenance ’
Do not enable the top-level ‘Maintenance ’ menu with options for debuggingddd.
This is the default. SeeSection 3.1.9 [Maintenance Menu], page 49, for details.

Giving this option is equivalent to setting theddd ‘maintenance ’ resource tooff.
SeeSection 3.1.9 [Maintenance Menu], page 49, for details.

‘ --no-source-window ’
Do not open the source window upon start-up.

Giving this option is equivalent to setting theddd ‘openSourceWindow ’ resource
to ‘off ’. SeeSection 3.6.4.4 [Toggling Windows], page 70, for details.

‘ --no-value-tips ’
Disable value tips.

Giving this option is equivalent to setting theddd ‘valueTips ’ resource to ‘off ’.
SeeSection 7.1 [Value Tips], page 105, for details.

‘ --nw ’ Do not use the X window interface. Start the inferior debugger on the local host.

‘ --perl ’ Run Perl as inferior debugger.

Giving this option is equivalent to setting theddd ‘debugger ’ resource to ‘perl ’.
SeeSection 2.5 [Customizing Debugger Interaction], page 34, for details.

‘ --pydb ’ Run pydb as inferior debugger.

Giving this option is equivalent to setting theddd ‘debugger ’ resource to ‘pydb ’.
SeeSection 2.5 [Customizing Debugger Interaction], page 34, for details.

‘ --panned-graph-editor ’
Use an Athena panner to scroll the data window. Most people prefer panners on
scroll bars, since panners allow two-dimensional scrolling. However, the panner is
off by default, since some M*tif implementations do not work well with Athena
widgets. SeeSection 7.3.5.5 [Display Resources], page 128, for details; see also
‘ --scrolled-graph-editor ’, below.

Giving this option is equivalent to setting theddd ‘pannedGraphEditor ’ resource
to ‘on ’. SeeSection 7.3.5.5 [Display Resources], page 128, for details.

‘ --play-log log-file ’
Recapitulate a previousddd session.

ddd --play-log log-file

invokesddd as inferior debugger, simulating the inferior debugger given inlog-file
(see below). This is useful for debuggingddd.

Giving this option is equivalent to setting theddd ‘playLog ’ resource to ‘on ’. See
Section 2.5 [Customizing Debugger Interaction], page 34, for details.

‘ --PLAY log-file ’
Simulate an inferior debugger.log-file is a ‘~/.ddd/log ’ file as generated by some
previousddd session (seeSection B.5.1 [Logging], page 170). When a command is
entered, scanlog-file for this command and re-issue the logged reply; if the command
is not found, do nothing. This is used by the ‘--play ’ option.
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‘ --rhost hostname ’
‘ --rhost username@hostname ’

Run the inferior debugger interactively on the remote hosthostname. If username is
given and the ‘--login ’ option is not used, useusername as remote user name. See
Section 2.4.2 [Remote Debugger], page 32, for details.

Giving this option is equivalent to setting theddd ‘debuggerRHost ’ resource to
hostname. SeeSection 2.4.2 [Remote Debugger], page 32, for details.

‘ --scrolled-graph-editor ’
Use M*tif scroll bars to scroll the data window. This is the default in mostddd
configurations. SeeSection 7.3.5.5 [Display Resources], page 128, for details; see
also ‘--panned-graph-editor ’, above.

Giving this option is equivalent to setting theddd ‘pannedGraphEditor ’ resource
to ‘off ’. SeeSection 7.3.5.5 [Display Resources], page 128, for details.

‘ --separate-windows ’
‘ --separate ’

Separate the console, source and data windows. See also the ‘--attach ’ options,
above.

Giving this option is equivalent to setting theddd ‘Separate ’ resource class to
‘off ’. SeeSection 3.6.4.2 [Window Layout], page 65, for details.

‘ --session session ’
Load session upon start-up. SeeSection 2.3.2 [Resuming Sessions], page 30, for
details.

Giving this option is equivalent to setting theddd ‘session ’ resource tosession.
SeeSection 2.3.2 [Resuming Sessions], page 30, for details.

‘ --source-window ’
Open the source window upon start-up.

Giving this option is equivalent to setting theddd ‘openSourceWindow ’ resource
to ‘on ’. SeeSection 3.6.4.4 [Toggling Windows], page 70, for details.

‘ --status-at-bottom ’
Place the status line at the bottom of the source window.

Giving this option is equivalent to setting theddd ‘statusAtBottom ’ resource to
‘on ’. SeeSection 3.6.4.2 [Window Layout], page 65, for details.

‘ --status-at-top ’
Place the status line at the top of the source window.

Giving this option is equivalent to setting theddd ‘statusAtBottom ’ resource to
‘off ’. SeeSection 3.6.4.2 [Window Layout], page 65, for details.

‘ --sync-debugger ’
Do not process X events while the debugger is busy. This may result in slightly better
performance on single-processor systems.

Giving this option is equivalent to setting theddd ‘synchronousDebugger ’ re-
source to ‘on ’. SeeSection 2.5 [Customizing Debugger Interaction], page 34, for
details.
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‘ --toolbars-at-bottom ’
Place the toolbars at the bottom of the respective window.

Giving this option is equivalent to setting theddd ‘ toolbarsAtBottom ’ resource
to ‘on ’. SeeSection 3.6.4.2 [Window Layout], page 65, for details.

‘ --toolbars-at-top ’
Place the toolbars at the top of the respective window.

Giving this option is equivalent to setting theddd ‘ toolbarsAtBottom ’ resource
to ‘off ’. SeeSection 3.6.4.2 [Window Layout], page 65, for details.

‘ --trace ’
Show the interaction betweenddd and the inferior debugger on standard error. This is
useful for debuggingddd. If ‘ --trace ’ is not specified, this information is written
into ‘~/.ddd/log ’ (‘ ~’ stands for your home directory), such that you can also do
a post-mortem debugging. SeeSection B.5.1 [Logging], page 170, for details about
logging.

Giving this option is equivalent to setting theddd ‘ trace ’ resource toon. SeeSec-
tion B.5 [Diagnostics], page 170, for details.

‘ --tty ’
‘ -t ’ Enabletty interface, taking additional debugger commands from standard input and

forwarding debugger output on standard output. Current positions are issued in a for-
mat readable for humans. By default, the debugger console is disabled.

Giving this option is equivalent to setting theddd ‘ ttyMode ’ resource to ‘on ’. See
Section 10.2 [TTY mode], page 150, for details.

‘ --value-tips ’
Enable value tips.

Giving this option is equivalent to setting theddd ‘valueTips ’ resource to ‘on ’.
SeeSection 7.1 [Value Tips], page 105, for details.

‘ --version ’
‘ -v ’ Print theddd version on standard output and exit.

Giving this option is equivalent to setting theddd ‘showVersion ’ resource to ‘on ’.
SeeSection B.5 [Diagnostics], page 170, for details.

‘ --vsl-library library ’
Load thevsl library library instead of using theddd built-in library. This is useful
for customizing display shapes and fonts.

Giving this option is equivalent to setting theddd ‘vslLibrary ’ resource tolibrary.
SeeSection 7.3.5.6 [VSL Resources], page 128, for details.

‘ --vsl-path path ’
Searchvsl libraries inpath (a colon-separated directory list).

Giving this option is equivalent to setting theddd ‘vslPath ’ resource topath. See
Section 7.3.5.6 [VSL Resources], page 128, for details.

‘ --vsl-help ’
Show a list of further options controlling thevsl interpreter. These options are in-
tended for debugging purposes and are subject to change without further notice.
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‘ --wdb ’ Run wdb as inferior debugger.

Giving this option is equivalent to setting theddd ‘debugger ’ resource to ‘wdb’.
SeeSection 2.5 [Customizing Debugger Interaction], page 34, for details.

‘ --xdb ’ Run xdb as inferior debugger.

Giving this option is equivalent to setting theddd ‘debugger ’ resource to ‘xdb ’.
SeeSection 2.5 [Customizing Debugger Interaction], page 34, for details.

2.1.3 X Options

ddd also understands the following X options. Note that these options only take a single dash
‘ - ’.

‘ -display display ’
Use the X serverdisplay. By default,display is taken from theDISPLAY environment
variable.

‘ -geometry geometry ’
Specify the initial size and location of the debugger console.

‘ -iconic ’
Startddd iconified.

‘ -name name ’
Giveddd the namename.

‘ -selectionTimeout timeout ’
Specify the timeout in milliseconds within which two communicating applications
must respond to one another for a selection request.

‘ -title name ’
Give theddd window the titlename.

‘ -xrm resourcestring ’
Specify a resource name and value to override any defaults.

2.1.4 Inferior Debugger Options

All options thatddd does not recognize are passed to the inferior debugger. This section lists
the most useful options of the different inferior debuggers supported byddd. In case these options
do not work as expected, please lookup the appropriate reference.

2.1.4.1 GDB Options

Thesegdb options are useful when usingddd with gdb as inferior debugger. Single dashes
‘ - ’ instead of double dashes ‘-- ’ may also be used.

‘ -b baudrate ’
Set serial port baud rate used for remote debugging.

‘ --cd dir ’ Change current directory todir.

‘ --command file ’
Executegdb commands fromfile.
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‘ --core corefile ’
Analyze the core dumpcorefile.

‘ --directory dir ’
‘ -d dir ’ Add directory to the path to search for source files.

‘ --exec execfile ’
Useexecfile as the executable.

‘ --mapped ’
Use mapped symbol files if supported on this system.

‘ --nx ’

‘ -n ’ Do not read ‘.gdbinit ’ file.

‘ --readnow ’
Fully read symbol files on first access.

‘ --se file ’
Usefile as symbol file and executable file.

‘ --symbols symfile ’
Read symbols fromsymfile.

Seesection “Invoking GDB” inDebugging with GDB , for further options that can be used with
gdb.

2.1.4.2 DBX and Ladebug Options

dbx variants differ widely in their options, so we cannot give a list here. Check out thedbx(1)
andladebug(1) manual pages.

2.1.4.3 XDB Options

Thesexdb options are useful when usingddd with xdb as inferior debugger.

‘ -d dir ’ Specify dir as an alternate directory where source files are located.

‘ -P process-id ’
Specify the process ID of an existing process the user wants to debug.

‘ -l library ’
Pre-load information about the shared librarylibrary. ‘-l ALL ’ means always pre-
load shared library information.

‘ -S num ’ Set the size of the string cache tonum bytes (default is 1024, which is also the mini-
mum).

‘ -s ’ Enable debugging of shared libraries.

Further options can be found in thexdb(1) manual page.

2.1.4.4 JDB Options
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JDB as of JDK 1.2

The following jdb options are useful when usingddd with jdb (from jdk 1.2) as inferior
debugger.

‘ -attach address ’
attach to a running virtual machine (VM) ataddress using standard connector

‘ -listen address ’
wait for a running VM to connect ataddress using standard connector

‘ -listenany ’
wait for a running VM to connect at any available address using standard connector

‘ -launch ’
launch VM immediately instead of waiting for ‘run ’ command

Thesejdb options are forwarded to the debuggee:

‘ -verbose[:class|gc|jni] ’
‘ -v ’ Turn on verbose mode.

‘ -D name=value ’
Set the system propertyname to value.

‘ -classpath path ’
List directories in which to look for classes.path is a list of directories separated by
colons.

‘ -X option ’
Non-standard target VM option

JDB as of JDK 1.1

The following jdb options are useful when usingddd with jdb (from jdk 1.1) as inferior
debugger.

‘ -host hostname ’
host machine of interpreter to attach to

‘ -password psswd ’
password of interpreter to attach to (from ‘-debug ’)

Thesejdb options are forwarded to the debuggee:

‘ -verbose ’
‘ -v ’ Turn on verbose mode.

‘ -debug ’ Enable remote Java debugging,

‘ -noasyncgc ’
Don’t allow asynchronous garbage collection.

‘ -verbosegc ’
Print a message when garbage collection occurs.
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‘ -noclassgc ’
Disable class garbage collection.

‘ -checksource ’
‘ -cs ’ Check if source is newer when loading classes.

‘ -ss number ’
Set the maximum native stack size for any thread.

‘ -oss number ’
Set the maximum Java stack size for any thread.

‘ -ms number ’
Set the initial Java heap size.

‘ -mx number ’
Set the maximum Java heap size.

‘ -D name=value ’
Set the system propertyname to value.

‘ -classpath path ’
List directories in which to look for classes.path is a list of directories separated by
colons.

‘ -prof ’
‘ -prof: file ’

Output profiling data to ‘./java.prof ’. If file is given, write the data to ‘./ file ’.

‘ -verify ’
Verify all classes when read in.

‘ -verifyremote ’
Verify classes read in over the network (default).

‘ -noverify ’
Do not verify any class.

‘ -dbgtrace ’
Print info for debuggingjdb.

Further options can be found in thejdb documentation.

2.1.4.5 PYDB Options

For a list of usefulpydb options, check out thepydb documentation.

2.1.4.6 Perl Options

The most important Perl option to use withddd is ‘-w ’; it enables several important warnings.
For further options, see theperlrun(1) manual page.

2.1.4.7 Bash Options

If you have the proper bash installed, the option needed to specify debugging support is
‘ --debugger ’. (If your bash doesn’t understand this option you need to pick up a version of
bash that does fromhttp://bashdb.sourceforge.net .)

http://bashdb.sourceforge.net
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2.1.5 Multiple DDD Instances

If you have multipleddd instances running, they share common preferences and history files.
This means that changes applied to one instance may get lost when being overwritten by the other in-
stance.ddd has two means to protect you against unwanted losses. The first means is an automatic
reloading of changed options, controlled by the following resource (seeSection 3.6 [Customizing],
page 60):

ResourcecheckOptions (class CheckOptions)
Everyn seconds, wheren is the value of this resource,ddd checks whether the options file
has changed. Default is30 , which means that every 30 seconds,ddd checks for the options
file. Setting this resource to0 disables checking for changed option files.

Normally, automatic reloading of options should already suffice. If you need stronger protection,
ddd also provides a warning against multiple instances. This warning is disabled by default, If you
want to be warned about multipleddd invocations sharing the same preferences and history files,
enable ‘Edit ⇒ Preferences ⇒Warn if Multiple ddd Instances are Running ’.

This setting is tied to the following resource (seeSection 3.6 [Customizing], page 60):

ResourcewarnIfLocked (class WarnIfLocked)
Whether to warn if multipleddd instances are running (‘on ’) or not (‘off ’, default).

2.1.6 X warnings

If you are bothered by X warnings, you can suppress them by setting ‘Edit ⇒ Preferences
⇒ General ⇒ Suppress X warnings ’.

This setting is tied to the following resource (seeSection 3.6 [Customizing], page 60):

ResourcesuppressWarnings (class SuppressWarnings)
If ‘ on ’, X warnings are suppressed. This is sometimes useful for executables that were built
on a machine with a different X or M*tif configuration. By default, this is ‘off ’.

2.2 Quitting DDD

To exit ddd, select ‘File ⇒ Exit ’. You may also type thequit command at the debugger
prompt or press〈Ctrl+Q〉. gdb andxdb also accept theq command or an end-of-file character
(usually〈Ctrl+D〉). Closing the lastddd window will also exitddd.

An interrupt (〈ESC〉 or ‘Interrupt ’) does not exit fromddd, but rather terminates the action
of any debugger command that is in progress and returns to the debugger command level. It is safe
to type the interrupt character at any time because the debugger does not allow it to take effect until
a time when it is safe.

In case an ordinary interrupt does not succeed, you can also use an abort (〈Ctrl+\ 〉 or ‘Abort ’),
which sends aSIGABRTsignal to the inferior debugger. Use this in emergencies only; the inferior
debugger may be left inconsistent or even exit after aSIGABRTsignal.

As a last resort (ifddd hangs, for example), you may also interruptddd itself using an interrupt
signal (SIGINT ). This can be done by typing the interrupt character (usually〈Ctrl+C〉) in the shell
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ddd was started from, or by using theunix ‘kill ’ command. An interrupt signal interrupts any
ddd action; the inferior debugger is interrupted as well. Since this interrupt signal can result in
internal inconsistencies, use this as a last resort in emergencies only; save your work as soon as
possible and restartddd.

2.3 Persistent Sessions

If you want to interrupt your currentddd session, you can save the entire the entireddd state
assession on disk and resume later.

2.3.1 Saving Sessions

To save a session, select ‘File ⇒ Save Session As ’. You will be asked for a symbolic
session namesession.

If your program is running (seeChapter 6 [Running], page 91), or if you have opened a core
file (seeSection 4.2.2 [Opening Core Dumps], page 74), ddd can also include a core file in the
session such that the debuggee data will be restored when re-opening it. To get a core file,ddd
typically mustkill the debuggee. This means that you cannot resume program execution after
saving a session. Depending on your architecture, other options for getting a core file may also be
available.

Including a core dump is necessary for restoring memory contents and the current execution
position. To include a core dump, enable ‘Include Core Dump ’.

Program Data
Set to save

Saving a Session

Default session

Saved sessions

Click to save

After clicking on ‘Save ’, the session is saved in ‘~/.ddd/sessions/ session ’.

Here’s a list of the items whose state is saved in a session:

• The state of the debugged program, as a core file.1

1 Only if a core file is included.
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• All breakpoints and watchpoints (seeChapter 5 [Stopping], page 81).

• All signal settings (seeSection 6.10 [Signals], page 102).

• All displays (seeSection 7.3 [Displaying Values], page 107).2

• All ddd options (seeSection 3.6.1.3 [Saving Options], page 61).

• All debugger settings (seeSection 3.6.5 [Debugger Settings], page 71).

• All user-defined buttons (seeSection 10.4 [Defining Buttons], page 151).

• All user-defined commands (seeSection 10.5 [Defining Commands], page 154).

• The positions and sizes ofddd windows.

• The command history (seeSection 10.1.2 [Command History], page 148).

After saving the current state as a session, the session becomesactive. This means thatddd
state will be saved as session defaults:

• User options will be saved in ‘~/.ddd/sessions/ session/init ’ instead of
‘~/.ddd/init ’. SeeSection 3.6.1.3 [Saving Options], page 61, for details.

• Theddd command history will be saved in ‘~/.ddd/sessions/ session/history ’ in-
stead of ‘~/.ddd/history ’. SeeSection 10.1.2 [Command History], page 148, for details.

To make the current session inactive, open thedefault sessionnamed ‘[None] ’. See Sec-
tion 2.3.2 [Resuming Sessions], page 30, for details on opening sessions.

2.3.2 Resuming Sessions

To resume a previously saved session, select ‘File ⇒ Open Session ’ and choose a session
name from the list. After clicking on ‘Open’, the entireddd state will be restored from the given
session.

The session named ‘[None] ’ is thedefault session which is active when startingddd. To save
options for default sessions, choose the default session before exitingddd. SeeSection 3.6.1.3
[Saving Options], page 61, for details.

2 If a core file isnot to be included in the session,ddd data displays are saved asdeferred; that is, they
will be restored as soon as program execution reaches the scope in which they were created. SeeSec-
tion 7.3.1.1 [Creating Single Displays], page 107, for details.
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Click to open

Saved sessions

Opening a Session

Default session

If a the restored session includes a core dump, the program being debugged will be in the same
state at the time the session was saved; in particular, you can examine the program data. However,
you will not be able to resume program execution since the process and its environment (open
files, resources, etc.) no longer exist. However, you can restart the program, re-using the restored
breakpoints and data displays.

Opening sessions also restores command definitions, buttons, display shortcuts and the source
tab width. This way, you can maintain a different set of definitions for each session.

You can also specify a session to open when startingddd. To invokeddd with a sessionsession,
use

ddd --session session

There is also a shortcut that opens the sessionsession and invokes the inferior debugger on an
executable namedsession (in casesession cannot be opened):

ddd = session

There is no need to give further command-line options when restarting a session, as they will be
overridden by the options saved in the session.

You can also use an X session manager such asxsm to save and restoreddd sessions.3 When
being shut down by a session manager,ddd saves its state under the name specified by the session
manager; resuming the X session makesddd reload its saved state.

2.3.3 Deleting Sessions

To delete sessions that are no longer needed, select ‘File ⇒ Open Session ’ or ‘ File ⇒
Save Session ’. Select the sessions you want to delete and click on ‘Delete ’.

The default session ‘[None] ’ cannot be deleted.

3 Requires X11R6 or later.
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2.3.4 Customizing Sessions

You can change the place whereddd saves its sessions by setting the environment variable
DDD_SESSIONSto the name of a directory. Default is ‘~/.ddd/sessions/ ’.

Where applicable,ddd supports agcore command to obtain core files of the running program.
You can enter its path via ‘Edit ⇒ Preferences ⇒ Helpers ⇒ Get Core File ’. Leave
the value empty if you have nogcore or similar command.

This setting is tied to the following resource (seeSection 3.6 [Customizing], page 60):

ResourcegetCoreCommand (class GetCoreCommand)
A command to get a core dump of a running process (typically,gcore ) ‘@FILE@’ is re-
placed by the base name of the file to create; ‘@PID@’ is replaced by the process id. The
output must be written to ‘@FILE@.@PID@’.

Leave the value empty if you have nogcore or similar command.

2.4 Remote Debugging

You can have each ofddd, the inferior debugger, and the debugged program run on different
machines.

2.4.1 Running DDD on a Remote Host

You can runddd on a remote host, using your current host as X display. On the remote host,
invokeddd as

ddd -display display

wheredisplay is the name of the X server to connect to (for instance, ‘hostname:0.0 ’, where
hostname is your host).

Instead of specifying ‘-display display ’, you can also set theDISPLAY environment variable
to display.

2.4.2 Using DDD with a Remote Inferior Debugger

In order to run the inferior debugger on a remote host, you need ‘remsh ’ (called ‘rsh ’ on BSD
systems) access on the remote host.

To run the debugger on a remote hosthostname, invokeddd as

ddd --host hostname remote-program

If your remoteusername differs from the local username, use

ddd --host hostname --login username remote-program

or

ddd --host username@hostname remote-program

instead.

There are a fewcaveatsin remote mode:
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• The remote debugger is started in your remote home directory. Hence, you must specify an ab-
solute path name forremote-program (or a path name relative to your remote home directory).
Same applies to remote core files. Also, be sure to specify a remote process id when debugging
a running program.

• The remote debugger is started non-interactively. Somedbx versions have trouble with this.
If you do not get a prompt from the remote debugger, use the ‘--rhost ’ option instead of
‘ --host ’. This will invoke the remote debugger via an interactive shell on the remote host,
which may lead to better results.

Note: using ‘--rhost ’, ddd invokes the inferior debugger as soon as a shell prompt appears.
The first output on the remote host ending in a space character or ‘>’ and not followed by a
newline is assumed to be a shell prompt. If necessary, adjust your shell prompt on the remote
host.

• To run the remote program,ddd invokes an ‘xterm ’ terminal emulator on the remote
host, giving your current ‘DISPLAY’ environment variable as address. If the remote host
cannot invoke ‘xterm ’, or does not have access to your X display, startddd with the
‘ --no-exec-window ’ option. The program input/output will then go through theddd
debugger console.

• In remote mode, all sources are loaded from the remote host; file dialogs scan remote directo-
ries. This may result in somewhat slower operation than normal.

• To help you find problems due to remote execution, runddd with the ‘--trace ’ option. This
prints the shell commands issued byddd on standard error.

SeeSection 2.4.2.1 [Customizing Remote Debugging], page 33, for customizing remote mode.

2.4.2.1 Customizing Remote Debugging

When having the inferior debugger run on a remote host (seeSection 2.4 [Remote Debugging],
page 32), all commands to access the inferior debugger as well as its files must be run remotely.
This is controlled by the following resources (seeSection 3.6 [Customizing], page 60):

ResourcershCommand (class RshCommand)
The remote shell command to invoketty-based commands on remote hosts. Usually,
remsh , rsh , ssh , or on .

ResourcelistCoreCommand (class listCoreCommand)
The command to list all core files on the remote host. The string ‘@MASK@’ is replaced by a
file filter. The default setting is:

Ddd*listCoreCommand: \
file @MASK@ | grep ’.*:.*core.*’ | cut -d: -f1

ResourcelistDirCommand (class listDirCommand)
The command to list all directories on the remote host. The string ‘@MASK@’ is replaced by
a file filter. The default setting is:

Ddd*listDirCommand: \
file @MASK@ | grep ’.*:.*directory.*’ | cut -d: -f1
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ResourcelistExecCommand (class listExecCommand)
The command to list all executable files on the remote host. The string ‘@MASK@’ is replaced
by a file filter. The default setting is:

Ddd*listExecCommand: \
file @MASK@ | grep ’.*:.*exec.*’ \

| grep -v ’.*:.*script.*’ \
| cut -d: -f1 | grep -v ’.*\.o$’

ResourcelistSourceCommand (class listSourceCommand)
The command to list all source files on the remote host. The string ‘@MASK@’ is replaced by
a file filter. The default setting is:

Ddd*listSourceCommand: \
file @MASK@ | grep ’.*:.*text.*’ | cut -d: -f1

2.4.3 Debugging a Remote Program

Thegdb debugger allows you to run thedebugged programon a remote machine (calledremote
target), while gdb runs on the local machine.

Seesection “Remote Debugging” inDebugging with gdb, for details. Basically, the following
steps are required:

• Transfer the executable to the remote target.

• Startgdbserver on the remote target.

• Startddd usinggdb on the local machine, and load the same executable using thegdb file
command.

• Attach to the remote ‘gdbserver ’ using thegdb target remote command.

The local ‘.gdbinit ’ file is useful for setting up directory search paths, etc.

Of course, you can also combineddd remote mode andgdb remote mode, runningddd, gdb,
and the debugged program each on a different machine.

2.5 Customizing Interaction with the Inferior Debugger

These settings control the interaction ofddd with its inferior debugger.

2.5.1 Invoking an Inferior Debugger

To choose the default inferior debugger, select ‘Edit ⇒ Preferences ⇒ Startup ⇒
Debugger Type ’. You can

• haveddd determine the appropriate inferior debugger automatically from its command-line
arguments. Set ‘Determine Automatically from Arguments ’ to enable.

• haveddd start the debugger of your choice, as specified in ‘Debugger Type ’.

The followingddd resources control the invocation of the inferior debugger (seeSection 3.6
[Customizing], page 60).
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ResourceautoDebugger (class AutoDebugger)
If this is ‘on ’ (default),ddd will attempt to determine the debugger type from its arguments,
possibly overriding the ‘debugger ’ resource (see below). If this is ‘off ’, ddd will invoke
the debugger specified by the ‘debugger ’ resource regardless ofddd arguments.

Resourcedebugger (class Debugger)
The type of the inferior debugger to invoke (‘gdb ’, ‘ dbx ’, ‘ ladebug ’, ‘ xdb ’, ‘ jdb ’,
‘pydb ’, ‘ perl ’, or ‘bash ’).

This resource is usually set through the ‘--gdb ’, ‘ --dbx ’, ‘ --ladebug ’, ‘ --xdb ’,
‘ --jdb ’, ‘ --pydb ’, ‘ --perl ’, and ‘--bash ’ options; SeeSection 2.1.2 [Options],
page 16, for details.

ResourcedebuggerCommand (class DebuggerCommand)
The name under which the inferior debugger is to be invoked. If this string is empty (default),
the debugger type (‘debugger ’ resource) is used.

This resource is usually set through the ‘--debugger ’ option; SeeSection 2.1.2 [Options],
page 16, for details.

2.5.2 Initializing the Inferior Debugger

ddd uses a number of resources to initialize the inferior debugger (seeSection 3.6 [Customiz-
ing], page 60).

2.5.2.1 GDB Initialization

ResourcegdbInitCommands (class InitCommands)
This string contains a list of newline-separated commands that are initially sent togdb.
As a side-effect, all settings specified in this resource are considered fixed and cannot be
changed through thegdb settings panel, unless preceded by white space. By default, the
‘gdbInitCommands ’ resource contains some settings vital toddd:

Ddd*gdbInitCommands: \
set height 0\n\
set width 0\n\

set verbose off\n\
set prompt (gdb) \n

While the ‘set height ’, ‘ set width ’, and ‘set prompt ’ settings are fixed, the ‘set
verbose ’ settings can be changed through thegdb settings panel (although being reset
upon each newddd invocation).

Do not use this resource to customizegdb; instead, use a personal ‘~/.gdbinit ’ file. See
yourgdb documentation for details.

ResourcegdbSettings (class Settings)
This string contains a list of newline-separated commands that are also initially sent togdb.
Its default value is
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Ddd*gdbSettings: \
set print asm-demangle on\n

This resource is used to save and restore the debugger settings.

ResourcesourceInitCommands (class SourceInitCommands)
If ‘ on ’ (default),ddd writes allgdb initialization commands into a temporary file and makes
gdb read this file, rather than sending each initialization command separately. This results in
faster startup (especially if you have several user-defined commands). If ‘off ’, ddd makes
gdb process each command separately.

2.5.2.2 DBX Initialization

ResourcedbxInitCommands (class InitCommands)
This string contains a list of newline-separated commands that are initially sent todbx. By
default, it is empty.

Do not use this resource to customizedbx; instead, use a personal ‘~/.dbxinit ’ or
‘~/.dbxrc ’ file. See yourdbx documentation for details.

ResourcedbxSettings (class Settings)
This string contains a list of newline-separated commands that are also initially sent todbx.
By default, it is empty.

2.5.2.3 XDB Initialization

ResourcexdbInitCommands (class InitCommands)
This string contains a list of newline-separated commands that are initially sent toxdb. By
default, it is empty.

Do not use this resource to customizedbx; instead, use a personal ‘~/.xdbrc ’ file. See
yourxdb documentation for details.

ResourcexdbSettings (class Settings)
This string contains a list of newline-separated commands that are also initially sent toxdb.
By default, it is empty.

2.5.2.4 JDB Initialization

ResourcejdbInitCommands (class InitCommands)
This string contains a list of newline-separated commands that are initially sent tojdb. This
resource may be used to customizejdb. By default, it is empty.

ResourcejdbSettings (class Settings)
This string contains a list of newline-separated commands that are also initially sent tojdb.
By default, it is empty.

This resource is used byddd to save and restorejdb settings.
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2.5.2.5 PYDB Initialization

ResourcepydbInitCommands (class InitCommands)
This string contains a list of newline-separated commands that are initially sent topydb. By
default, it is empty.

This resource may be used to customizepydb.

ResourcepydbSettings (class Settings)
This string contains a list of newline-separated commands that are also initially sent topydb.
By default, it is empty.

This resource is used byddd to save and restorepydb settings.

2.5.2.6 Perl Initialization

ResourceperlInitCommands (class InitCommands)
This string contains a list of newline-separated commands that are initially sent to the Perl
debugger. By default, it is empty.

This resource may be used to customize the Perl debugger.

ResourceperlSettings (class Settings)
This string contains a list of newline-separated commands that are also initially sent to the
Perl debugger. By default, it is empty.

This resource is used byddd to save and restore Perl debugger settings.

2.5.2.7 Bash Initialization

ResourcebashInitCommands (class InitCommands)
This string contains a list of newline-separated commands that are initially sent to the Bash
debugger. By default, it is empty.

This resource may be used to customize the Bash debugger.

Resourcebash (class Settings)
This string contains a list of newline-separated commands that are also initially sent to the
Perl debugger. By default, it is empty.

This resource is used byddd to save and restore Bash debugger settings.

2.5.2.8 Finding a Place to Start

ResourceinitSymbols (class InitSymbols)
When loading an executable,ddd queries the inferior debugger for the initial source
location—typically themain function. If this location is not found,ddd tries other symbols
from this newline-separated list. The default value makesddd look for a variety of main
functions (especially FORTRAN main functions):



38 Debugging with DDD

main\n\
MAIN\n\
main_\n\
MAIN_\n\
main__\n\
MAIN__\n\
_main\n\
_MAIN\n\
__main\n\
__MAIN

2.5.2.9 Opening the Selection

ResourceopenSelection(class OpenSelection)
If this is ‘on ’, ddd invoked without argument checks whether the current selection or clip-
board contains the file name or URL of an executable program. If this is so,ddd will auto-
matically open this program for debugging. If this resource is ‘off ’ (default),ddd invoked
without arguments will always start without a debugged program.

2.5.3 Communication with the Inferior Debugger

The following resources control the communication with the inferior debugger.

ResourceblockTTYInput (class BlockTTYInput)
Whetherddd should block when reading data from the inferior debugger via the pseudo-tty
interface. Mostunix systems exceptgnu/Linux require this; set it to ‘on ’. On gnu/Linux,
set it to ‘off ’. The value ‘auto ’ (default) will always select the “best” choice (that is, the
best choice known to theddd developers).

ResourcebufferGDBOutput (class BufferGDBOutput)
If this is ‘on ’, all output from the inferior debugger is buffered until a debugger prompt ap-
pears. This makes it easier forddd to parse the output, but has the drawback that interaction
with a running debuggee in the debugger console is not possible. If ‘off ’, output is shown
as soon as it arrives, enabling interaction, but making it harder forddd to parse the output.
If ‘ auto ’ (default), output is buffered if and only if the execution window is open, which
redirects debuggee output and thus enables interaction. SeeSection 6.2 [Using the Execution
Window], page 93, for details.

ResourcecontInterruptDelay (class InterruptDelay)
The time (in ms) to wait before automatically interrupting a ‘cont ’ command.ddd cannot
interrupt a ‘cont ’ command immediately, because this may disturb the status change of the
process. Default is200 .

ResourcedisplayTimeout (class DisplayTimeout)
The time (in ms) to wait for the inferior debugger to finish a partial display information.
Default is2000 .
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ResourcepositionTimeout (class PositionTimeout)
The time (in ms) to wait for the inferior debugger to finish a partial position information.
Default is500 .

ResourcequestionTimeout (class QuestionTimeout)
The time (in seconds) to wait for the inferior debugger to reply. Default is10 .

ResourcerunInterruptDelay (class InterruptDelay)
The time (in ms) to wait before automatically interrupting a ‘run ’ command.ddd cannot
interrupt a ‘cont ’ command immediately, because this may disturb process creation. Default
is 2000 .

ResourcestopAndContinue (class StopAndContinue)
If ‘ on ’ (default), debugger commands interrupt program execution, resuming execution after
the command has completed. This only happens if the last debugger command was either a
‘ run ’ or a ‘continue ’ command. If ‘off ’, debugger commands do not interrupt program
execution.

ResourcesynchronousDebugger(class SynchronousDebugger)
If ‘ on ’, X events are not processed while the debugger is busy. This may result in slightly
better performance on single-processor systems. SeeSection 2.1.2 [Options], page 16, for
the ‘--sync-debugger ’ option.

ResourceterminateOnEOF (class TerminateOnEOF)
If ‘ on ’, ddd terminates the inferior debugger whenddd detects an EOF condition (that is,
as soon as the inferior debugger closes its output channel). This was the default behavior in
ddd 2.x and earlier. If ‘off ’ (default),ddd takes no special action.

ResourceuseTTYCommand (class UseTTYCommand)
If ‘ on ’, use thegdb tty command for redirecting input/output to the separate execution
window. If ‘off ’, use explicit redirection through shell redirection operators ‘<’ and ‘>’.
The default is ‘off ’ (explicit redirection), since on some systems, thetty command does
not work properly on somegdb versions.
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3 The DDD Windows

ddd is composed of three main windows. From top to bottom, we have:

• TheData Window shows the current data of the debugged program. SeeSection 7.3 [Display-
ing Values], page 107, for details.

• TheSource Window shows the current source code of the debugged program. SeeChapter 4
[Navigating], page 73, for details.

• TheDebugger Console accepts debugger commands and shows debugger messages. SeeChap-
ter 10 [Commands], page 147, for details.

Machine Code Window

Data Window

Menu Bar

Source Window

Tool Bar

Debugger Console

Status Line

Panner

Command Tool

Scroll Bar

Resize Sash

Value Tip

Busy Indicator

The DDD Layout using Stacked Windows

Besides these three main windows, there are some other optional windows:

• TheCommand Tool offers buttons for frequently used commands. It is usually placed on the
source window. SeeSection 3.3 [Command Tool], page 55, for details.

• TheMachine Code Window shows the current machine code. It is usually placed beneath the
current source. SeeSection 8.1 [Machine Code], page 141, for details.

• TheExecution Window shows the input and output of the debugged program. SeeSection 6.2
[Using the Execution Window], page 93, for details.

3.1 The Menu Bar

Theddd Menu Bar gives you access to allddd functions.

File Perform file-related operations such as selecting programs, processes, and sessions,
printing graphs, recompiling, as well as exitingddd.
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Edit Perform standard editing operations, such as cutting, copying, pasting, and killing
selected text. Also allows editingddd options and preferences.

View Allows accessing the individualddd windows.

Program Perform operations related to the program being debugged, such as starting and stop-
ping the program.

Commands
Perform operations related toddd commands, such as accessing the command history
or defining new commands.

Status Examine the program status, such as the stack traces, registers, or threads.

Source Perform source-related operations such as looking up items or editing breakpoints.

Data Perform data-related operations such as editing displays or layouting the display graph.

Maintenance
Perform operations that are useful for debuggingddd. By default, this menu is dis-
abled.

Help Give help onddd usage.

There are two ways of selecting an item from a pull-down menu:

• Select an item in the menu bar by moving the cursor over it and clickmouse button 1. Then
move the cursor over the menu item you want to choose and click left again.

• Select an item in the menu bar by moving the cursor over it and click and holdmouse button 1.
With the mouse button depressed, move the cursor over the menu item you want, then release
it to make your selection.

The menus can also betorn off (i.e. turned into a persistent window) by selecting the dashed
line at the top.

If a command in the pull-down menu is not applicable in a given situation, the command is
disabled and its name appears faded. You cannot invoke items that are faded. For example, many
commands on the ‘Edit ’ menu appear faded until you select text on which they are to operate;
after you select a block of text, edit commands are enabled.

3.1.1 The File Menu

The ‘File ’ menu contains file-related operations such as selecting programs, processes, and
sessions, printing graphs, recompiling, as well as exitingddd.

Open Program
Open Class

Open a program or class to be debugged (〈Ctrl+O〉). SeeSection 4.2.1 [Opening Pro-
grams], page 73, for details.

Open Recent
Re-open a recently opened program to be debugged. SeeSection 4.2.1 [Opening Pro-
grams], page 73, for details.

Open Core Dump
Open a core dump for the currently debugged program. SeeSection 4.2.2 [Opening
Core Dumps], page 74, for details.
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Open Source
Open a source file of the currently debugged program. SeeSection 4.2.3 [Opening
Source Files], page 74, for details.

Open Session
Resume a previously savedddd session (〈Ctrl+N〉). SeeSection 2.3.2 [Resuming Ses-
sions], page 30, for details.

Save Session As
Save the currentddd session such that you can resume it later (〈Ctrl+S〉). SeeSec-
tion 2.3.1 [Saving Sessions], page 29, for details.

Attach to Process
Attach to a running process of the debugged program. SeeSection 6.3 [Attaching to a
Process], page 94, for details.

Detach Process
Detach from the running process. SeeSection 6.3 [Attaching to a Process], page 94,
for details.

Print Graph
Print the current graph on a printer. SeeSection 7.3.7 [Printing the Graph], page 131,
for details.

Change Directory
Change the working directory of your program. SeeSection 6.1.3 [Working Direc-
tory], page 92, for details.

Make Run themake program (〈Ctrl+M〉). SeeSection 9.2 [Recompiling], page 146, for
details.

Close Close thisddd window (〈Ctrl+W〉). SeeSection 2.2 [Quitting], page 28, for details.

Restart Restartddd.

Exit Exit ddd (〈Ctrl+Q〉). SeeSection 2.2 [Quitting], page 28, for details.

3.1.2 The Edit Menu

The ‘Edit ’ menu contains standard editing operations, such as cutting, copying, pasting, and
killing selected text. Also allows editingddd options and preferences.

Undo Undo the most recent action (〈Ctrl+Z〉). Almost all commands can be undone this way.
SeeSection 3.5 [Undo and Redo], page 60, for details.

Redo Redo the action most recently undone (〈Ctrl+Y〉). Every command undone can be
redone this way. SeeSection 3.5 [Undo and Redo], page 60, for details.

Cut Removes the selected text block from the current text area and makes it the X clipboard
selection (〈Ctrl+X〉 or 〈Shift+Del〉; SeeSection 3.1.11.2 [Customizing the Edit Menu],
page 51, for details). Before executing this command, you have to select a region in a
text area—either with the mouse or with the usual text selection keys.

This item can also be applied to displays (seeSection 7.3.1.12 [Deleting Displays],
page 116).
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Copy Makes a selected text block the X clipboard selection (〈Ctrl+C〉 or 〈Ctrl+Ins〉; SeeSec-
tion 3.1.11.2 [Customizing the Edit Menu], page 51, for details). You can select text
by selecting a text region with the usual text selection keys or with the mouse. See
Section 3.1.11.2 [Customizing the Edit Menu], page 51, for changing the default ac-
celerator.

This item can also be applied to displays (seeSection 7.3.1.12 [Deleting Displays],
page 116).

Paste Inserts the current value of the X clipboard selection in the most recently selected
text area (〈Ctrl+V〉 or 〈Shift+Ins〉; SeeSection 3.1.11.2 [Customizing the Edit Menu],
page 51, for details). You can paste in text you have placed in the clipboard using
‘Copy’ or ‘ Cut ’. You can also use ‘Paste ’ to insert text that was pasted into the
clipboard from other applications.

Clear Clears the most recently selected text area (〈Ctrl+U〉).

Delete Removes the selected text block from the most recently selected text area, but does not
make it the X clipboard selection.

This item can also be applied to displays (seeSection 7.3.1.12 [Deleting Displays],
page 116).

Select All
Selects all characters from the most recently selected text area (〈Ctrl+A〉 or or
〈Ctrl+Shift+A〉; see Section 3.1.11.2 [Customizing the Edit Menu], page 51, for
details).

Preferences
Allows you to customizeddd interactively. SeeSection 3.6 [Customizing], page 60,
for details.

Debugger Settings
Allows you to customize the inferior debugger. SeeSection 3.6.5 [Debugger Settings],
page 71, for details.

Save Options
If set, all preferences and settings will be saved for the nextddd invocation. See
Section 3.6.1.3 [Saving Options], page 61, for details.

3.1.3 The View Menu

The ‘View ’ menu allows accessing the individualddd windows.

Command Tool
Open and recenter the command tool (〈Alt+8〉). SeeSection 3.3 [Command Tool],
page 55, for details.

Execution Window
Open the separate execution window (〈Alt+9〉). SeeSection 6.2 [Using the Execution
Window], page 93, for details.

Debugger Console
Open the debugger console (〈Alt+1〉). SeeChapter 10 [Commands], page 147, for
details.



Chapter 3: The DDD Windows 45

Source Window
Open the source window (〈Alt+2〉). SeeChapter 4 [Navigating], page 73, for details.

Data Window
Open the data window (〈Alt+3〉). SeeSection 7.3 [Displaying Values], page 107, for
details.

Machine Code Window
Show machine code (〈Alt+4〉). SeeSection 8.1 [Machine Code], page 141, for details.

3.1.4 The Program Menu

The ‘Program ’ menu performs operations related to the program being debugged, such as
starting and stopping the program.

Most of these operations are also found on the command tool (seeSection 3.3 [Command Tool],
page 55).

Run Start program execution, prompting for program arguments (〈F2〉). SeeSection 6.1
[Starting Program Execution], page 91, for details.

Run Again
Start program execution with the most recently used arguments (〈F3〉). SeeSection 6.1
[Starting Program Execution], page 91, for details.

Run in Execution Window
If enabled, start next program execution in separate execution window. SeeSection 6.2
[Using the Execution Window], page 93, for details.

Step Continue running your program until control reaches a different source line, then stop
it and return control toddd (〈F5〉). SeeSection 6.5 [Resuming Execution], page 96,
for details.

Step Instruction
Execute one machine instruction, then stop and return toddd (〈Shift+F5〉). SeeSec-
tion 8.2 [Machine Code Execution], page 142, for details.

Next Continue to the next source line in the current (innermost) stack frame (〈F6〉). This is
similar to ‘Step ’, but function calls that appear within the line of code are executed
without stopping. SeeSection 6.5 [Resuming Execution], page 96, for details.

Next Instruction
Execute one machine instruction, but if it is a function call, proceed until the function
returns (〈Shift+F6〉). SeeSection 8.2 [Machine Code Execution], page 142, for details.

Until Continue running until a source line past the current line, in the current stack frame, is
reached (〈F7〉). SeeSection 6.5 [Resuming Execution], page 96, for details.

Finish Continue running until just after function in the selected stack frame returns (〈F8〉).
Print the returned value (if any). SeeSection 6.5 [Resuming Execution], page 96, for
details.

Continue
Resume program execution, at the address where your program last stopped (〈F9〉); any
breakpoints set at that address are bypassed. SeeSection 6.5 [Resuming Execution],
page 96, for details.
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Continue Without Signal
Continue execution without giving a signal (〈Shift+F9〉). This is useful when your pro-
gram stopped on account of a signal and would ordinary see the signal when resumed
with ‘Continue ’. SeeSection 6.10 [Signals], page 102, for details.

Kill Kill the process of the debugged program (〈F4〉). SeeSection 6.11 [Killing the Pro-
gram], page 104, for details.

Interrupt
Interrupt program execution (〈Esc〉 or 〈Ctrl+C〉; seeSection 3.1.11.2 [Customizing the
Edit Menu], page 51, for details). This is equivalent to sending an interrupt signal to
the process. SeeSection 5.3 [Interrupting], page 88, for details.

Abort Abort program execution (and maybe debugger execution, too;〈Ctrl+\ 〉). This is equiv-
alent to sending aSIGABRTsignal to the process. SeeSection 2.2 [Quitting], page 28,
for details.

3.1.5 The Commands Menu

The ‘Commands’ menu performs operations related toddd commands, such as accessing the
command history or defining new commands.

Most of these items are not meant to be actually executed via the menu; instead, they serve as
reminderfor the equivalent keyboard commands.

Command History
View the command history. SeeSection 10.1.2 [Command History], page 148, for
details.

Previous
Show the previous command from the command history (〈Up〉). SeeSection 10.1.2
[Command History], page 148, for details.

Next Show the next command from the command history (〈Down〉). SeeSection 10.1.2
[Command History], page 148, for details.

Find Backward
Do an incremental search backward through the command history (〈Ctrl+B〉). SeeSec-
tion 10.1.2 [Command History], page 148, for details.

Find Forward
Do an incremental search forward through the command history (〈Ctrl+F〉). SeeSec-
tion 10.1.2 [Command History], page 148, for details.

Quit Search
Quit incremental search through the command history (〈Esc〉). SeeSection 10.1.2
[Command History], page 148, for details.

Complete
Complete the current command in the debugger console (〈Tab〉). SeeSection 10.1
[Entering Commands], page 147, for details.

Apply Apply the current command in the debugger console (〈Apply〉). SeeSection 10.1 [En-
tering Commands], page 147, for details.
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Clear Line
Clear the current command line in the debugger console (〈Ctrl+U〉). SeeSection 10.1
[Entering Commands], page 147, for details.

Clear Window
Clear the debugger console (〈Shift+Ctrl+U〉). SeeSection 10.1 [Entering Commands],
page 147, for details.

Define Command
Define a new debugger command. SeeSection 10.5 [Defining Commands], page 154,
for details.

Edit Buttons
Customizeddd buttons. SeeSection 10.4 [Defining Buttons], page 151, for details.

3.1.6 The Status Menu

The ‘Status ’ menu lets you examine the program status, such as the stack traces, registers, or
threads.

Backtrace
View the current backtrace. SeeSection 6.7.2 [Backtraces], page 99, for a discussion.

Registers
View the current register contents. SeeSection 8.3 [Registers], page 142, for details.

Threads View the current threads. SeeSection 6.9 [Threads], page 101, for details.

Signals View and edit the current signal handling. SeeSection 6.10 [Signals], page 102, for
details.

Up Select the stack frame (i.e. the function) that called this one (〈Ctrl+Up〉). This advances
toward the outermost frame, to higher frame numbers, to frames that have existed
longer. SeeSection 6.7 [Stack], page 98, for details.

Down Select the stack frame (i.e. the function) that was called by this one (〈Ctrl+Down〉).
This advances toward the innermost frame, to lower frame numbers, to frames that
were created more recently. SeeSection 6.7 [Stack], page 98, for details.

3.1.7 The Source Menu

The ‘Source ’ menu performs source-related operations such as looking up items or editing
breakpoints.

Breakpoints
Edit all Breakpoints. SeeSection 5.1.11 [Editing all Breakpoints], page 86, for details.

Lookup ()
Look up the argument ‘() ’ in the source code (〈Ctrl+/〉). SeeSection 4.3.1 [Looking
up Definitions], page 75, for details.

Find >> ()
Look up the next occurrence of the argument ‘() ’ in the current source code (〈Ctrl+.〉).
SeeSection 4.3.2 [Textual Search], page 76, for details.
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Find << ()
Look up the previous occurrence of the argument ‘() ’ in the current source code
(〈Ctrl+,〉). SeeSection 4.3.2 [Textual Search], page 76, for details.

Find Words Only
If enabled, find only complete words (〈Alt+W〉). SeeSection 4.3.2 [Textual Search],
page 76, for details.

Find Case Sensitive
If enabled, find is case-sensitive (〈Alt+I〉). SeeSection 4.3.2 [Textual Search], page 76,
for details.

Display Line Numbers
If enabled, prefix source lines with their line number (〈Alt+N〉). SeeSection 4.4 [Cus-
tomizing Source], page 77, for details.

Display Machine Code
If enabled, show machine code (〈Alt+4〉). SeeSection 8.1 [Machine Code], page 141,
for details.

Edit Source
Invoke an editor for the current source file (〈Shift+Ctrl+V〉). SeeSection 9.1 [Editing
Source Code], page 145, for details.

Reload Source
Reload the current source file (〈Shift+Ctrl+L〉). SeeSection 9.1 [Editing Source Code],
page 145, for details.

3.1.8 The Data Menu

The ‘Data ’ menu performs data-related operations such as editing displays or layouting the
display graph.

Displays
Invoke the Display Editor. SeeSection 7.3.1.11 [Editing all Displays], page 115, for
details.

Watchpoints
Edit all Watchpoints. SeeSection 5.2.3 [Editing all Watchpoints], page 88, for details.

Memory View a memory dump. SeeSection 7.5 [Examining Memory], page 138, for details.

Print () Print the value of ‘() ’ in the debugger console (〈Ctrl+=〉). SeeSection 7.2 [Printing
Values], page 106, for details.

Display ()
Display the value of ‘() ’ in the data window (〈Ctrl+-〉). SeeSection 7.3 [Displaying
Values], page 107, for details.

Detect Aliases
If enabled, detect shared data structures (〈Alt+A〉). SeeSection 7.3.4.3 [Shared Struc-
tures], page 121, for a discussion.
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Display Local Variables
Show all local variables in a display (〈Alt+L〉). SeeSection 7.3.1.5 [Displaying Local
Variables], page 111, for details.

Display Arguments
Show all arguments of the current function in a display (〈Alt+U〉). SeeSection 7.3.1.5
[Displaying Local Variables], page 111, for details.

Status Displays
Show current debugging information in a display. SeeSection 7.3.1.6 [Displaying
Program Status], page 112, for details.

Align on Grid
Align all displays on the grid (〈Alt+G〉). SeeSection 7.3.6.3 [Aligning Displays],
page 130, for a discussion.

Rotate Graph
Rotate the graph by 90 degrees (〈Alt+R〉). SeeSection 7.3.6.5 [Rotating the Graph],
page 131, for details.

Layout Graph
Layout the graph (〈Alt+Y〉). SeeSection 7.3.6 [Layouting the Graph], page 129, for
details.

Refresh Update all values in the data window (〈Ctrl+L〉). SeeSection 7.3.1.7 [Refreshing the
Data Window], page 113, for details.

3.1.9 The Maintenance Menu

The ‘Maintenance ’ menu performs operations that are useful for debuggingddd.

By default, this menu is disabled; it is enabled by specifically requesting it atddd invocation
(via the ‘--maintenance ’ option; seeSection 2.1.2 [Options], page 16). It is also enabled when
ddd gets a fatal signal.

Debug ddd
Invoke a debugger (typically,gdb) and attach it to thisddd process (〈F12〉). This is
useful only if you are addd maintainer.

Dump Core Now
Make thisddd process dump core. This can also be achieved by sendingddd a
SIGUSR1signal.

Tic Tac Toe
Invoke a Tic Tac Toe game. You must try to get three stop signs in a row, while
preventingddd from doing so with its skulls. Click on ‘New Game’ to restart.

Whenddd Crashes
Select what to do whenddd gets a fatal signal.

Debug ddd
Invoke a debugger on theddd core dump whenddd crashes. This is
useful only if you are addd maintainer.
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Dump Core
Just dump core whenddd crashes; don’t invoke a debugger. This is
the default setting, as the core dump may contain important information
required for debuggingddd.

Do Nothing
Do not dump core or invoke a debugger whenddd crashes.

Remove Menu
Make this menu inaccessible again.

3.1.10 The Help Menu

The ‘Help ’ menu gives help onddd usage. SeeSection 3.4 [Getting Help], page 59, for a
discussion on how to get help withinddd.

Overview
Explains the most important concepts ofddd help.

On Item Lets you click on an item to get help on it.

On Window
Gives you help on thisddd window.

What Now?
Gives a hint on what to do next.

Tip of the Day
Shows the current tip of the day.

ddd Reference
Shows theddd Manual.

ddd News Shows what’s new in thisddd release.

Debugger Reference
Shows the on-line documentation for the inferior debugger.

ddd License
Shows theddd License (seeAppendix G [License], page 187).

ddd www Page
Invokes awww browser for theddd www page.

About ddd
Shows version and copyright information.

3.1.11 Customizing the Menu Bar

The Menu Bar can be customized in various ways (seeSection 3.6 [Customizing], page 60).
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3.1.11.1 Auto-Raise Menus

You can cause pull-down menus to be raised automatically.

ResourceautoRaiseMenu (class AutoRaiseMenu)
If ‘ on ’ (default),ddd will always keep the pull down menu on top of theddd main window.
If this setting interferes with your window manager, or if your window manager does not
auto-raise windows, set this resource to ‘off ’.

ResourceautoRaiseMenuDelay(class AutoRaiseMenuDelay)
The time (in ms) during which an initial auto-raised window blocks further auto-raises. This
is done to prevent two overlapping auto-raised windows from entering anauto-raise loop.
Default is100 .

3.1.11.2 Customizing the Edit Menu

In the Menu Bar, the ‘Edit ’ Menu can be customized in various ways. Use ‘Edit ⇒
Preferences ⇒ Startup ’ to customize these keys.

The〈Ctrl+C〉 key can be bound to different actions, each in accordance with a specific style guide.

Copy This setting binds〈Ctrl+C〉 to the Copy operation, as specified by the KDE style guide.
In this setting, use〈ESC〉 to interrupt the debuggee.

Interrupt

This (default) setting binds〈Ctrl+C〉 to the Interrupt operation, as used in severalunix command-
line programs. In this setting, use〈Ctrl+Ins〉 to copy text to the clipboard.

The〈Ctrl+A〉 key can be bound to different actions, too.

Select All
This (default) setting binds〈Ctrl+A〉 to the ‘Select All ’ operation, as specified by
the KDE style guide. In this setting, use〈Home〉 to move the cursor to the beginning of
a line.

Beginning of Line
This setting binds〈Ctrl+A〉 to the ‘Beginning of Line ’ operation, as used in sev-
eralunix text-editing programs. In this setting, use〈Ctrl+Shift+A〉 to select all text.

Here are the relatedddd resources:

ResourcecutCopyPasteBindings(class BindingStyle)
Controls the key bindings for clipboard operations.

• If this is ‘Motif ’ (default), Cut/Copy/Paste is on〈Shift+Del〉/〈Ctrl+Ins〉/〈Shift+Ins〉. This
is conformant to the M*tif style guide.

• If this is ‘KDE’, Cut/Copy/Paste is on〈Ctrl+X〉/〈Ctrl+C〉/〈Ctrl+V〉. This is conformant
to the KDE style guide. Note that this means that〈Ctrl+C〉 no longer interrupts the
debuggee; use〈ESC〉 instead.
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ResourceselectAllBindings (class BindingStyle)
Controls the key bindings for the ‘Select All ’ operation.

• If this is ‘Motif ’, Select All is on〈Shift+Ctrl+A〉.

• If this is ‘KDE’ (default), Select All is on〈Ctrl+A〉. This is conformant to the KDE style
guide. Note that this means that〈Ctrl+A〉 no longer moves the cursor to the beginning of
a line; use〈Home〉 instead.

3.2 The Tool Bar

Someddd commands require anargument. This argument is specified in theargument field,
labeled ‘(): ’. Basically, there are four ways to set arguments:

• You cankey inthe argument manually.

• You canpastethe current selection into the argument field (typically usingmouse button
2). To clear old contents beforehand, click on the ‘(): ’ label.

• You canselect an itemfrom the source and data windows. This will automatically copy the
item to the argument field.

• You can select apreviously used argumentfrom the drop-down menu at the right of the argu-
ment field.

Usinggdb and Perl, the argument field provides a completion mechanism. You can enter the
first few characters of an item an press the〈TAB〉 key to complete it. Pressing〈TAB〉 again shows
alternative completions.

After having entered an argument, you can select one of the buttons on the right. Most of these
buttons also have menus associated with them; this is indicated by a small arrow in the upper right
corner. Pressing and holdingmouse button 1on such a button will pop up a menu with further
operations.

Get Previous Arguments

Data CommandsLookup Commands Breakpoint Commands

Enter Argument

The Tool Bar

These are the buttons of the tool bar. Note that not all buttons may be inactive, depending on the
current state and the capabilities of the inferior debugger.

Lookup

Look up the argument ‘() ’ in the source code. SeeSection 4.3.1 [Looking up Defini-
tions], page 75, for details.

Find >>
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Look up the next occurrence of the argument ‘() ’ in the current source code. See
Section 4.3.2 [Textual Search], page 76, for details.

Break/Clear
Toggle a breakpoint (seeSection 5.1 [Breakpoints], page 81) at the location ‘() ’.

Break If there is no breakpoint at ‘() ’, then this button is labeled ‘Break ’.
Clicking on ‘Break ’ sets a breakpoint at the location ‘() ’. SeeSec-
tion 5.1.1 [Setting Breakpoints], page 81, for details.

Clear If there already is a breakpoint at ‘() ’, then this button is labeled
‘Clear ’. Clicking on ‘Clear ’ clears (deletes) the breakpoint at the
location ‘() ’. SeeSection 5.1.2 [Deleting Breakpoints], page 82, for
details.

Watch/Unwatch
Toggle a watchpoint (seeSection 5.2 [Watchpoints], page 87) on the expression ‘() ’.

Watch If ‘ () ’ is not being watched, then this button is labeled ‘Watch ’. Click-
ing on ‘Watch ’ creates a watchpoint on the expression ‘() ’. SeeSec-
tion 5.2.1 [Setting Watchpoints], page 88, for details.

Unwatch If ‘ () ’ is being watched, then this button is labeled ‘Unwatch ’. Clicking
on ‘Unwatch ’ clears (deletes) the watchpoint on ‘() ’. SeeSection 5.2.4
[Deleting Watchpoints], page 88, for details.

Print

Print the value of ‘() ’ in the debugger console. SeeSection 7.2 [Printing Values],
page 106, for details.

Display

Display the value of ‘() ’ in the data window. SeeSection 7.3 [Displaying Values],
page 107, for details.

Plot

Plot ‘() ’ in a plot window. SeeSection 7.4 [Plotting Values], page 133, for details.

Show/Hide
Toggle details of the selected display(s). SeeSection 7.3.1.3 [Showing and Hiding
Details], page 109, for a discussion.

Rotate

Rotate the selected display(s). SeeSection 7.3.1.4 [Rotating Displays], page 110, for
details.

Set

Set (change) the value of ‘() ’. SeeSection 7.3.3 [Assignment], page 119, for details.

Undisp

Undisplay (delete) the selected display(s). SeeSection 7.3.1.12 [Deleting Displays],
page 116, for details.
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3.2.1 Customizing the Tool Bar

The ddd tool bar buttons can appear in a variety of styles, customized via ‘Edit ⇒
Preferences ⇒ Startup ’.

Images This lets each tool bar button show an image illustrating the action.

Captions
This shows the action name below the image.

The default is to have images as well as captions, but you can choose to have only images (saving
space) or only captions.

Tool Bar Appearance

No captions, no images

Captions only, non−flat

Images only, flat

Captions, images, flat, color

If you choose to have neither images nor captions, tool bar buttons are labeled like other buttons,
as inddd 2.x. Note that this implies that in the stacked window configuration, the common tool bar
cannot be displayed; it is replaced by two separate tool bars, as inddd 2.x.

If you enable ‘Flat ’ buttons (default), the border of tool bar buttons will appear only if the
mouse pointer is over them. This latest-and-greatestgui invention can be disabled, such that the
button border is always shown.

If you enable ‘Color ’ buttons, tool bar images will be colored when entered. Ifddd was built
using M*tif 2.0 and later, you can also choose a third setting, where buttons appear in color all the
time.

Here are the related resources (seeSection 3.6 [Customizing], page 60):

ResourceactiveButtonColorKey (class ColorKey)
The xpm color key to use for the images of active buttons (entered or armed). ‘c ’ means
color, ‘g’ (default) means grey, and ‘m’ means monochrome.
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ResourcebuttonCaptions (class ButtonCaptions)
Whether the tool bar buttons should be shown using captions (‘on ’, default) or not (‘off ’).
If neither captions nor images are enabled, tool bar buttons are shown using ordinary labels.
See also ‘buttonImages ’, below.

ResourcebuttonCaptionGeometry (class ButtonCaptionGeometry)
The geometry of the caption subimage within the button icons. Default is ‘29x7+0-0 ’.

ResourcebuttonImages (class ButtonImages)
Whether the tool bar buttons should be shown using images (‘on ’, default) or not (‘off ’).
If neither captions nor images are enabled, tool bar buttons are shown using ordinary labels.
See also ‘buttonCaptions ’, above.

ResourcebuttonImageGeometry (class ButtonImageGeometry)
The geometry of the image within the button icon. Default is ‘25x21+2+0 ’.

ResourcebuttonColorKey (class ColorKey)
Thexpm color key to use for the images of inactive buttons (non-entered or insensitive). ‘c ’
means color, ‘g’ (default) means grey, and ‘m’ means monochrome.

ResourceflatToolbarButtons (class FlatButtons)
If ‘ on ’ (default), all tool bar buttons with images or captions are given a ‘flat’ appearance—
the 3-D border only shows up when the pointer is over the icon. If ‘off ’, the 3-D border is
shown all the time.

ResourceflatDialogButtons (class FlatButtons)
If ‘ on ’ (default), all dialog buttons with images or captions are given a ‘flat’ appearance—
the 3-D border only shows up when the pointer is over the icon. If ‘off ’, the 3-D border is
shown all the time.

3.3 The Command Tool

The command tool is a small window that gives you access to the most frequently usedddd
commands. It can be moved around on top of theddd windows, but it can also be placed besides
them.

By default, the command toolsticksto theddd source window: Whenever you move theddd
source window, the command tool follows such that the distance between source window and com-
mand tool remains the same. By default, the command tool is alsoauto-raised, such that it stays on
top of otherddd windows.

The command tool can be configured to appear as a command tool bar above the source window;
see ‘Edit ⇒ Preferences ⇒ Source ⇒ Tool Buttons Location ’ for details.

Whenever you saveddd state,ddd also saves the distance between command tool and source
window, such that you can select your own individual command tool placement. To move the
command tool to its saved position, use ‘View ⇒ Command Tool’.



56 Debugging with DDD

Start debugged program

Interrupt debugged program

Step program one line (step into calls)

Step program one line (step over calls)

Edit source file

Select stack frame that called this one

Continue program after breakpoint

Step one instruction (step into calls)

Step one instruction (step over calls)

Select stack frame called by this one

Kill execution of debugged program

Invoke the make program

Continue until frame returns

The Command Tool

Continue until program reaches next line

Undo previous action Redo next action

These are the buttons of the command tool. Note that not all buttons may be inactive, depending
on the current state and the capabilities of the inferior debugger.

Run Start program execution. When you click this button, your program will begin to exe-
cute immediately. SeeSection 6.1 [Starting Program Execution], page 91, for details.

Interrupt
Interrupt program execution. This is equivalent to sending an interrupt signal to the
process. SeeSection 5.3 [Interrupting], page 88, for details.

Step Continue running your program until control reaches a different source line, then stop
it and return control toddd. SeeSection 6.5 [Resuming Execution], page 96, for
details.

Stepi Execute one machine instruction, then stop and return toddd. SeeSection 8.2 [Ma-
chine Code Execution], page 142, for details.

Next Continue to the next source line in the current (innermost) stack frame. This is similar
to ‘Step ’, but function calls that appear within the line of code are executed without
stopping. SeeSection 6.5 [Resuming Execution], page 96, for details.

Nexti Execute one machine instruction, but if it is a function call, proceed until the function
returns. SeeSection 8.2 [Machine Code Execution], page 142, for details.

Until Continue running until a source line past the current line, in the current stack frame, is
reached. SeeSection 6.5 [Resuming Execution], page 96, for details.

Finish Continue running until just after function in the selected stack frame returns. Print the
returned value (if any). SeeSection 6.5 [Resuming Execution], page 96, for details.
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Cont Resume program execution, at the address where your program last stopped; any
breakpoints set at that address are bypassed. SeeSection 6.5 [Resuming Execution],
page 96, for details.

Kill Kill the process of the debugged program. SeeSection 6.11 [Killing the Program],
page 104, for details.

Up Select the stack frame (i.e. the function) that called this one. This advances toward
the outermost frame, to higher frame numbers, to frames that have existed longer. See
Section 6.7 [Stack], page 98, for details.

Down Select the stack frame (i.e. the function) that was called by this one. This advances
toward the innermost frame, to lower frame numbers, to frames that were created more
recently. SeeSection 6.7 [Stack], page 98, for details.

Undo Undo the most recent action. Almost all commands can be undone this way. See
Section 3.5 [Undo and Redo], page 60, for details.

Redo Redo the action most recently undone. Every command undone can be redone this
way. SeeSection 3.5 [Undo and Redo], page 60, for details.

Edit Invoke an editor for the current source file. SeeSection 9.1 [Editing Source Code],
page 145, for details.

Make Run themake program with the most recently given arguments. SeeSection 9.2 [Re-
compiling], page 146, for details.

3.3.1 Customizing the Command Tool

The Command Tool can be customized in various ways.

SeeSection 10.4.1 [Customizing Buttons], page 152, for details on customizing the tool buttons.

3.3.1.1 Disabling the Command Tool

You can disable the command tool and show its buttons in a separate row beneath the tool
bar. To disable the command tool, set ‘Edit ⇒ Preferences ⇒ Source ⇒ Tool Buttons
Location ⇒ Source Window ’.



58 Debugging with DDD

Source Preferences

Here’s the related resource:

ResourcecommandToolBar (class ToolBar)
Whether the tool buttons should be shown in a tool bar above the source window (‘on ’)
or within the command tool (‘off ’, default). Enabling the command tool bar disables the
command tool and vice versa.

3.3.2 Command Tool Position

The following resources control the position of the command tool (seeSection 3.6 [Customiz-
ing], page 60):

ResourceautoRaiseTool (class AutoRaiseTool)
If ‘ on ’ (default), ddd will always keep the command tool on top of otherddd windows.
If this setting interferes with your window manager, or if your window manager keeps the
command tool on top anyway, set this resource to ‘off ’.

ResourcestickyTool (class StickyTool)
If ‘ on ’ (default), the command tool automatically follows every movement of the source
window. Whenever the source window is moved, the command tool is moved by the same
offset such that its position relative to the source window remains unchanged. If ‘off ’, the
command tool does not follow source window movements.

ResourcetoolRightOffset (class Offset)
The distance between the right border of the command tool and the right border of the source
text (in pixels). Default is 8.

ResourcetoolTopOffset (class Offset)
The distance between the upper border of the command tool and the upper border of the
source text (in pixels). Default is 8.
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3.3.2.1 Customizing Tool Decoration

The following resources control the decoration of the command tool (seeSection 3.6 [Customiz-
ing], page 60):

ResourcedecorateTool (class Decorate)
This resource controls the decoration of the command tool.

• If this is ‘off ’, the command tool is created as atransient window. Several window
managers keep transient windows automatically on top of their parents, which is appro-
priate for the command tool. However, your window manager may be configured not
to decorate transient windows, which means that you cannot easily move the command
tool around.

• If this is ‘on ’, ddd realizes the command tool as atop-level window. Such win-
dows are always decorated by the window manager. However, top-level windows are
not automatically kept on top of other windows, such that you may wish to set the
‘autoRaiseTool ’ resource, too.

• If this is ‘auto ’ (default), ddd checks whether the window manager decorates tran-
sients. If yes, the command tool is realized as a transient window (as in the ‘off ’
setting); if no, the command tool is realized as a top-level window (as in the ‘on ’ set-
ting). Hence, the command tool is always decorated using the “best” method, but the
extra check takes some time.

3.4 Getting Help

ddd has an extensive on-line help system. Here’s how to get help while working withddd.

• You can get a short help text on mostddd buttons by simply moving the mouse pointer on it
and leave it there. After a second, a small window (calledbutton tip; also known astool tip
or balloon help) pops up, giving a hint on the button’s meaning. The button tip disappears as
soon as you move the mouse pointer to another item.

• Thestatus line also displays information about the currently selected item. By clicking on the
status line, you can redisplay the most recent messages.

• You can get detailed help on any visibleddd item. Just point on the item you want help and
press the ‘F1’ key. This pops up a detailed help text.

• Theddd dialogs all contain ‘Help ’ buttons that give detailed information about the dialog.

• You can get help on debugger commands by enteringhelp at the debugger prompt. See
Section 10.1 [Entering Commands], page 147, for details on entering commands.

• If you are totally stuck, try ‘Help ⇒What Now?’ (the ‘What Now?’ item in the ‘Help ’
menu) or press〈Ctrl+F1〉. Depending on the current state,ddd will give you some hints on
what you can do next.

• Of course, you can always refer to theon-line documentation:

− ‘Help ⇒ ddd Reference ’ gives you access to theddd manual, the ultimateddd
reference.

− ‘Help ⇒ Debugger Reference ’ shows you the on-line documentation of the inferior
debugger.
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− ‘Help ⇒ ddd www Page’ gives you access to the latest and greatest information on
ddd.

• Finally, theddd Tip Of The Day gives you important hints with each newddd invocation.

All these functions can be customized in various ways (seeSection 3.6.2 [Customizing Help],
page 61).

If, after all, you made a mistake, don’t worry: almost everyddd command can be undone. See
Section 3.5 [Undo and Redo], page 60, for details.

3.5 Undoing and Redoing Commands

Almost everyddd command can be undone, using ‘Edit ⇒ Undo’ or the ‘Undo’ button on
the command tool.

Likewise, ‘Edit ⇒ Redo’ repeats the command most recently undone.

The ‘Edit ’ menu shows which commands are to be undone and redone next; this is also indi-
cated by the popup help on the ‘Undo’ and ‘Redo’ buttons.

3.6 Customizing DDD

ddd is controlled by severalresources—user-defined variables that take specific values in order
to control and customizeddd behavior.

Mostddd resources can be set interactively whileddd is running or when invokingddd. See
[Resource Index], page 211, for the full list ofddd resources.

We first discuss how customizing works in general; then we turn to customizing parts ofddd
introduced so far.

3.6.1 How Customizing DDD Works

3.6.1.1 Resources

Just like any X program,ddd has a number of places to get resource values from. Forddd, the
most important places to specify resources are:

• The ‘~/.ddd/init ’ file (‘ ~’ stands for your home directory). This file is read in byddd
upon start-up; the resources specified herein override all other sources (except for resources
given implicitly by command-line options).

If the environment variableDDD_STATEis set, its value is used instead of ‘~/.ddd/ ’.

• The ‘Ddd’ application-defaults file. This file is typically compiled into theddd executable.
If it exists, its resource values override the values compiled intoddd. If the versions of the
‘Ddd’ application-defaults file and theddd executable do not match,ddd may not function
properly;ddd will give you a warning in this case.1

• The command-line options. These options override all other resource settings.

1 If you use a ‘Ddd’ application-defaults file, you will not be able to maintain multipleddd versions at the
same time. This is why the suiting ‘Ddd’ is normally compiled into theddd executable.
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• If the environment variableDDD_SESSIONis set, it indicates the name of a session to start,
overriding all options and resources. This is used byddd when restarting itself.

Not every resource has a matching command-line option. Each resource (whether in
‘~/.ddd/init ’ or ‘ Ddd’) is specified using a line

Ddd* resource: value

For instance, to set the ‘pollChildStatus ’ resource to ‘off ’, you would specify in
‘~/.ddd/init ’:

Ddd*pollChildStatus: off

For more details on the syntax of resource specifications, see the sectionRESOURCES in the
X(1) manual page.

3.6.1.2 Changing Resources

You can changeddd resources by three methods:

• Useddd to change the options, notably ‘Edit ⇒ Preferences ’. This works for the most
importantddd resources. Be sure to save the options (seeSection 3.6.1.3 [Saving Options],
page 61) such that they apply to futureddd sessions, too.

• You can also invokeddd with an appropriate command-line option. This changes the re-
latedddd resource for this particularddd invocation. However, if you save the options (see
Section 3.6.1.3 [Saving Options], page 61), the changed resource will also apply to future
invocations.

• Finally, you can set the appropriate resource in a file named ‘.ddd/init ’ in your home
directory. See[Resource Index], page 211, for a list ofddd resources to be set.

3.6.1.3 Saving Options

You can save the current option settings by setting ‘Edit ⇒ Save Options ’. Options are
saved in a file named ‘.ddd/init ’ in your home directory whenddd exits. If a sessionsession
is active, options will be saved in ‘~/.ddd/sessions/ session/init ’ instead.

The options are automatically saved when exitingddd. You can turn off this feature by unsetting
‘Edit ⇒ Save Options ’. This is tied to the following resource:

ResourcesaveOptionsOnExit (class SaveOnExit)
If ‘ on ’ (default), the current option settings are automatically saved whenddd exits.

3.6.2 Customizing DDD Help

ddd Help can be customized in various ways.

3.6.2.1 Button Tips

Button tips are helpful for novices, but may be distracting for experienced users. You can turn off
button tips via ‘Edit ⇒ Preferences ⇒ General ⇒ Automatic display of Button
Hints ⇒ as Popup Tips ’.
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You can also turn off the hint that is displayed in the status line. Just toggle ‘Edit ⇒
Preferences ⇒ General ⇒ Automatic Display of Button Hints ⇒ in the
Status Line ’.

General Preferences

These are the relatedddd resources (seeSection 3.6 [Customizing], page 60):

ResourcebuttonTips (class Tips)
If ‘ on ’ (default), enable button tips.

ResourcebuttonDocs (class Docs)
If ‘ on ’ (default), show button hints in the status line.

3.6.2.2 Tip of the day

You can turn off the tip of the day by toggling ‘Edit ⇒ Preferences ⇒ Startup ⇒
Startup Windows ⇒ Tip of the Day ’.

Here is the relatedddd resource (seeSection 3.6 [Customizing], page 60):

ResourcestartupTips (class StartupTips)
If ‘ on ’ (default), show a tip of the day uponddd startup.

SeeSection 2.1.2 [Options], page 16, for options to set this resource uponddd invocation.

The actual tips are controlled by these resources (seeSection 3.6 [Customizing], page 60):

ResourcestartupTipCount (class StartupTipCount)
The numbern of the tip of the day to be shown at startup. See also the ‘tip n ’ resources.

Resourcetipn (class Tip)
The tip of the day numberedn (a string).
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3.6.2.3 Help Helpers

ddd relies on a number of external commands, specified via ‘Edit ⇒ Preferences ⇒
Helpers ’.

Setting Helpers Preferences

To uncompress help texts, you can define a ‘Uncompress ’ command:

ResourceuncompressCommand(class UncompressCommand)
The command to uncompress the built-inddd manual, theddd license, and theddd news.
Takes a compressed text from standard input and writes the uncompressed text to standard
output. The default value isgzip -d -c ; typical values includezcat andgunzip -c .

To viewwww pages, you can define a ‘Web Browser ’ command:

ResourcewwwCommand (class WWWCommand)
The command to invoke awww browser. The string ‘@URL@’ is replaced by theurl to
open. Default is to try a running Netscape first (tryingmozilla , thennetscape ), then
$WWWBROWSER, then to invoke a new Netscape process, then to let a running Emacs or
XEmacs do the job (viagnudoit ), then to invoke Mosaic, then to invoke Lynx in an xterm.

To specify ‘netscape-6.0 ’ as browser, use the setting:
Ddd*wwwCommand: \

netscape-6.0 -remote ’openURL(@URL@)’ \
|| netscape-6.0 ’@URL@’

This command first tries to connect to a runningnetscape-6.0 browser; if this fails, it
starts a newnetscape-6.0 process.

This is the defaultwww Page shown by ‘Help ⇒ ddd www Page’:
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ResourcewwwPage (classwwwPage)
Theddd www page. Value:http://www.gnu.org/software/ddd/

3.6.3 Customizing Undo

ddd Undo can be customized in various ways.

To set a maximum size for the undo buffer, set ‘Edit ⇒ Preferences ⇒ General ⇒
Undo Buffer Size ’.

This is related to the ‘maxUndoSize ’ resource:

ResourcemaxUndoSize (class MaxUndoSize)
The maximum memory usage (in bytes) of the undo buffer. Useful for limitingddd memory
usage. A negative value means to place no limit. Default is2000000 , or 2000 kBytes.

You can also limit the number of entries in the undo buffer, regardless of size (seeSection 3.6
[Customizing], page 60):

ResourcemaxUndoDepth (class MaxUndoDepth)
The maximum number of entries in the undo buffer. This limits the number of actions that
can be undone, and the number of states that can be shown in historic mode. Useful for
limiting ddd memory usage. A negative value (default) means to place no limit.

To clear the undo buffer at any time, thus reducing memory usage, use ‘Edit ⇒
Preferences ⇒ General ⇒ Clear Undo Buffer ’

3.6.4 Customizing the DDD Windows

You can customize theddd Windows in various ways.

3.6.4.1 Splash Screen

You can turn off theddd splash screen shown upon startup. Just select ‘Edit ⇒
Preferences ⇒ Startup ddd Splash Screen ’.

http://www.gnu.org/software/ddd/
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Startup Preferences

The value applies only to the nextddd invocation.

This setting is related to the following resource:

ResourcesplashScreen(class SplashScreen)
If ‘ on ’ (default), show addd splash screen upon start-up.

You can also customize the appearance of the splash screen (seeSection 3.6 [Customizing],
page 60):

ResourcesplashScreenColorKey(class ColorKey)
The color key to use for theddd splash screen. Possible values include:

• ‘c ’ (default) for a color visual,

• ‘g’ for a multi-level greyscale visual,

• ‘g4 ’ for a 4-level greyscale visual, and

• ‘m’ for a dithered monochrome visual.

• ‘best ’ chooses the best visual available for your display.

Please note: ifddd runs on a monochrome display, or ifddd was compiled without thexpm
library, only the monochrome version (‘m’) can be shown.

3.6.4.2 Window Layout

By default,ddd stacks commands, source, and data in one single top-level window. To have
separate top-level windows for source, data, and debugger console, set ‘Edit ⇒ Preferences
⇒ Startup ⇒Window Layout ⇒ Separate Windows ’.
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Source Window

Debugger Console

Data Window

Button Tip

The DDD Layout using Separate Windows

Here are the relatedddd resources:

ResourceseparateDataWindow (class Separate)
If ‘ on ’, the data window and the debugger console are realized in different top-level windows.
If ‘ off ’ (default), the data window is attached to the debugger console.

ResourceseparateSourceWindow(class Separate)
If ‘ on ’, the source window and the debugger console are realized in different top-level win-
dows. If ‘off ’ (default), the source window is attached to the debugger console.

By default, theddd tool bars are located on top of the window. If you prefer the tool bar being
located at the bottom, as inddd 2.x and earlier, set ‘Edit ⇒ Preferences ⇒ Startup ⇒
Tool Bar Appearance ⇒ Bottom ’.

This is related to the ‘toolbarsAtBottom ’ resource:

ResourcetoolbarsAtBottom (class ToolbarsAtBottom)
Whether source and data tool bars should be placed above source and data, respectively
(‘off ’, default), or below, as inddd 2.x (‘on ’).

The bottom setting is only supported for separate tool bars—that is, you must either choose
separate windows or configure the tool bar to have neither images nor captions (seeSection 3.2.1
[Customizing the Tool Bar], page 54).

If you use stacked windows, you can choose whether there should be one tool bar or two tool
bars. By default,ddd uses two tool bars if you use separate windows and disable captions and
images, but you can also explicitly change the setting via this resource:
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ResourcecommonToolBar (class ToolBar)
Whether the tool bar buttons should be shown in one common tool bar at the top of the
commonddd window (‘on ’, default), or whether they should be placed in two separate tool
bars, one for data, and one for source operations, as inddd 2.x (‘off ’).

You can also change the location of thestatus line(seeSection 3.6 [Customizing], page 60):

ResourcestatusAtBottom (class StatusAtBottom)
If ‘ on ’ (default), the status line is placed at the bottom of theddd source window. If ‘off ’,
the status line is placed at the top of theddd source window (as inddd 1.x).

SeeSection 2.1.2 [Options], page 16, for options to set these resources uponddd invocation.

3.6.4.3 Customizing Fonts

You can configure the basicddd fonts at run-time. Each font is specified using two members:

• The font family is an X font specifications, where the initial ‘foundry- ’ specification may
be omitted, as well as any specification afterfamily. Thus, a pair ‘family- weight ’ usually
suffices.

• Thefont size is given as (resolution-independent) 1/10 points.

To specify fonts, select ‘Edit ⇒ Preferences ⇒ Fonts ’.

Setting Font Preferences

The ‘Browse ’ button opens a font selection program, where you can select fonts and attributes
interactively. Clicking ‘quit ’ or ‘ select ’ in the font selector causes all non-default values to be
transferred to theddd font preferences panel.

The following fonts can be set using the preferences panel:
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Default Font
The default ddd font to use for labels, menus, and buttons. Default is
‘helvetica-bold ’.

Variable Width
The variable widthddd font to use for help texts and messages. Default is
‘helvetica-medium ’.

Fixed Width
The fixed widthddd font to use for source code, the debugger console, text fields, and
the execution window. Default is ‘lucidatypewriter-medium ’.

Data Theddd font to use for data displays. Default is ‘lucidatypewriter-medium ’.

Changes in this panel will take effect only in the nextddd session. To make it effective right
now, restartddd (using ‘File ⇒ Restart ddd’).

After having made changes in the panel,ddd will automatically offer you to restart itself, such
that you can see the changes taking effect.

The ‘Reset ’ button restores the most recently saved preferences.

Here are the resources related to font specifications:

ResourcedefaultFont (class Font)
The defaultddd font to use for labels, menus, buttons, etc. The font is specified as an X font
spec, where the initialFoundry specification may be omitted, as well as any specification
afterFamily.

Default value is ‘helvetica-bold ’.

To set the defaultddd font to, say, ‘helvetica medium ’, insert a line
Ddd*defaultFont: helvetica-medium

in your ‘~/.ddd/init ’ file.

ResourcedefaultFontSize (class FontSize)
The size of the defaultddd font, in 1/10 points. This resource overrides any font size spec-
ification in the ‘defaultFont ’ resource (see above). The default value is120 for a 12.0
point font.

ResourcevariableWidthFont (class Font)
The variable widthddd font to use for help texts and messages. The font is specified as an X
font spec, where the initialFoundry specification may be omitted, as well as any specification
afterFamily.

Default value is ‘helvetica-medium-r ’.

To set the variable widthddd font family to, say, ‘times ’, insert a line
Ddd*fixedWidthFont: times-medium

in your ‘~/.ddd/init ’ file.

ResourcevariableWidthFontSize (class FontSize)
The size of the variable widthddd font, in 1/10 points. This resource overrides any font
size specification in the ‘variableWidthFont ’ resource (see above). The default value
is 120 for a 12.0 point font.
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ResourcefixedWidthFont (class Font)
The fixed widthddd font to use for source code, the debugger console, text fields, and
the execution window. The font is specified as an X font spec, where the initialFoundry
specification may be omitted, as well as any specification afterFamily.

Default value is ‘lucidatypewriter-medium ’.

To set the fixed widthddd font family to, say, ‘courier ’, insert a line

Ddd*fixedWidthFont: courier-medium

in your ‘~/.ddd/init ’ file.

ResourcefixedWidthFontSize (class FontSize)
The size of the fixed widthddd font, in 1/10 points. This resource overrides any font size
specification in the ‘fixedWidthFont ’ resource (see above). The default value is120 for
a 12.0 point font.

ResourcedataFont (class Font)
The fixed widthddd font to use data displays. The font is specified as an X font spec, where
the initial Foundry specification may be omitted, as well as any specification afterFamily.

Default value is ‘lucidatypewriter-medium ’.

To set theddd data font family to, say, ‘courier ’, insert a line

Ddd*dataFont: courier-medium

in your ‘~/.ddd/init ’ file.

ResourcedataFontSize (class FontSize)
The size of theddd data font, in 1/10 points. This resource overrides any font size specifi-
cation in the ‘dataFont ’ resource (see above). The default value is120 for a 12.0 point
font.

As all font size resources have the same class (and by default the same value), you can easily
change the defaultddd font size to, say, 9.0 points by inserting a line

Ddd*FontSize: 90

in your ‘~/.ddd/init ’ file.

Here’s how to specify the command to select fonts:

ResourcefontSelectCommand (class FontSelectCommand)
A command to select from a list of fonts. The string ‘@FONT@’ is replaced by the current
ddd default font; the string ‘@TYPE@’ is replaced by a symbolic name of theddd font to
edit. The program must either place the name of the selected font in thePRIMARYselection
or print the selected font on standard output. A typical value is:

Ddd*fontSelectCommand: xfontsel -print

SeeSection 2.1.2 [Options], page 16, for options to set these resources uponddd invocation.
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3.6.4.4 Toggling Windows

In the default stacked window setting, you can turn the individualddd windows on and off
by toggling the respective items in the ‘View ’ menu (seeSection 3.1.3 [View Menu], page 44).
When using separate windows (seeSection 3.6.4.2 [Window Layout], page 65), you can close the
individual windows via ‘File ⇒ Close ’ or by closing them via your window manager.

Whether windows are opened or closed when startingddd is controlled by the following re-
sources, immediately tied to the ‘View ’ menu items:

ResourceopenDataWindow (class Window)
If ‘ off ’ (default), the data window is closed upon start-up.

ResourceopenDebuggerConsole(class Window)
If ‘ off ’, the debugger console is closed upon start-up.

ResourceopenSourceWindow (class Window)
If ‘ off ’, the source window is closed upon start-up.

SeeSection 2.1.2 [Options], page 16, for options to set these resources uponddd invocation.

3.6.4.5 Text Fields

Theddd text fields can be customized using the following resources:

ResourcepopdownHistorySize (class HistorySize)
The maximum number of items to display in pop-down value histories. A value of0 (default)
means an unlimited number of values.

ResourcesortPopdownHistory (class SortPopdownHistory)
If ‘ on ’ (default), items in the pop-down value histories are sorted alphabetically. If ‘off ’,
most recently used values will appear at the top.

3.6.4.6 Icons

If you frequently switch betweenddd and other multi-window applications, you may like to
set ‘Edit ⇒ Preferences ⇒ General ⇒ Iconify all windows at once ’. This way,
all ddd windows are iconified and deiconified as a group.

This is tied to the following resource:

ResourcegroupIconify (class GroupIconify)
If this is ‘on ’, (un)iconifying anyddd window causes all otherddd windows to (un)iconify
as well. Default is ‘off ’, meaning that eachddd window can be iconified on its own.

If you want to keepddd off your desktop during a longer computation, you may like to set
‘Edit ⇒ Preferences ⇒ General ⇒ Uniconify when ready ’. This way, you can
iconify ddd while it is busy on a command (e.g. running a program);ddd will automatically pop
up again after becoming ready (e.g. after the debugged program has stopped at a breakpoint). See
Section 6.4 [Program Stop], page 96, for a discussion.

Here is the related resource:
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ResourceuniconifyWhenReady (class UniconifyWhenReady)
If this is ‘on ’ (default), theddd windows are uniconified automatically whenevergdb be-
comes ready. This way, you can iconifyddd during some longer operation and have it
uniconify itself as soon as the program stops. Setting this to ‘off ’ leaves theddd windows
iconified.

3.6.4.7 Adding Buttons

You can extendddd with new buttons. SeeSection 10.4 [Defining Buttons], page 151, for
details.

3.6.4.8 More Customizations

You can change just about any label, color, keyboard mapping, etc. by changing resources from
the ‘Ddd’ application defaults file which comes with theddd source distribution. Here’s how it
works:

• Identify the appropriate resource in the ‘Ddd’ file.

• Copy the resource line to your ‘~/.ddd/init ’ file and change it at will.

SeeAppendix A [Application Defaults], page 159, for details on the application-defaults file.

3.6.5 Debugger Settings

For most inferior debuggers, you can change their internal settings using ‘Edit ⇒ Settings ’.
Using the settings editor, you can determine whether C++ names are to be demangled, how many
array elements are to print, and so on.

GDB Settings Panel (Excerpt)
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The capabilities of the settings editor depend on the capabilities of your inferior debugger. Click-
ing on ‘?’ gives an an explanation on the specific item; thegdb documentation gives more details.

Use ‘Edit ⇒ Undo’ to undo changes. Clicking on ‘Reset ’ restores the most recently saved
settings.

Some debugger settings are insensitive and cannot be changed, because doing so would endanger
ddd operation. See the ‘gdbInitCommands ’ and ‘dbxInitCommands ’ resources for details.

All debugger settings (except source and object paths) are saved withddd options.
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4 Navigating through the Code

This chapter discusses how to access code from withinddd.

4.1 Compiling for Debugging

In order to debug a program effectively, you need to generate debugging information when you
compile it. This debugging information is stored in the object file; it describes the data type of
each variable or function and the correspondence between source line numbers and addresses in the
executable code.1

To request debugging information, specify the ‘-g ’ option when you run the compiler.

Many C compilers are unable to handle the ‘-g ’ and ‘-O ’ options together. Using those compil-
ers, you cannot generate optimized executables containing debugging information.

gcc, the gnu C compiler, supports ‘-g ’ with or without ‘-O ’, making it possible to debug
optimized code. We recommend that youalwaysuse ‘-g ’ whenever you compile a program. You
may think your program is correct, but there is no sense in pushing your luck.

When you debug a program compiled with ‘-g -O ’, remember that the optimizer is rearranging
your code; the debugger shows you what is really there. Do not be too surprised when the execution
path does not exactly match your source file! An extreme example: if you define a variable, but
never use it,ddd never sees that variable—because the compiler optimizes it out of existence.

4.2 Opening Files

If you did not invokeddd specifying a program to be debugged, you can use the ‘File ’ menu
to open programs, core dumps and sources.

4.2.1 Opening Programs

To open a program to be debugged, select ‘File ⇒ Open Program ’.2 Click on ‘Open’ to
open the program

In jdb, select ‘File ⇒ Open Class ’ instead. This gives you a list of available classes to
choose from.

1 If you useddd to debug Perl, Python or Bash scripts, then this section does not apply.
2 With xdb and somedbx variants, the debugged program must be specified upon invocation and cannot

be changed at run time.
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Opening a program to be debugged

Directory List

Program to be opened

Click here to open

File List

File Filter

To re-open a recently debugged program or class, select ‘File ⇒ Open Recent ’ and choose
a program or class from the list.

If no sources are found, SeeSection 4.3.4 [Source Path], page 76, for specifying source directo-
ries.

4.2.2 Opening Core Dumps

If a previous run of the program has crashed and you want to find out why, you can haveddd
examine itscore dump.3

To open a core dump for the program, select ‘File ⇒ Open Core Dump’. Click on ‘Open’
to open the core dump.

Before ‘Open Core Dump’, you should first use ‘File ⇒ Open Program ’ to specify the
program that generated the core dump and to load its symbol table.

4.2.3 Opening Source Files

To open a source file of the debugged program, select ‘File ⇒ Open Source ’.

• Usinggdb, this gives you a list of the sources used for compiling your program.

• Using other inferior debuggers, this gives you a list of accessible source files, which may or
may not be related to your program.

Click on ‘Open’ to open the source file. SeeSection 4.3.4 [Source Path], page 76, if no sources
are found.

3 jdb, pydb, Perl, and Bash do not support core dumps.
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4.2.4 Filtering Files

When presenting files to be opened,ddd by default filters files when opening execution files,
core dumps, or source files, such that the selection shows only suitable files. This requires thatddd
opens each file, which may take time. SeeSection 4.4.6 [Customizing File Filtering], page 80, if
you want to turn off this feature.

4.3 Looking up Items

As soon as the source of the debugged program is available, thesource windowdisplays its
current source text. (seeSection 4.3.4 [Source Path], page 76, if a source text cannot be found.)

In the source window, you can lookup and examine function and variable definitions as well as
search for arbitrary occurrences in the source text.

4.3.1 Looking up Definitions

If you wish to lookup a specific function or variable definition whose name is visible in the
source text, click withmouse button 1on the function or variable name. The name is copied to the
argument field. Change the name if desired and click on the ‘Lookup ’ button to find its definition.

Show Item Value

The Source Popup Menu

Set and Delete Breakpoint at Item

Lookup Item’s Definition in Source Code

Show Item Type

Press Button 3 on Item

As a faster alternative, you can simply pressmouse button 3on the function name and select the
‘Lookup ’ item from the source popup menu.

As an even faster alternative, you can also double-click on a function call (an identifier followed
by a ‘( ’ character) to lookup the function definition.
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If a source file is not found, SeeSection 4.3.4 [Source Path], page 76, for specifying source
directories.

4.3.2 Textual Search

If the item you wish to search is visible in the source text, click withmouse button 1on it.
The identifier is copied to the argument field. Click on the ‘Find >> ’ button to find following
occurrences and on ‘Find >> ⇒ Find << () ’ to find previous occurrences.

By default,ddd finds only complete words. To search for arbitrary substrings, change the value
of the ‘Source ⇒ Find Words Only ’ option.

4.3.3 Looking up Previous Locations

After looking up a location, use ‘Edit ⇒ Undo’ (or the ‘Undo’ button on the command tool)
to go back to the original locations. ‘Edit ⇒ Redo’ brings you back again to the location you
looked for.

The Source Window

Program Counter

Disabled Breakpoint

Execution Position

Enabled Breakpoint

Click here to lookup ‘tree_test’

Click here to find further occurrences of ‘tree_test’Argument for command buttons on the right

4.3.4 Specifying Source Directories

Executable programs sometimes do not record the directories of the source files from which
they were compiled, just the names. Even when they do, the directories could be moved between
the compilation and your debugging session.
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Here’s howgdb accesses source files; other inferior debuggers have similar methods.

gdb has a list of directories to search for source files; this is called thesource path. Each time
gdb wants a source file, it tries all the directories in the list, in the order they are present in the list,
until it finds a file with the desired name. Note that the executable search path isnot used for this
purpose. Neither is the current working directory, unless it happens to be in the source path.

If gdb cannot find a source file in the source path, and the object program records a directory,
gdb tries that directory too. If the source path is empty, and there is no record of the compilation
directory,gdb looks in the current directory as a last resort.

To specify a source path for your inferior debugger, use ‘Edit ⇒ Debugger Settings ’
(seeSection 3.6.5 [Debugger Settings], page 71and search for appropriate entries (ingdb, this is
‘Search path for source files ’).

If ‘ Debugger Settings ’ has no suitable entry, you can also specify a source path for the
inferior debugger when invokingddd. SeeSection 2.1.4 [Inferior Debugger Options], page 24, for
details.

When usingjdb, you can set theCLASSPATHenvironment variable to specify directories where
jdb (andddd) should search for classes.

If DDD does not find a source file for any reason, check the following issues:

• In order to debug a program effectively, you need to generate debugging information when
you compile it. Without debugging information, the inferior debugger will be unable to locate
the source code. To request debugging information, specify the ‘-g ’ option when you run the
compiler. SeeSection 4.1 [Compiling for Debugging], page 73, for details.

• You may need to tell your inferior debugger where the source code files are. SeeSection 4.3.4
[Source Path], page 76, for details.

Using gdb, you can also create a local ‘.gdbinit ’ file that contains a linedirectory
path . Here,path is a colon-separated list of source paths.

4.4 Customizing the Source Window

The source window can be customized in a number of ways, most of them accessed via ‘Edit
⇒ Preferences ⇒ Source ’.
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Source Preferences

4.4.1 Customizing Glyphs

In the source text, the current execution position and breakpoints are indicated by symbols
(glyphs). As an alternative,ddd can also indicate these positions using text characters. If you
wish to disable glyphs, set ‘Edit ⇒ Preferences ⇒ Source ⇒ Show Position and
Breakpoints ⇒ as Text Characters ’ option. This also makesddd run slightly faster,
especially when scrolling.

This setting is tied to this resource:

ResourcedisplayGlyphs (class DisplayGlyphs)
If this is ‘on ’, the current execution position and breakpoints are displayed as glyphs; other-
wise, they are shown through characters in the text. The default is ‘on ’. SeeSection 2.1.2
[Options], page 16, for the ‘--glyphs ’ and ‘--no-glyphs ’ options.

You can further control glyphs using the following resources:

ResourcecacheGlyphImages(class CacheMachineCode)
Whether to cache (share) glyph images (‘on ’) or not (‘off ’). Caching glyph images re-
quires less X resources, but has been reported to fail with OSF/Motif 2.1 on XFree86 servers.
Default is ‘off ’ for OSF/Motif 2.1 or later ongnu/Linux machines, and ‘on ’ otherwise.

ResourceglyphUpdateDelay (class GlyphUpdateDelay)
A delay (in ms) that says how much time to wait before updating glyphs while scrolling the
source text. A small value results in glyphs being scrolled with the text, a large value disables
glyphs while scrolling and makes scrolling faster. Default:10 .

ResourcemaxGlyphs (class MaxGlyphs)
The maximum number of glyphs to be displayed (default:10). Raising this value causes
more glyphs to be allocated, possibly wasting resources that are never needed.
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4.4.2 Customizing Searching

Searching in the source text (seeSection 4.3.2 [Textual Search], page 76) is controlled by these
resources, changed via the ‘Source ’ menu:

ResourcefindCaseSensitive(class FindCaseSensitive)
If this is ‘on ’ (default), the ‘Find ’ commands are case-sensitive. Otherwise, occurrences
are found regardless of case.

ResourcefindWordsOnly (class FindWordsOnly)
If this is ‘on ’ (default), the ‘Find ’ commands find complete words only. Otherwise, arbi-
trary occurrences are found.

4.4.3 Customizing Source Appearance

You can haveddd show line numbers within the source window. Use ‘Edit ⇒
Preferences ⇒ Source ⇒ Display Source Line Numbers ’.

ResourcedisplayLineNumbers (class DisplayLineNumbers)
If this is ‘on ’, lines in the source text are prefixed with their respective line number. The
default is ‘off ’.

You can instructddd to indent the source code, leaving more room for breakpoints and
execution glyphs. This is done using the ‘Edit ⇒ Preferences ⇒ Source ⇒ Source
indentation ’ slider. The default value is0 for no indentation at all.

ResourceindentSource (class Indent)
The number of columns to indent the source code, such that there is enough place to display
breakpoint locations. Default:0.

By default,ddd uses a minimum indentation for script languages.

ResourceindentScript (class Indent)
The minimum indentation for script languages, such as Perl, Python, and Bash. Default:4.

The maximum width of line numbers is controlled by this resource.

ResourcelineNumberWidth (class LineNumberWidth)
The number of columns to use for line numbers (if displaying line numbers is enabled). Line
numbers wider than this value extend into the breakpoint space. Default:4.

If your source code uses a tab width different from8 (the default), you can set an alternate width
using the ‘Edit ⇒ Preferences ⇒ Source ⇒ Tab width ’ slider.

ResourcetabWidth (class TabWidth)
The tab width used in the source window (default:8)
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4.4.4 Customizing Source Scrolling

These resources control when the source window is scrolled:

ResourcelinesAboveCursor (class LinesAboveCursor)
The minimum number of lines to show before the current location. Default is2.

ResourcelinesBelowCursor (class LinesBelowCursor)
The minimum number of lines to show after the current location. Default is3.

4.4.5 Customizing Source Lookup

Somedbx andxdb variants do not properly handle paths in source file specifications. If you
want the inferior debugger to refer to source locations by source base names only, unset the ‘Edit
⇒ Preferences ⇒ Source ⇒ Refer to Program Sources by full path name ’
option.

This is related to the following resource:

ResourceuseSourcePath(class UseSourcePath)
If this is ‘off ’ (default), the inferior debugger refers to source code locations only by their
base names. If this is ‘on ’ (default),ddd uses the full source code paths.

By default, ddd caches source files in memory. This is convenient for remote debugging,
since remote file access may be slow. If you want to reduce memory usage, unset the ‘Edit ⇒
Preferences ⇒ Source ⇒ Cache source files ’ option.

This is related to the following resource:

ResourcecacheSourceFiles(class CacheSourceFiles)
Whether to cache source files (‘on ’, default) or not (‘off ’). Caching source files requires
more memory, but makesddd run faster.

4.4.6 Customizing File Filtering

You can control whetherddd should filter files to be opened.

ResourcefilterFiles (class FilterFiles)
If this is ‘on ’ (default),ddd filters files when opening execution files, core dumps, or source
files, such that the selection shows only suitable files. This requires thatddd opens each file,
which may take time. If this is ‘off ’, ddd always presents all available files.
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5 Stopping the Program

The principal purposes of using a debugger are so that you can stop your program before it
terminates; or so that, if your program runs into trouble, you can investigate and find out why.

Insideddd, your program may stop for any of several reasons, such as a signal, a breakpoint,
or reaching a new line after addd command such as ‘Step ’. You may then examine and change
variables, set new breakpoints or remove old ones, and then continue execution.

The inferior debuggers supported byddd support two mechanisms for stopping a program upon
specific events:

• A breakpoint makes your program stop whenever a certain point in the program is reached.
For each breakpoint, you can add conditions to control in finer detail whether your program
stops. Typically, breakpoints are set before running the program.

• A watchpoint is a special breakpoint that stops your program when the value of an expression
changes.

5.1 Breakpoints

5.1.1 Setting Breakpoints

You can set breakpoints by location or by name.

5.1.1.1 Setting Breakpoints by Location

Breakpoints are set at a specific location in the program.

If the source line is visible, click withmouse button 1on the left of the source line and then on
the ‘Break ’ button.

As a faster alternative, you can simply pressmouse button 3on the left of the source line and
select the ‘Set Breakpoint ’ item from the line popup menu.

The Line Popup Menu

Set Breakpoint at Line
Press Button 3 on Line

As an even faster alternative, you can simply double-click on the left of the source line to set a
breakpoint.
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As yet another alternative, you can select ‘Source ⇒ Breakpoints ’. Click on the ‘Break ’
button and enter the location.

(If you find this number of alternatives confusing, be aware thatddd users fall into three cate-
gories, which must all be supported.Novice usersexploreddd and may prefer to use one single
mouse button.Advanced usersknow how to use shortcuts and prefer popup menus.Experienced
usersprefer the command line interface.)

Breakpoints are indicated by a plain stop sign, or as ‘#n ’, wheren is the breakpoint number. A
greyed out stop sign (or ‘_n_’) indicates a disabled breakpoint. A stop sign with a question mark
(or ‘?n?’) indicates a conditional breakpoint or a breakpoint with an ignore count set.

If you set a breakpoint by mistake, use ‘Edit ⇒ Undo’ to delete it again.

5.1.1.2 Setting Breakpoints by Name

If the function name is visible, click withmouse button 1on the function name. The function
name is then copied to the argument field. Click on the ‘Break ’ button to set a breakpoint there.

As a shorter alternative, you can simply pressmouse button 3on the function name and select
the ‘Break at ’ item from the popup menu.

As yet another alternative, you can click on ‘Break... ’ from the Breakpoint editor (invoked
through ‘Source ⇒ Breakpoints ’) and enter the function name.

5.1.1.3 Setting Regexp Breakpoints

Usinggdb, you can also set a breakpoint on all functions that match a given string. ‘Break ⇒
Set Breakpoints at Regexp () ’ sets a breakpoint on all functions whose name matches the
regular expressiongiven in ‘() ’. Here are some examples:

• To set a breakpoint on every function that starts with ‘Xm’, set ‘() ’ to ‘ ^Xm’.

• To set a breakpoint on every member of class ‘Date ’, set ‘() ’ to ‘ ^Date:: ’.

• To set a breakpoint on every function whose name contains ‘_fun ’, set ‘() ’ to ‘ _fun ’.

• To set a breakpoint on every function that ends in ‘_test ’, set ‘() ’ to ‘ _test$ ’.

5.1.2 Deleting Breakpoints

To delete a visible breakpoint, click withmouse button 1on the breakpoint. The breakpoint
location is copied to the argument field. Click on the ‘Clear ’ button to delete all breakpoints
there.

If the function name is visible, click withmouse button 1on the function name. The function
name is copied to the argument field. Click on the ‘Clear ’ button to clear all breakpoints there.

As a faster alternative, you can simply pressmouse button 3on the breakpoint and select the
‘Delete Breakpoint ’ item from the popup menu.

As yet another alternative, you can select the breakpoint and click on ‘Delete ’ in the Break-
point editor (invoked through ‘Source ⇒ Breakpoints ’).

As an even faster alternative, you can simply double-click on the breakpoint while holding〈Ctrl〉.
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5.1.3 Disabling Breakpoints

Rather than deleting a breakpoint or watchpoint, you might prefer todisable it. This makes the
breakpoint inoperative as if it had been deleted, but remembers the information on the breakpoint
so that you canenable it again later.1

To disable a breakpoint, pressmouse button 3on the breakpoint symbol and select the
‘Disable Breakpoint ’ item from the breakpoint popup menu. To enable it again, select
‘Enable Breakpoint ’.

The Breakpoint Popup Menu

Disable Breakpoint

Edit Properties

Press Button 3 on Breakpoint

As an alternative, you can select the breakpoint and click on ‘Disable ’ or ‘ Enable ’ in the
Breakpoint editor (invoked through ‘Source ⇒ Breakpoints ’.

Disabled breakpoints are indicated by a grey stop sign, or ‘_n_’, where n is the breakpoint
number.

The ‘Disable Breakpoint ’ item is also accessible via the ‘Clear ’ button. Just press and
holdmouse button 1on the button to get a popup menu.

5.1.4 Temporary Breakpoints

A temporary breakpoint is immediately deleted as soon as it is reached.2

To set a temporary breakpoint, pressmouse button 3on the left of the source line and select the
‘Set Temporary Breakpoint ’ item from the popup menu.

As a faster alternative, you can simply double-click on the left of the source line while holding
〈Ctrl〉.

Temporary breakpoints are convenient to make the program continue up to a specific location:
just set the temporary breakpoint at this location and continue execution.

The ‘Continue Until Here ’ item from the popup menu sets a temporary breakpoint on the
left of the source line and immediately continues execution. Execution stops when the temporary
breakpoint is reached.

1 jdb does not support breakpoint disabling.
2 jdb does not support temporary breakpoints.
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The ‘Set Temporary Breakpoint ’ and ‘Continue Until Here ’ items are also acces-
sible via the ‘Break ’ button. Just press and holdmouse button 1on the button to get a popup
menu.

5.1.5 Editing Breakpoint Properties

You can change all properties of a breakpoint by pressingmouse button 3on the breakpoint
symbol and select ‘Properties ’ from the breakpoint popup menu. This will pop up a dialog
showing the current properties of the selected breakpoint.

Breakpoint Properties

Edit Breakpoint Condition

Edit Ignore Count

Disable Breakpoint

As an even faster alternative, you can simply double-click on the breakpoint.

• Click on ‘Lookup ’ to move the cursor to the breakpoint’s location.

• Click on ‘Enable ’ to enable the breakpoint.

• Click on ‘Disable ’ to disable the breakpoint.

• Click on ‘Temp’ to make the breakpoint temporary.3

• Click on ‘Delete ’ to delete the breakpoint.

5.1.6 Breakpoint Conditions

The simplest sort of breakpoint breaks every time your program reaches a specified place. You
can also specify acondition for a breakpoint. A condition is just a Boolean expression in your

3 gdb has no way to make a temporary breakpoint non-temporary again.
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programming language. A breakpoint with a condition evaluates the expression each time your
program reaches it, and your program stops only if the condition istrue.

This is the converse of using assertions for program validation; in that situation, you want to
stop when the assertion is violated–that is, when the condition is false. In C, if you want to test
an assertion expressed by the conditionassertion, you should set the condition ‘! assertion ’ on the
appropriate breakpoint.

Break conditions can have side effects, and may even call functions in your program. This can
be useful, for example, to activate functions that log program progress, or to use your own print
functions to format special data structures. The effects are completely predictable unless there is
another enabled breakpoint at the same address. (In that case,ddd might see the other breakpoint
first and stop your program without checking the condition of this one.)

Note that breakpoint commands are usually more convenient and flexible for the purpose of
performing side effects when a breakpoint is reached. SeeSection 5.1.8 [Breakpoint Commands],
page 85, for details.

5.1.7 Breakpoint Ignore Counts

A special case of a breakpoint condition is to stop only when the breakpoint has been reached a
certain number of times. This is so useful that there is a special way to do it, using theignore count
of the breakpoint. Every breakpoint has an ignore count, which is an integer. Most of the time, the
ignore count is zero, and therefore has no effect. But if your program reaches a breakpoint whose
ignore count is positive, then instead of stopping, it just decrements the ignore count by one and
continues. As a result, if the ignore count value isn, the breakpoint does not stop the nextn times
your program reaches it.

In the field ‘Ignore Count ’ of the ‘Breakpoint Properties ’ panel, you can specify the
breakpoint ignore count.4

If a breakpoint has a positive ignore count and a condition, the condition is not checked. Once
the ignore count reaches zero,ddd resumes checking the condition.

5.1.8 Breakpoint Commands

You can give any breakpoint (or watchpoint) a series ofddd commands to execute when your
program stops due to that breakpoint. For example, you might want to print the values of certain
expressions, or enable other breakpoints.5

Using the ‘Commands’ buttons of the ‘Breakpoint Properties ’ panel, you can edit com-
mands to be executed when the breakpoint is hit.

To edit breakpoint commands, click on ‘Edit >> ’ and enter the commands in the commands
editor. When done with editing, click on ‘Edit << ’ to close the commands editor.

Usinggdb, you can alsorecord a command sequence to be executed. To record a command
sequence, follow these steps:

1. Click on ‘Record ’ to begin the recording of the breakpoint commands.

4 jdb, Perl and somedbx variants do not support breakpoint ignore counts.
5 jdb, pydb, and somedbx variants do not support breakpoint commands.
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2. Now interact withddd. While recording,ddd does not execute commands, but simply records
them to be executed when the breakpoint is hit. The recorded debugger commands are shown
in the debugger console.

3. To stop the recording, click on ‘End’ or enter ‘end ’ at thegdb prompt. Tocancel the record-
ing, click on ‘Interrupt ’ or press〈ESC〉.

4. You can edit the breakpoint commands just recorded using ‘Edit >> ’.

5.1.9 Moving and Copying Breakpoints

To move a breakpoint to a different location, pressmouse button 1on the stop sign and drag it
to the desired location.6 This is equivalent to deleting the breakpoint at the old location and setting
a breakpoint at the new location. The new breakpoint inherits all properties of the old breakpoint,
except the breakpoint number.

To copy a breakpoint to a new location, press〈Shift〉 while dragging.

5.1.10 Looking up Breakpoints

If you wish to lookup a specific breakpoint, select ‘Source ⇒ Breakpoints ⇒ Lookup ’.
After selecting a breakpoint from the list and clicking the ‘Lookup ’ button, the breakpoint location
is displayed.

As an alternative, you can enter ‘#n ’ in the argument field, wheren is the breakpoint number,
and click on the ‘Lookup ’ button to find its definition.

5.1.11 Editing all Breakpoints

To view and edit all breakpoints at once, select ‘Source ⇒ Breakpoints ’. This will popup
theBreakpoint Editor which displays the state of all breakpoints.

6 When glyphs are disabled (seeSection 4.4 [Customizing Source], page 77), breakpoints cannot be
dragged. Delete and set breakpoints instead.
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Condition

Ignore Count
Commands

Edit Properties

The Breakpoint Editor

In the breakpoint editor, you can select individual breakpoints by clicking on them. Pressing
〈Ctrl〉 while clicking toggles the selection. To edit the properties of all selected breakpoints, click on
‘Props ’.

5.1.12 Hardware-Assisted Breakpoints

Usinggdb, a few more commands related to breakpoints can be invoked through the debugger
console:

hbreak position
Sets a hardware-assisted breakpoint atposition. This command requires hardware
support and some target hardware may not have this support. The main purpose of this
is eprom/rom code debugging, so you can set a breakpoint at an instruction without
changing the instruction.

thbreak pos
Set a temporary hardware-assisted breakpoint atpos.

Seesection “Setting Breakpoints” inDebugging with gdb, for details.

5.2 Watchpoints

You can make the program stop as soon as some variable value changes, or when some variable
is read or written. This is calledsetting a watchpoint on a variable.7

Watchpoints have much in common with breakpoints: in particular, you can enable and disable
them. You can also set conditions, ignore counts, and commands to be executed when a watched
variable changes its value.

7 Watchpoints are available ingdb and somedbx variants only. Inxdb, a similar feature is available via
xdb assertions; see thexdb documentation for details.
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Please note: on architectures without special watchpoint support, watchpoints currently make
the program execute two orders of magnitude more slowly. This is so because the inferior debugger
must interrupt the program after each machine instruction in order to examine whether the watched
value has changed. However, this delay can be well worth it to catch errors when you have no clue
what part of your program is the culprit.

5.2.1 Setting Watchpoints

If the variable name is visible, click withmouse button 1on the variable name. The variable
name is copied to the argument field. Otherwise, enter the variable name in the argument field.
Click on the ‘Watch ’ button to set a watchpoint there.

Usinggdb andjdb 1.2, you can set different types of watchpoints. Click and holdmouse button
1 on the ‘Watch ’ button to get a menu.

5.2.2 Editing Watchpoint Properties

To change the properties of a watchpoint, enter the name of the watched variable in the ar-
gument field. Click and holdmouse button 1on the ‘Watch ’ button and select ‘Watchpoint
Properties ’.

The Watchpoint Properties panel has the same functionality as the Breakpoint Properties panel
(seeSection 5.1.5 [Editing Breakpoint Properties], page 84). As an additional feature, you can click
on ‘Print ’ to see the current value of a watched variable.

5.2.3 Editing all Watchpoints

To view and edit all watchpoints at once, select ‘Data ⇒Watchpoints ’. This will popup
theWatchpoint Editor which displays the state of all watchpoints.

The Watchpoint Editor has the same functionality as the Breakpoint Editor (seeSection 5.1.11
[Editing all Breakpoints], page 86). As an additional feature, you can click on ‘Print ’ to see the
current value of a watched variable.

5.2.4 Deleting Watchpoints

To delete a watchpoint, enter the name of the watched variable in the argument field and click
the ‘Unwatch ’ button.

5.3 Interrupting

If the program is already running (seeChapter 6 [Running], page 91), you can interrupt it any
time by clicking the ‘Interrupt ’ button or typing〈ESC〉 in a ddd window.8 Usinggdb, this is
equivalent to sending aSIGINT (Interrupt) signal.

‘ Interrupt ’ and 〈ESC〉 also interrupt a running debugger command, such as printing data.

8 If 〈Ctrl+C〉 is not bound to ‘Copy’ (seeSection 3.1.11.2 [Customizing the Edit Menu], page 51), you can
also use〈Ctrl+C〉 to interrupt the running program.
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5.4 Stopping X Programs

If your program is a modal X application,ddd may interrupt it while it has grabbed the mouse
pointer, making further interaction impossible—your X display will be unresponsive to any user
actions.

By default,ddd will check after each interaction whether the pointer is grabbed. If the pointer is
grabbed,ddd will continue the debugged program such that you can continue to use your X display.

This is how this feature works: When the program stops,ddd checks for input events such as
keyboard or mouse interaction. Ifddd does not receive any event within the next 5 seconds,ddd
checks whether the mouse pointer is grabbed by attempting to grab and ungrab it. If this attempt
fails, thenddd considers the pointer grabbed.

Unfortunately,ddd cannot determine the program that grabbed the pointer—it may be the de-
bugged program, or another program. Consequently, you have another 10 seconds to cancel contin-
uation beforeddd continues the program automatically.

There is one situation where this fails: if you lock your X display whileddd is running, then
ddd will consider a resulting pointer grab as a result of running the program—and automatically
continue execution of the debugged program. Consequently, you can turn off this feature via ‘Edit
⇒ Preferences ⇒ General ⇒ Continue Automatically when Mouse Pointer
is Frozen ’.

5.4.1 Customizing Grab Checking

The grab checks are controlled by the following resources:

ResourcecheckGrabs (class CheckGrabs)
If this is ‘on ’ (default),ddd will check after each interaction whether the pointer is grabbed.
If this is so,ddd will automatically continue execution of debugged program.

ResourcecheckGrabDelay (class CheckGrabDelay)
The time to wait (in ms) after a debugger command before checking for a grabbed pointer. If
ddd sees some pointer event within this delay, the pointer cannot be grabbed and an explicit
check for a grabbed pointer is unnecessary. Default is5000 , or 5 seconds.

ResourcegrabAction (class grabAction)
The action to take after having detected a grabbed mouse pointer. This is a list of newline-
separated commands. Default iscont , meaning to continue the debuggee. Other possible
choices includekill (killing the debuggee) orquit (exitingddd).

ResourcegrabActionDelay (class grabActionDelay)
The time to wait (in ms) before taking an action due to having detected a grabbed pointer.
During this delay, a working dialog pops up telling the user about imminent execution of the
grab action (see the ‘grabAction ’ resource, above). If the pointer grab is released within
this delay, the working dialog pops down and no action is taken. This is done to exclude
pointer grabs from sources other than the debugged program (includingddd). Default is
10000 , or 10 seconds.
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6 Running the Program

You may start the debugged program with its arguments, if any, in an environment of your
choice. You may redirect your program’s input and output, debug an already running process, or
kill a child process.

6.1 Starting Program Execution

To start execution of the debugged program, select ‘Program ⇒ Run’. You will then be
prompted for the arguments to pass to your program. You can either select from a list of previ-
ously used arguments or enter own arguments in the text field. Afterwards, press the ‘Run’ button
to start execution with the selected arguments.

Click here to select

Empty Argument List
Other Arguments

Program Arguments

Click here to run

Starting a Program with Arguments

To run your program again, with the same arguments, select ‘Program ⇒ Run Again ’ or
press the ‘Run’ button on the command tool. You may also enterrun , followed by arguments at
the debugger prompt instead.

When you click on ‘Run’, your program begins to execute immediately. SeeChapter 5 [Stop-
ping], page 81, for a discussion of how to arrange for your program to stop. Once your program has
stopped, you may call functions in your program to examine data. SeeChapter 7 [Examining Data],
page 105, for details.

If the modification time of your symbol file has changed since the last timegdb read its symbols,
gdb discards its symbol table, and reads it again. When it does this,gdb andddd try to retain
your current debugger state, such as breakpoints.
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6.1.1 Your Program’s Arguments

The arguments to your program are specified by the arguments of the ‘run ’ command, as com-
posed in ‘Program ⇒ Run’.

In gdb, the arguments are passed to a shell, which expands wildcard characters and performs
redirection of I/O, and thence to your program. YourSHELL environment variable (if it exists)
specifies what shellgdb uses. If you do not defineSHELL, gdb uses ‘/bin/sh ’.

If you use another inferior debugger, the exact semantics on how the arguments are interpreted
depend on the inferior debugger you are using. Normally, the shell is used to pass the arguments,
so that you may use normal conventions (such as wildcard expansion or variable substitution) in
describing the arguments.

6.1.2 Your Program’s Environment

Your program normally inherits its environment from the inferior debugger, which again inherits
it from ddd, which again inherits it from its parent process (typically the shell or desktop).

In gdb, you can use the commandsset environment and unset environment
to change parts of the environment that affect your program. Seesection “Your Program’s
Environment” inDebugging with gdb, for details.

The following environment variables are set byddd:

DDD Set to a string indicating theddd version. By testing whetherDDDis set, a debuggee
(or inferior debugger) can determine whether it was invoked byddd.

TERM Set to ‘dumb’, the ddd terminal type. This is set for the inferior debugger only.1

TERMCAP Set to ‘’ (none), theddd terminal capabilities.

PAGER Set to ‘cat ’, the preferredddd pager.

The inferior debugger, in turn, might also set or unset some environment variables.

6.1.3 Your Program’s Working Directory

Your program normally inherits its working directory from the inferior debugger, which again
inherits it fromddd, which again inherits it from its parent process (typically the shell or desktop).

You can change the working directory of the inferior debugger via ‘File ⇒ Change
Directory ’ or via the ‘cd ’ command of the inferior debugger.

6.1.4 Your Program’s Input and Output

By default, the program you run underddd does input and output to the debugger console.
Normally, you can redirect your program’s input and/or output usingshell redirections with the
arguments—that is, additional arguments like ‘< input ’ or ‘ > output ’. You can enter these shell
redirections just like other arguments (seeSection 6.1.1 [Arguments], page 92).

1 If the debuggee runs in a separate execution window, the debuggee’sTERMvalue is set according to the
‘ termType ’ resource; SeeSection 6.2.1 [Customizing the Execution Window], page 94, for details.
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Warning:While input and output redirection work, you cannot use pipes to pass the output of the
program you are debugging to another program; if you attempt this,ddd may wind up debugging
the wrong program. SeeSection 6.3 [Attaching to a Process], page 94, for an alternative.

If command output is sent to the debugger console, it is impossible forddd to distinguish
between the output of the debugged program and the output of the inferior debugger.

Program output that confusesddd includes:

• Primary debugger prompts (e.g. ‘(gdb) ’, ‘ (dbx) ’ or ‘ (ladebug) ’)

• Secondary debugger prompts (e.g. ‘>’)

• Confirmation prompts (e.g. ‘(y or n) ’)

• Prompts for more output (e.g. ‘Press RETURN to continue ’)

• Display output (e.g. ‘$pc = 0x1234 ’)

If your program outputs any of these strings, you may encounter problems withddd mistaking
them for debugger output. These problems can easily be avoided by redirecting program I/O, for
instance to the separate execution window (seeSection 6.2 [Using the Execution Window], page 93).

If the inferior debugger changes the defaulttty settings, for instance through astty command
in its initialization file,ddd may also become confused. The same applies to debugged programs
which change the defaulttty settings.

The behavior of the debugger console can be controlled using the following resource:

ResourcelineBufferedConsole (class LineBuffered)
If this is ‘on ’ (default), each line from the inferior debugger is output on each own, such that
the final line is placed at the bottom of the debugger console. If this is ‘off ’, all lines are
output as a whole. This is faster, but results in a random position of the last line.

6.2 Using the Execution Window

By default, input and output of your program go to the debugger console. As an alternative,ddd
can also invoke anexecution window, where the program terminal input and output is shown.2

To activate the execution window, select ‘Program ⇒ Run in Execution Window ’.

Using the execution window has an important side effect: The output of your program no longer
gets intermixed with the output of the inferior debugger. This makes it far easier forddd to parse
the debugger output correctly. SeeSection 2.5.3 [Debugger Communication], page 38, for details
on the ‘bufferGDBOutput ’ resource.

The execution window is opened automatically as soon as you start the debugged program.
While the execution window is active,ddd redirects the standard input, output, and error streams
of your program to the execution window. Note that the device ‘/dev/tty ’ still refers to the
debugger console,not the execution window.

You can override theddd stream redirection by giving alternate redirection operations as argu-
ments. For instance, to have your program read fromfile, but to write to the execution window,
invoke your program with ‘< file ’ as argument. Likewise, to redirect the standard error output to
the debugger console, use ‘2> /dev/tty ’ (assuming the inferior debugger and/or yourunix shell
support standard error redirection).

2 The execution window is not available injdb.
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6.2.1 Customizing the Execution Window

You can customize theddd execution window and use a differenttty command. The command
is set by ‘Edit ⇒ Preferences ⇒ Helpers ⇒ Execution Window ’:

ResourcetermCommand (class TermCommand)
The command to invoke for the execution window—atty emulator that shows the in-
put/output of the debugged program. A Bourne shell command to run in the separatetty is
appended to this string. The string ‘@FONT@’ is replaced by the name of the fixed width font
used byddd. A simple value is

Ddd*termCommand: xterm -fn @FONT@ -e /bin/sh -c

You can also set the terminal type:

ResourcetermType (class TermType)
The terminal type provided by the ‘termCommand’ resource—that is, the value of theTERM
environment variable to be passed to the debugged program. Default: ‘xterm ’.

Whether the execution window is active or not, as set by ‘Program ⇒ Run in Execution
Window’, is saved using this resource:

ResourceseparateExecWindow(class Separate)
If ‘ on ’, the debugged program is executed in a separate execution window. If ‘off ’ (default),
the debugged program is executed in the console window.

6.3 Attaching to a Running Process

If the debugged program is already running in some process, you canattach to this process
(instead of starting a new one with ‘Run’).3

To attachddd to a process, select ‘File ⇒ Attach to Process ’. You can now choose
from a list of processes. Then, press the ‘Attach ’ button to attach to the specified process.

3 jdb, pydb, Perl, and Bash do not support attaching the debugger to running processes.
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Selecting a Process to Attach

Click to attach

Selected process
ps output

The first thingddd does after arranging to debug the specified process is to stop it. You can
examine and modify an attached process with all theddd commands that are ordinarily available
when you start processes with ‘Run’. You can insert breakpoints; you can step and continue; you
can modify storage. If you would rather the process continue running, you may use ‘Continue ’
after attachingddd to the process.

When using ‘Attach to Process ’, you should first use ‘Open Program ’ to specify the
program running in the process and load its symbol table.

When you have finished debugging the attached process, you can use the ‘File ⇒ Detach
Process ’ to release it fromddd control. Detaching the process continues its execution. After
‘Detach Process ’, that process andddd become completely independent once more, and you
are ready to attach another process or start one with ‘Run’.

You can customize the list of processes shown by defining an alternate command to list pro-
cesses. See ‘Edit ⇒ Preferences ⇒ Helpers ⇒ List Processes ’; See Section 6.3.1
[Customizing Attaching to Processes], page 95, for details.

6.3.1 Customizing Attaching to Processes

When attaching to a process (seeSection 6.3 [Attaching to a Process], page 94), ddd uses aps
command to get the list of processes. This command is defined by the ‘psCommand’ resource.

ResourcepsCommand (class PsCommand)
The command to get a list of processes. Usuallyps . Depending on your system, useful
alternate values includeps -ef andps ux . The first line of the output must either contain a
‘PID ’ title, or each line must begin with a process ID.

Note that the output of this command is filtered byddd; a process is only shown if it can
be attached to. Theddd process itself as well as the process of the inferior debugger are
suppressed, too.
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6.4 Program Stops

After the program has been started, it runs until one of the following happens:

• A breakpoint is reached (seeSection 5.1 [Breakpoints], page 81).

• A watched value changes (seeSection 5.2 [Watchpoints], page 87).

• The program is interrupted (seeSection 5.3 [Interrupting], page 88).

• A signal is received (seeSection 6.10 [Signals], page 102).

• Execution completes.

ddd shows the current program status in the debugger console. The current execution position
is highlighted by an arrow.

If ‘ Edit ⇒ Preferences ⇒ General ⇒ Uniconify When Ready ’ is set, ddd auto-
matically deiconifies itself when the program stops. This way, you can iconifyddd during a lengthy
computation and have it uniconify as soon as the program stops.

6.5 Resuming Execution

6.5.1 Continuing

To resume execution, at the current execution position, click on the ‘Continue ’ button. Any
breakpoints set at the current execution position are bypassed.

6.5.2 Stepping one Line

To execute just one source line, click on the ‘Step ’ button. The program is executed until
control reaches a different source line, which may be in a different function. Then, the program is
stopped and control returns toddd.

Warning: If you use the ‘Step ’ button while control is within a function that was compiled
without debugging information, execution proceeds until control reaches a function that does have
debugging information. Likewise, it will not step into a function which is compiled without de-
bugging information. To step through functions without debugging information, use the ‘Stepi ’
button (seeSection 8.2 [Machine Code Execution], page 142).

In gdb, the ‘Step ’ button only stops at the first instruction of a source line. This prevents the
multiple stops that used to occur in switch statements, for loops, etc. ‘Step ’ continues to stop if a
function that has debugging information is called within the line.

Also, the ‘Step ’ in gdb only enters a subroutine if there is line number information for the
subroutine. Otherwise it acts like the ‘Next ’ button.

6.5.3 Continuing to the Next Line

To continue to the next line in the current function, click on the ‘Next ’ button. This is similar
to ‘Step ’, but any function calls appearing within the line of code are executed without stopping.

Execution stops when control reaches a different line of code at the original stack level that was
executing when you clicked on ‘Next ’.
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6.5.4 Continuing Until Here

To continue running until a specific location is reached, use the ‘Continue Until Here ’
facility from the line popup menu. SeeSection 5.1.4 [Temporary Breakpoints], page 83, for a
discussion.

6.5.5 Continuing Until a Greater Line is Reached

To continue until a greater line in the current function is reached, click on the ‘Until ’ button.
This is useful to avoid single stepping through a loop more than once.

‘Until ’ is like ‘ Next ’, except that when ‘Until ’ encounters a jump, it automatically contin-
ues execution until the program counter is greater than the address of the jump.

This means that when you reach the end of a loop after single stepping though it, ‘until ’ makes
your program continue execution until it exits the loop. In contrast, clicking on ‘Next ’ at the end
of a loop simply steps back to the beginning of the loop, which forces you to step through the next
iteration.

‘Until ’ always stops your program if it attempts to exit the current stack frame.

‘Until ’ works by means of single instruction stepping, and hence is slower than continuing
until a breakpoint is reached.

6.5.6 Continuing Until Function Returns

To continue running until the current function returns, use the ‘Finish ’ button. The returned
value (if any) is printed.

6.6 Continuing at a Different Address

Ordinarily, when you continue your program, you do so at the place where it stopped. You can
instead continue at an address of your own choosing.

The most common occasion to use this feature is to back up—perhaps with more breakpoints
set-over a portion of a program that has already executed, in order to examine its execution in more
detail.

To set the execution position to the current location, use ‘Set Execution Position ’
from the breakpoint popup menu. This item is also accessible by pressing and holding the
‘Break/Clear ’ button.4

As a quicker alternative, you can also pressmouse button 1on the arrow and drag it to a different
location.5

4 jdb, pydb, Perl, and Bash do not support altering the execution position.
5 When glyphs are disabled (seeSection 4.4 [Customizing Source], page 77), dragging the execution posi-

tion is not possible. Set the execution position explicitly instead.
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Click on arrow, ... ... hold mouse button and move ... ... to the final position.

Changing the Execution Position by Dragging the Execution Arrow

Moving the execution position does not change the current stack frame, or the stack pointer, or
the contents of any memory location or any register other than the program counter.

Some inferior debuggers (notablygdb) allow you to set the new execution position into a differ-
ent function from the one currently executing. This may lead to bizarre results if the two functions
expect different patterns of arguments or of local variables. For this reason, moving the execution
position requests confirmation if the specified line is not in the function currently executing.

After moving the execution position, click on ‘Continue ’ to resume execution.

6.7 Examining the Stack

When your program has stopped, the first thing you need to know is where it stopped and how it
got there.

Each time your program performs a function call, information about the call is generated. That
information includes the location of the call in your program, the arguments of the call, and the
local variables of the function being called. The information is saved in a block of data called a
stack frame. The stack frames are allocated in a region of memory called thecall stack.

When your program stops, theddd commands for examining the stack allow you to see all of
this information.

One of the stack frames isselected by ddd and manyddd commands refer implicitly to the
selected frame. In particular, whenever you askddd for the value of a variable in your program, the
value is found in the selected frame. There are specialddd commands to select whichever frame
you are interested in.

6.7.1 Stack Frames

The call stack is divided up into contiguous pieces calledstack frames, or frames for short; each
frame is the data associated with one call to one function. The frame contains the arguments given
to the function, the function’s local variables, and the address at which the function is executing.
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When your program is started, the stack has only one frame, that of the functionmain . This is
called theinitial frame or theoutermost frame. Each time a function is called, a new frame is made.
Each time a function returns, the frame for that function invocation is eliminated. If a function is
recursive, there can be many frames for the same function. The frame for the function in which
execution is actually occurring is called theinnermost frame. This is the most recently created of
all the stack frames that still exist.

Inside your program, stack frames are identified by their addresses. A stack frame consists of
many bytes, each of which has its own address; each kind of computer has a convention for choosing
one byte whose address serves as the address of the frame. Usually this address is kept in a register
called theframe pointer register while execution is going on in that frame.

gdb assigns numbers to all existing stack frames, starting with zero for the innermost frame, one
for the frame that called it, and so on upward. These numbers do not really exist in your program;
they are assigned bygdb to give you a way of designating stack frames ingdb commands.

6.7.2 Backtraces

ddd provides abacktrace window showing a summary of how your program got where it is.
It shows one line per frame, for many frames, starting with the currently executing frame (frame
zero), followed by its caller (frame one), and on up the stack.

To enable the backtrace window, select ‘Status ⇒ Backtrace ’.

Selecting a Frame from the Backtrace Viewer

Called functions

Current frame in source window

Calling functions

Using gdb, each line in the backtrace shows the frame number and the function name. The
program counter value is also shown—unless you use thegdb command ‘set print address
off ’. The backtrace also shows the source file name and line number, as well as the arguments to
the function. The program counter value is omitted if it is at the beginning of the code for that line
number.
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6.7.3 Selecting a Frame

Most commands for examining the stack and other data in your program work on whichever
stack frame is selected at the moment. Here are the commands for selecting a stack frame.6

In the backtrace window, you canselectan arbitrary frame to move from one stack frame to
another. Just click on the desired frame.

The ‘Up’ button selects the function that called the current one—that is, it moves one frame up.

The ‘Down’ button selects the function that was called by the current one—that is, it moves one
frame down.

You can also directly type theup anddown commands at the debugger prompt. Typing〈Ctrl+Up〉
and〈Ctrl+Down〉, respectively, will also move you through the stack.

‘Up’ and ‘Down’ actions can be undone via ‘Edit ⇒ Undo’.

6.8 “Undoing” Program Execution

If you take a look at the ‘Edit ⇒ Undo’ menu item after an execution command, you’ll find
thatddd offers you to undo execution commands just as other commands. Does this mean thatddd
allows you to go backwards in time, undoing program execution as well as undoing any side-effects
of your program?

Sorry—we must disappoint you.ddd cannot undo what your program did. (After a little bit
of thought, you’ll find that this would be impossible in general.) However,ddd can do something
different: it can showpreviously recorded statesof your program.

After “undoing” an execution command (via ‘Edit ⇒ Undo’, or the ‘Undo’ button), the exe-
cution position moves back to the earlier position and displayed variables take their earlier values.
Your program state is in fact unchanged, butddd gives you aviewon the earlier state as recorded
by ddd.

In this so-calledhistoric mode, most normalddd commands that would query further infor-
mation from the program are disabled, since the debugger cannot be queried for the earlier state.
However, you can examine the current execution position, or the displayed variables. Using ‘Undo’
and ‘Redo’, you can move back and forward in time to examine how your program got into the
present state.

To let you know that you are operating in historic mode, the execution arrow gets a dashed-line
appearance (indicating a past position); variable displays also come with dashed lines. Furthermore,
the status line informs you that you are seeing an earlier program state.

Here’s how historic mode works: each time your program stops,ddd collects the current exe-
cution position and the values of displayed variables. Backtrace, thread, and register information is
also collected if the corresponding dialogs are open. When “undoing” an execution command,ddd
updates its view from this collected state instead of querying the program.

If you want to collect this information without interrupting your program—within a loop, for
instance—you can place a breakpoint with an associatedcont command (seeSection 5.1.8 [Break-
point Commands], page 85). When the breakpoint is hit,ddd will stop, collect the data, and execute
the ‘cont ’ command, resuming execution. Using a later ‘Undo’, you can step back and look at
every single loop iteration.

6 Perl does not allow changing the current stack frame.
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To leave historic mode, you can use ‘Redo’ until you are back in the current program state.
However, anyddd command that refers to program state will also leave historic mode immediately
by applying to the current program state instead. For instance, ‘Up’ leaves historic mode immedi-
ately and selects an alternate frame in the restored current program state.

If you want to see the history of a specific variable, as recorded during program stops, you can
enter theddd command

graph history name

This returns a list of all previously recorded values of the variablename, using array syntax.
Note thatname must have been displayed at earlier program stops in order to record values.

6.9 Examining Threads

In some operating systems, a single program may have more than onethreadof execution. The
precise semantics of threads differ from one operating system to another, but in general the threads
of a single program are akin to multiple processes—except that they share one address space (that
is, they can all examine and modify the same variables). On the other hand, each thread has its own
registers and execution stack, and perhaps private memory.

For debugging purposes,ddd lets you display the list of threads currently active in your program
and lets you select thecurrent thread—the thread which is the focus of debugging.ddd shows all
program information from the perspective of the current thread.7

Current thread

Change thread properties

Click on group to toggle view

Selecting Threads

To view all currently active threads in your program, select ‘Status ⇒ Threads ’. The cur-
rent thread is highlighted. Select any thread to make it the current thread.

Usingjdb, additional functionality is available:

7 Currently, threads are supported ingdb andjdb only.



102 Debugging with DDD

• Select athread groupto switch between viewing all threads and the threads of the selected
thread group;

• Click on ‘Suspend ’ to suspend execution of the selected threads;

• Click on ‘Resume’ to resume execution of the selected threads.

For more information on threads, see thejdb andgdb documentation (seesection “Debugging
Programs with Multiple Threads” inDebugging with gdb).

6.10 Handling Signals

A signal is an asynchronous event that can happen in a program. The operating system defines
the possible kinds of signals, and gives each kind a name and a number. For example, inunix,
SIGINT is the signal a program gets when you type an interrupt;SIGSEGVis the signal a program
gets from referencing a place in memory far away from all the areas in use;SIGALRMoccurs when
the alarm clock timer goes off (which happens only if your program has requested an alarm).

Some signals, includingSIGALRM, are a normal part of the functioning of your program. Oth-
ers, such asSIGSEGV, indicate errors; these signals arefatal (kill your program immediately) if
the program has not specified in advance some other way to handle the signal.SIGINT does not
indicate an error in your program, but it is normally fatal so it can carry out the purpose of the
interrupt: to kill the program.

gdb has the ability to detect any occurrence of a signal in your program. You can tellgdb in
advance what to do for each kind of signal.

Normally, ddd is set up to ignore non-erroneous signals likeSIGALRM(so as not to interfere
with their role in the functioning of your program) but to stop your program immediately whenever
an error signal happens. Inddd, you can view and edit these settings via ‘Status ⇒ Signals ’.

‘Status ⇒ Signals ’ pops up a panel showing all the kinds of signals and howgdb has been
told to handle each one. The settings available for each signal are:

Stop If set, gdb should stop your program when this signal happens. This also implies
‘Print ’ being set.

Print If set,gdb should print a message when this signal happens.

If unset,gdb should not mention the occurrence of the signal at all. This also implies
‘Stop ’ being unset.

Pass If set,gdb should allow your program to see this signal; your program can handle the
signal, or else it may terminate if the signal is fatal and not handled.

If unset,gdb should not allow your program to see this signal.
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GDB Signal Handling Panel (Excerpt)

The entry ‘All Signals ’ is special. Changing a setting here affectsall signals at once—
except those used by the debugger, typicallySIGTRAPandSIGINT .

To undo any changes, use ‘Edit ⇒ Undo’. The ‘Reset ’ button restores the saved settings.

When a signal stops your program, the signal is not visible until you continue. Your program
sees the signal then, if ‘Pass ’ is in effect for the signal in questionat that time. In other words,
aftergdb reports a signal, you can change the ‘Pass ’ setting in ‘Status ⇒ Signals ’ to control
whether your program sees that signal when you continue.

You can also cause your program to see a signal it normally would not see, or to give it any
signal at any time. The ‘Send’ button will resume execution where your program stopped, but
immediately give it the signal shown.

On the other hand, you can also prevent your program from seeing a signal. For example, if
your program stopped due to some sort of memory reference error, you might store correct values
into the erroneous variables and continue, hoping to see more execution; but your program would
probably terminate immediately as a result of the fatal signal once it saw the signal. To prevent this,
you can resume execution using ‘Commands⇒ Continue Without Signal ’.

Signal settings are not saved across DDD invocations, since changed signal settings are normally
useful within specific projects only. Instead, signal settings are saved with the current session, using
‘File ⇒ Save Session As ’.
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6.11 Killing the Program

You can kill the process of the debugged program at any time using the ‘Kill ’ button.

Killing the process is useful if you wish to debug a core dump instead of a running process.gdb
ignores any core dump file while your program is running.

The ‘Kill ’ button is also useful if you wish to recompile and relink your program, since on
many systems it is impossible to modify an executable file while it is running in a process. In this
case, when you next click on ‘Run’, gdb notices that the file has changed, and reads the symbol
table again (while trying to preserve your current debugger state).
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7 Examining Data

ddd provides several means to examine data.

• The quickest way to examine variables is to move the pointer on an occurrence in the source
text. The value is displayed in the source line; after a second, a popup window (calledvalue
tip) shows the variable value. This is useful for quick examination of several simple values.

• If you want to refer to variable values at a later time, you canprint the value in the debugger
console. This allows for displaying and examining larger data structures.

• If you want to examine complex data structures, you candisplay them graphically in the data
window. Displays remain effective until you delete them; they are updated each time the
program stops. This is useful for large dynamic structures.

• If you want to examine arrays of numeric values, you canplot them graphically in a separate
plot window. The plot is updated each time the program stops. This is useful for large numeric
arrays.

• Usinggdb or dbx, you can alsoexamine memory contents in any of several formats, inde-
pendently of your program’s data types.

7.1 Showing Simple Values using Value Tips

To display the value of a simple variable, move the mouse pointer on its name. After a second, a
small window (calledvalue tip) pops up showing the value of the variable pointed at. The window
disappears as soon as you move the mouse pointer away from the variable. The value is also shown
in the status line.

Displaying Simple Values using Value Tips

Move pointer on item

The value tip shows its value

You can disable value tips via ‘Edit ⇒ Preferences ⇒ General ⇒ Automatic
display of variable values as popup tips ’.
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You can disable displaying variable values in the status line via ‘Edit ⇒ Preferences ⇒
General ⇒ Automatic display of variable values in the status line ’.

These customizations are tied to the following resources:

ResourcevalueTips (class Tips)
Whether value tips are enabled (‘on ’, default) or not (‘off ’). Value tips affectddd perfor-
mance and may be distracting for some experienced users.

ResourcevalueDocs (class Docs)
Whether the display of variable values in the status line is enabled (‘on ’, default) or not
(‘off ’).

You can turn off value tips via ‘Edit ⇒ Preferences ⇒ General ⇒ Automatic
Display of Variable Values ’.

7.2 Printing Simple Values in the Debugger Console

The variable value can also be printed in the debugger console, making it available for future
operations. To print a variable value, select the desired variable by clickingmouse button 1on its
name. The variable name is copied to the argument field. By clicking the ‘Print ’ button, the value
is printed in the debugger console. The printed value is also shown in the status line.

As a shorter alternative, you can simply pressmouse button 3on the variable name and select
the ‘Print ’ item from the popup menu.

The value is printed
in the debugger console

Select ‘Print’ on item

Displaying Simple Values in the Debugger Console
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In gdb, the ‘Print ’ button generates aprint command, which has several more options. See
section “Examining Data” inDebugging with gdb, for gdb-specific expressions, variables, and
output formats.

7.3 Displaying Complex Values in the Data Window

To explore complex data structures, you candisplay them permanently in thedata window. The
data window displays selected data of your program, showing complex data structures graphically.
It is updated each time the program stops.

7.3.1 Display Basics

This section discusses how to create, manipulate, and delete displays. The essentials are:

• Click on ‘Display ’ to display the variable in ‘() ’.

• Click on a display to select it.

• Click on ‘Undisplay ’ to delete the selected display.

7.3.1.1 Creating Single Displays

To create a new display showing a specific variable, select the variable by clickingmouse button
1 on its name. The variable name is copied to the argument field. By clicking the ‘Display ’
button, a new display is created in the data window. The data window opens automatically as soon
as you create a display.

Scroll the data display

Displaying Data

As a shorter alternative, you can simply pressmouse button 3on the variable name and select
‘Display ’ from the popup menu.

As an even faster alternative, you can also double-click on the variable name.

As another alternative, you may also enter the expression to be displayed in the argument field
and press the ‘Display ’ button.
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Finally, you may also type in a command at the debugger prompt:

graph display expr [clustered] [at ( x, y)]
[dependent on display] [[now or] when in scope]

This command creates a new display showing the value of the expressionexpr. The optional
parts have the following meaning:

clustered
If given, the new display is created in a cluster. SeeSection 7.3.1.9 [Clustering],
page 114, for a discussion.

at ( x, y) If given, the new display is created at the position (x, y). Otherwise, a default position
is assigned.

dependent on display
If given, an edge from the display numbered or nameddisplay to the new display
is created. Otherwise, no edge is created. SeeSection 7.3.4.1 [Dependent Values],
page 120, for details.

when in scope
now or when in scope

If ‘ when in ’ is given, the display creation isdeferred until execution reaches the
givenscope (a function name, as in the backtrace output).

If ‘ now or when in ’ is given, ddd first attempts to create the display immediately.
The display is deferred only if display creation fails.

If neither ‘when in ’ suffix nor ‘now or when in ’ suffix is given, the display is cre-
ated immediately.

7.3.1.2 Selecting Displays

Each display in the data window has atitle bar containing thedisplay numberand the displayed
expression (thedisplay name). Below the title, thedisplay valueis shown.

You can select single displays by clicking on them withmouse button 1.

You canextendan existing selection by pressing the〈Shift〉 key while selecting. You can also
togglean existing selection by pressing the〈Shift〉 key while selecting already selected displays.

Single displays may also be selected by using the arrow keys〈Up〉, 〈Down〉, 〈Left〉, and〈Right〉.

Multiple displaysare selected by pressing and holdingmouse button 1somewhere on the window
background. By moving the pointer while holding the button, a selection rectangle is shown; all
displays fitting in the rectangle are selected when mouse button 1 is released.

If the 〈Shift〉 key is pressed while selecting, the existing selection isextended.

By double-clicking on a display title, the display itself and all connected displays are automati-
cally selected.
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Selecting Multiple Displays

Selection rectangle

7.3.1.3 Showing and Hiding Details

Aggregate values (i.e. records, structs, classes, and arrays) can be shownexpanded, that is,
displaying all details, orhidden, that is, displayed as ‘{...} ’.

To show details about an aggregate, select the aggregate by clickingmouse button 1on its name
or value and click on the ‘Show’ button. Details are shown for the aggregate itself as well as for all
contained sub-aggregates.

To hide details about an aggregate, select the aggregate by clickingmouse button 1on its name
or value and click on the ‘Hide ’ button.

Showing Display Detail

Detailed view Select and show detailHidden details

When pressing and holdingmouse button 1on the ‘Show/Hide ’ button, a menu pops up with
even more alternatives:
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Show More ()
Shows details of all aggregates currently hidden, but not of their sub-aggregates. You
can invoke this item several times in a row to reveal more and more details of the
selected aggregate.

Show Just ()
Shows details of the selected aggregate, but hides all sub-aggregates.

Show All ()
Shows all details of the selected aggregate and of its sub-aggregates. This item is
equivalent to the ‘Show’ button.

Hide () Hide all details of the selected aggregate. This item is equivalent to the ‘Hide ’ button.

As a faster alternative, you can also pressmouse button 3on the aggregate and select the appro-
priate menu item.

As an even faster alternative, you can also double-clickmouse button 1on a value. If some part
of the value is hidden, more details will be shown; if the entire value is shown, double-clicking will
hide the value instead. This way, you can double-click on a value until you get the right amount of
details.

If all details of a display are hidden, the display is calleddisabled ; this is indicated by the string
‘ (Disabled) ’.

Displays can also be disabled or enabled via addd command, which you enter at the debugger
prompt:

graph disable display displays. . .

disables the given displays.

graph enable display displays. . .

re-enables the given displays.

In both commands,displays. . . is either

• a space-separated list of display numbers to disable or enable, or

• a single display name. If you specify a display by name, all displays with this name will be
affected.

Use ‘Edit ⇒ Undo’ to undo disabling or enabling displays.

7.3.1.4 Rotating Displays

Arrays, structures and lists can be oriented horizontally or vertically. To change the orientation
of a display, select it and then click on the ‘Rotate ’ button.

As a faster alternative, you can also pressmouse button 3on the array and select ‘Rotate ’ from
the popup menu.
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Select and Rotate

Rotating an Array

If a structure or list is oriented horizontally,ddd automatically suppresses the member names.
This can be handy for saving space.

The last chosen display orientation is used for the creation of new displays. If you recently
rotated an array to horizontal orientation, the next array you create will also be oriented horizontally.
These settings are tied to the following resources:

ResourcearrayOrientation (class Orientation)
How arrays are to be oriented. Possible values are ‘XmVERTICAL’ (default) and
‘XmHORIZONTAL’.

ResourceshowMemberNames(class ShowMemberNames)
Whether to show struct member names or not. Default is ‘on ’.

ResourcestructOrientation (class Orientation)
How structs are to be oriented. Possible values are ‘XmVERTICAL’ (default) and
‘XmHORIZONTAL’.

7.3.1.5 Displaying Local Variables

You can display all local variables at once by choosing ‘Data ⇒ Display Local
Variables ’. When usingdbx, xdb, jdb, or Perl, this displays all local variables, including the
arguments of the current function. When usinggdb or pydb, function arguments are contained in
a separate display, activated by ‘Data ⇒ Display Arguments ’.

The display showing the local variables can be manipulated just like any other data display.
Individual variables can be selected and dereferenced.
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Dereferencing a Local Variable

via popup menu
Dereference

Local arguments

Dereferenced pointer

7.3.1.6 Displaying Program Status

You can create a display from the output of an arbitrary debugger command. By entering
graph display ‘ command ‘

the output ofcommand is turned into astatus displayupdated each time the program stops.

For instance, the command
graph display ‘where‘

creates a status display named ‘Where’ that shows the current backtrace.

If you are usinggdb, ddd provides a panel from which you can choose useful status displays.
Select ‘Data ⇒ Status Displays ’ and pick your choice from the list.

Click here...

... to enable or disable this status display

Activating Status Displays
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Refreshing status displays at each stop takes time; you should delete status displays as soon as
you don’t need them any more.

7.3.1.7 Refreshing the Data Window

The data window is automatically updated orrefreshed each time the program stops. Values that
have changed since the last refresh are highlighted.

However, there may be situations where you should refresh the data window explicitly. This is
especially the case whenever you changed debugger settings that could affect the data format, and
want the data window to reflect these settings.

You can refresh the data window by selecting ‘Data ⇒ Refresh Displays ’.

As an alternative, you can pressmouse button 3on the background of the data window and select
the ‘Refresh Displays ’ item.

Typing

graph refresh

at the debugger prompt has the same effect.

7.3.1.8 Display Placement

By default, displays are created fromtop to bottom—that is, each new display is placed below
the downmost one. You can change this setting toleft to right via ‘Edit ⇒ Preferences ⇒
Data ⇒ Placement ⇒ Left to right ’.

Data Preferences

This setting is tied to the following resource:
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ResourcedisplayPlacement (class Orientation)
If this is ‘XmVERTICAL’ (default), ddd places each new independent display below the
downmost one. If this is ‘XmHORIZONTAL’, each new independent display is placed on the
right of the rightmost one.

Note that changing the placement of new displays also affects the placement ofdependent dis-
plays(seeSection 7.3.4.1 [Dependent Values], page 120). In top to bottommode, dependent dis-
plays are created on the right of the originating display; inleft to right mode, dependent displays
are created on the below the originating display.

7.3.1.9 Clustering Displays

If you examine several variables at once, having a separate display for each of them uses a lot
of screen space. This is whyddd supportsclusters. A cluster merges several logical data displays
into one physical display, saving screen space.

There are two ways to create clusters:

• You can create clustersmanually. This is done by selecting the displays to be clustered and
choosing ‘Undisp ⇒ Cluster () ’. This creates a new cluster from all selected displays.
If an already existing cluster is selected, too, the selected displays will be clustered into the
selected cluster.

• You can create a clusterautomaticallyfor all independent data displays, such that all new
data displays will automatically be clustered, too. This is achieved by enabling ‘Edit ⇒
Preferences ⇒ Data ⇒ Placement ⇒ clustered ’.

Displays

uni  = 

ii  = 7
bit1 = 1
bit2 = 3
u  = {...}

guni  = 
ii = 1
{...}
{...}

pi  = 3.14159274
sqrt2 = 1.4142135623730951

1: uni
ii  = 7
bit1 = 1
bit2 = 3
u  = {...}

2: guni
ii = 1
{...}
{...} 4: sqrt2

1.4142135623730951

3: pi
3.14159274

Clustered and Unclustered Displays

Displays in a cluster can be selected and manipulated like parts of an ordinary display; in par-
ticular, you can show and hide details, or dereference pointers. However, edges leading to clustered
displays can not be shown, and you must either select one or all clustered displays.

Disabling a cluster is calledunclustering, and again, there are two ways of doing it:

• You can uncluster displaysmanually, by selecting the cluster and choosing ‘Undisp ⇒
Uncluster () ’.

• You can uncluster all current and future displays by disabling ‘Edit ⇒ Preferences ⇒
Data ⇒ Placement ⇒ clustered ’.
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7.3.1.10 Creating Multiple Displays

To display several successive objects of the same type (a section of an array, or an array of
dynamically determined size), you can use the notation ‘from.. to ’ in display expressions.

from andto are numbers that denote the first and last expression to display. Thus,

graph display argv[0..9]

creates 10 new displays for ‘argv[0] ’, ‘ argv[1] ’, . . . , ‘argv[9] ’. The displays are clustered
automatically (seeSection 7.3.1.9 [Clustering], page 114), such that you can easily handle the set
just like an array.

The ‘from.. to ’ notation can also be used multiple times. For instance,

graph display 1..5 * 1..5

creates a handy small multiplication table.

The ‘from.. to ’ notation creates several displays, which takes time to create and update. If you
want to display only a part of an array,array slicesare a more efficient way. SeeSection 7.3.2.1
[Array Slices], page 117, for a discussion.

7.3.1.11 Editing all Displays

You can view the state of all displays by selecting ‘Data ⇒ Displays ’. This invokes the
Display Editor.

The Display Editor

Selected Display
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The Display Editor shows the properties of each display, using the following fields:

‘Num’ The display number.

‘Expression ’
The displayed expression.

‘State ’ One of

‘enabled ’
Normal state.

‘disabled ’
Disabled; all details are hidden. Use ‘Show’ to enable.

‘not active ’
Out of scope.

‘deferred ’
Will be created as soon as its ‘Scope ’ is reached (seeSection 7.3.1.1
[Creating Single Displays], page 107).

‘clustered ’
Part of a cluster (seeSection 7.3.1.9 [Clustering], page 114). Use
‘Undisp ⇒ Uncluster ’ to uncluster.

‘alias of display ’
A suppressed alias of displaydisplay (seeSection 7.3.4.3 [Shared Struc-
tures], page 121).

‘Scope ’ The scope in which the display was created. For deferred displays, this is the scope in
which the display will be created.

‘Address ’
The address of the displayed expression. Used for resolving aliases (seeSection 7.3.4.3
[Shared Structures], page 121).

7.3.1.12 Deleting Displays

To delete a single display, select its title or value and click on the ‘Undisp ’ button. As an
alternative, you can also pressmouse button 3on the display and select the ‘Undisplay ’ item.

When a display is deleted, its immediate ancestors and descendants are automatically selected,
so that you can easily delete entire graphs.

If you have selected only part of a display, clicking on the ‘Undisp ’ button allows you tosup-
pressthis part—by applying theSuppress Valuestheme on the part. You’ll be asked for confirmation
first. SeeSection 7.3.5.1 [Using Data Themes], page 125, for details.
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*()2: tree
(Tree *) 0x804eb50

value  = 7
_name  = 0x804a8c0 "Ada"
_left  = 0x804eb80
_right  = 0x804ec10

*()

value  = 7
_name  = 0x804a8c0 "Ada"
_left  = 0x804eb80
_right  = 0x804ec10
left_thread  = false
right_thread = false

date  = 

day_of_week = Thu
day  = 1
month  = 1
year  = 1970
_vptr.  = 0x804ba84

shared  = 4711

2: tree
(Tree *) 0x804eb50

Suppressed members

Normal Data Display

Suppressing Values

To delete several displays at once, use the ‘Undisp ’ button in the Display Editor (invoked via
‘Data ⇒ Displays ’). Select any number of display items in the usual way and delete them by
pressing ‘Undisp ’.

As an alternative, you can also use addd command:

graph undisplay displays. . .

Here,displays. . . is either

• a space-separated list of display numbers to disable or enable, or

• a single display name. If you specify a display by name, all displays with this name will be
affected.

If you are using stacked windows, deleting the last display from the data window also automat-
ically closes the data window. (You can change this via ‘Edit ⇒ Preferences ⇒ Data ⇒
Close data window when deleting last display ’.)

If you deleted a display by mistake, use ‘Edit ⇒ Undo’ to re-create it.

Finally, you can also cut, copy, and paste displays using the ‘Cut ’, ‘ Copy’, and ‘Paste ’ items
from the ‘Edit ’ menu. The clipboard holds thecommandsused to create the displays; ‘Paste ’
inserts the display commands in the debugger console. This allows you to save displays for later
usage or to copy displays across multipleddd instances.

7.3.2 Arrays

ddd has some special features that facilitate handling of arrays.

7.3.2.1 Array Slices

It is often useful to print out several successive objects of the same type in memory; aslice
(section) of an array, or an array of dynamically determined size for which only a pointer exists in
the program.
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Usingddd, you can display slices using the ‘from.. to ’ notation (seeSection 7.3.1.10 [Creating
Multiple Displays], page 115). But this requires that you already knowfrom and to; it is also
inefficient to create several single displays. If you usegdb, you have yet another alternative.

Usinggdb, you can display successive objects by referring to a contiguous span of memory as
anartificial array, using the binary operator ‘@’. The left operand of ‘@’ should be the first element
of the desired array and be an individual object. The right operand should be the desired length
of the array. The result is an array value whose elements are all of the type of the left argument.
The first element is actually the left argument; the second element comes from bytes of memory
immediately following those that hold the first element, and so on.

Here is an example. If a program says

int *array = (int *) malloc (len * sizeof (int));

you can print the contents ofarray with

print array[0]@len

and display the contents with

graph display array[0]@len

The general form of displaying an array slice is thus

graph display array[ first ]@nelems
wherearray is the name of the array to display,first is the index of the first element, andnelems is
the number of elements to display.

The left operand of ‘@’ must reside in memory. Array values made with ‘@’ in this way behave
just like other arrays in terms of subscripting, and are coerced to pointers when used in expressions.

7.3.2.2 Repeated Values

Usinggdb, an array value that is repeated 10 or more times is displayed only once. The value
is shown with a ‘<nx> ’ postfix added, wheren is the number of times the value is repeated. Thus,
the display ‘0x0 <30x> ’ stands for 30 array elements, each with the value ‘0x0 ’. This saves a lot
of display space, especially with homogeneous arrays.

Displaying Repeated Array Values

Repeated Value
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The defaultgdb threshold for repeated array values is 10. You can change it via ‘Edit ⇒
gdb Settings ⇒ Threshold for repeated print elements ’. Setting the threshold to
0 will causegdb (andddd) to display each array element individually. Be sure to refresh the data
window via ‘Data ⇒ Refresh Displays ’ after a change ingdb settings.

You can also configureddd to display each array element individually:

ResourceexpandRepeatedValues(class ExpandRepeatedValues)
gdb can print repeated array elements as ‘value <repeated n times> ’. If
‘expandRepeatedValues ’ is ‘ on ’, ddd will display n instances ofvalue instead. If
‘expandRepeatedValues ’ is ‘ off ’ (default), ddd will display value with ‘<nx> ’
appended to indicate the repetition.

7.3.2.3 Arrays as Tables

By default, ddd lays out two-dimensional arrays as tables, such that all array elements are
aligned with each other.1 To disable this feature, unset ‘Edit ⇒ Preferences ⇒ Data ⇒
Display Two-Dimensional Arrays as Tables ’. This is tied to the following resource:

Resourcealign2dArrays (class Align2dArrays)
If ‘ on ’ (default),ddd lays out two-dimensional arrays as tables, such that all array elements
are aligned with each other. If ‘off ’, ddd treats a two-dimensional array as an array of
one-dimensional arrays, each aligned on its own.

7.3.3 Assignment to Variables

During program execution, you can change the values of arbitrary variables.2

To change the value of a variable, enter its name in ‘() ’—for instance, by selecting an occur-
rence or a display. Then, click on the ‘Set ’ button. In a dialog, you can edit the variable value at
will; clicking the ‘OK’ or ‘ Apply ’ button commits your change and assigns the new value to the
variable.

1 This requires that the full array size is known to the debugger.
2 jdb 1.1 does not support changing variable values.
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Changing Variable Values

Select to set

Enter new value here

To change a displayed value, you can also select ‘Set Value ’ menu from the data popup menu,

If you made a mistake, you can use ‘Edit ⇒ Undo’ to re-set the variable to its previous value.

7.3.4 Examining Structures

Besides displaying simple values,ddd can also visualize theDependencies between values—
especially pointers and other references that make up complex data structures.

7.3.4.1 Displaying Dependent Values

Dependent displays are created from an existing display. The dependency is indicated by an
edge leading from the originating display to the dependent display.

To create a dependent display, select the originating display or display part and enter the depen-
dent expression in the ‘(): ’ argument field. Then click on the ‘Display ’ button.

Using dependent displays, you can investigate the data structure of a tree for example and lay it
out according to your intuitive image of the tree data structure.

By default,ddd does not recognize shared data structures (i.e. a data object referenced by
multiple other data objects). SeeSection 7.3.4.3 [Shared Structures], page 121, for details on how
to examine such structures.

7.3.4.2 Dereferencing Pointers

There are special shortcuts for creating dependent displays showing the value of a dereferenced
pointer. This allows for rapid examination of pointer-based data structures.

To dereference a pointer, select the originating pointer value or name and click on the ‘Disp * ’
button. A new display showing the dereferenced pointer value is created.

As a faster alternative, you can also pressmouse button 3on the originating pointer value or
name and select the ‘Display * ’ menu item.
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As an even faster alternative, you can also double-clickmouse button 1on the originating pointer
value or name. If you press〈Ctrl〉 while double-clicking, the display will be dereferencedin place–
that is, it will be replaced by the dereferenced display.

The ‘Display *() ’ function is also accessible by pressing and holding the ‘Display ’ button.

7.3.4.3 Shared Structures

By default,ddd does not recognize shared data structures—that is, a data object referenced by
multiple other data objects. For instance, if two pointers ‘p1 ’ and ‘p2 ’ point at the same data object
‘d’, the data displays ‘d’, ‘ *p1 ’, and ‘*p2 ’ will be separate, although they denote the same object.

ddd provides a special mode which makes it detect these situations.ddd recognizes if two or
more data displays are stored at the same physical address, and if this is so, merges all thesealiases
into one single data display, theoriginal data display. This mode is calledAlias Detection; it is
enabled via ‘Data ⇒ Detect Aliases ’.

When alias detection is enabled,ddd inquires the memory location (theaddress) of each data
display after each program step. If two displays have the same address, they are merged into one.
More specifically, only the one which has least recently changed remains (theoriginal data display);
all other aliases aresuppressed, i.e. completely hidden. The edges leading to the aliases are replaced
by edges leading to the original data display.

An edge created by alias detection is somewhat special: rather than connecting two displays
directly, it goes through anedge hint, describing an arc connecting the two displays and the edge
hint.

Each edge hint is a placeholder for a suppressed alias; selecting an edge hint is equivalent to
selecting the alias. This way, you can easily delete display aliases by simply selecting the edge hint
and clicking on ‘Undisp ’.

Examining Shared Data Structures

Original Display Edge Hint
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To access suppressed display aliases, you can also use the Display Editor. Suppressed displays
are listed in the Display Editor asaliasesof the original data display. Via the Display Editor, you
can select, change, and delete suppressed displays.

Suppressed displays become visible again as soon as

• alias detection is disabled,

• their address changes such that they are no more aliases, or

• the original data display is deleted, such that the least recently changed alias becomes the new
original data display.

Please note the followingcaveatswith alias detection:

• Alias detection requires that the current programming language provides a means to determine
the address of an arbitrary data object. Currently, only C, C++, and Java are supported.

• Some inferior debuggers (for instance, SunOSdbx) produce incorrect output for address ex-
pressions. Given a pointerp, you may verify the correct function of your inferior debugger by
comparing the values ofp and ‘&p ’ (unlessp actually points to itself). You can also examine
the data display addresses, as shown in the Display Editor.

• Alias detection slows downddd slightly, which is why you can turn it off. You may consider
to enable it only at need—for instance, while examining some complex data structure—and
disable it while examining control flow (i.e., stepping through your program).ddd will auto-
matically restore edges and data displays when switching modes.

Alias detection is controlled by the following resources:

ResourcedeleteAliasDisplays(class DeleteAliasDisplays)
If this is ‘on ’ (default), the ‘Undisplay () ’ button also deletes all aliases of the selected
displays. If this is ‘off ’, only the selected displays are deleted; the aliases remain, and one
of the aliases will be unsuppressed.

ResourcedetectAliases(class DetectAliases)
If ‘ on ’ (default), ddd attempts to recognize shared data structures. If ‘off ’, shared data
structures are not recognized.

ResourcetypedAliases (class TypedAliases)
If ‘ on ’ (default),ddd requires structural equivalence in order to recognize shared data struc-
tures. If this is ‘off ’, two displays at the same address are considered aliases, regardless of
their structure.

7.3.4.4 Display Shortcuts

ddd maintains ashortcut menuof frequently used display expressions. This menu is activated

• by pressing and holding the ‘Display ’ button, or

• by pressingmouse button 3on some display and selecting ‘New Display ’, or

• by pressing〈Shift〉 andmouse button 3on some display.
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By default, the shortcut menu contains frequently used base conversions.

The ‘Other ’ entry in the shortcut menu lets you create a new display thatextendsthe shortcut
menu.

As an example, assume you have selected a display named ‘date_ptr ’. Selecting ‘Display
⇒ Other ’ pops up a dialog that allows you to enter a new expression to be displayed—for instance,
you can cast the display ‘date_ptr ’ to a new display ‘(char *)date_ptr ’. If the ‘ Include
in ‘New Display’ Menu ’ toggle was activated, the shortcut menu will then contain a new entry
‘Display (char *)() ’ that will castanyselected displaydisplay to ‘(char *) display ’. Such
shortcuts can save you a lot of time when examining complex data structures.

Using Display Shortcuts

Modify expression here... ... to include it in the ‘New Display’ menu.

You can edit the contents of the ‘New Display ’ menu by selecting its ‘Edit Menu ’ item. This
pops up theShortcut Editorcontaining all shortcut expressions, which you can edit at leisure. Each
line contains the expression for exactly one menu item. Clicking on ‘Apply ’ re-creates the ‘New
Display ’ menu from the text. If the text is empty, the ‘New Display ’ menu will be empty, too.
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Invoke shortcut editor

Editing Display Shortcuts

ddd also allows you to specify individual labels for user-defined buttons. You can write such a
label after the expression, separated by ‘// ’. This feature is used in the default contents of thegdb
‘New Display ’ menu, where each of the base conversions has a label:

/t () // Convert to Bin
/d () // Convert to Dec
/x () // Convert to Hex
/o () // Convert to Oct

Feel free to add other conversions here.ddd supports up to 20 ‘New Display ’ menu items.

The shortcut menu is controlled by the following resources:

ResourcedbxDisplayShortcuts (class DisplayShortcuts)
A newline-separated list of display expressions to be included in the ‘New Display ’ menu
for dbx.

If a line contains a label delimiter3, the string before the delimiter is used asexpression,
and the string after the delimiter is used as label. Otherwise, the label is ‘Display expres-
sion ’. Upon activation, the string ‘() ’ in expression is replaced by the name of the currently
selected display.

ResourcegdbDisplayShortcuts (class DisplayShortcuts)
A newline-separated list of display expressions to be included in the ‘New Display ’ menu
for gdb. See the description of ‘dbxDisplayShortcuts ’, above.

3 The string ‘// ’; can be changed via the ‘labelDelimiter ’ resource. SeeSection 10.4.1 [Customizing
Buttons], page 152, for details.
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ResourcejdbDisplayShortcuts (class DisplayShortcuts)
A newline-separated list of display expressions to be included in the ‘New Display ’ menu
for jdb. See the description of ‘dbxDisplayShortcuts ’, above.

ResourceperlDisplayShortcuts (class DisplayShortcuts)
A newline-separated list of display expressions to be included in the ‘New Display ’ menu
for Perl. See the description of ‘dbxDisplayShortcuts ’, above.

ResourcebashDisplayShortcuts (class DisplayShortcuts)
A newline-separated list of display expressions to be included in the ‘New Display ’ menu
for Bash. See the description of ‘dbxDisplayShortcuts ’, above.

ResourcepydbDisplayShortcuts (class DisplayShortcuts)
A newline-separated list of display expressions to be included in the ‘New Display ’ menu
for pydb. See the description of ‘dbxDisplayShortcuts ’, above.

ResourcexdbDisplayShortcuts (class DisplayShortcuts)
A newline-separated list of display expressions to be included in the ‘New Display ’ menu
for xdb. See the description of ‘dbxDisplayShortcuts ’, above.

7.3.5 Customizing Displays

7.3.5.1 Using Data Themes

ddd provides a simple method to customize displays.ddd comes with a number ofvisual
modifiers, calleddata themes.

Each theme modifies a particular aspect of a data display. It can be applied to individual displays
or to a number of displays. The themes installed withddd include:

‘Small Titles ’
Apply this theme to show display titles in a smaller font.

‘Small Values ’
Apply this theme to display values in a smaller font.

‘Tiny Values ’
Apply this theme to display values in a tiny font.

‘Suppress Values ’
Apply this theme to display values not at all.

Each of these themes can be applied for specific displays.
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Some DDD Themes

To apply a theme on a display,

1. Pressmouse button 3on the display.

2. Select ‘Theme’

3. Select the theme to apply.

For instance, to display the variables in a tiny font, clickmouse button 3on the display ofs ,
and select ‘Theme⇒ Tiny Values ⇒ Apply ’.

To unapply a theme, just click on ‘Undo’ (if you just applied it) or repeat the sequence as above.

7.3.5.2 Applying Data Themes to Several Values

Whenever you want to apply a theme on astruct memberor anarray element,you will be asked
whether to
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• apply the theme on the single value only, or

• apply the theme on all similar values.

Suppose, for instance, that you don’t want to see ‘vptr ’ members anymore. Then you’d apply
the themeSuppress Valueson all similar values.

On the other hand, if you want to highlight one single value only, you’d apply the themeRed
Backgroundon only one single value.

If you find this confirmation annoying, you can define a command button which directly applies
the theme. SeeSection 10.5 [Defining Commands], page 154, for details on defining commands.

Applying and unapplying themes is associated with the following commands:

graph apply theme name pattern

applies the themename on pattern.

graph unapply theme name pattern

unapplies the themename on pattern.

graph toggle theme name pattern

applies the themename on pattern if it was not already applied, and unapplies it otherwise.

7.3.5.3 Editing Themes

Each theme can be globally activated or not. If a theme is activated, it is applied to all expressions
that match itspattern.

Normally, these patterns are automatically maintained by simply selecting the themes for the
individual displays. However, you can also edit patterns directly.

Patterns are separated by ‘; ’ and contain shell-like metacharacters:

• ‘* ’ matches any sequence of characters.

• ‘?’ matches any single character.

• ‘ [ set ] ’ matches any character inset. Character ranges can be expressed usingfrom-to:
‘ [0-9a-zA-Z_] ’ is the set of characters allowed in C characters.

• ‘ [! set ] ’ matches any character not inset.

• To suppress the special syntactic significance of any metacharacter\ n\ and match the character
exactly, precede it with ‘\ ’ (backslash).

• To suppress the syntactic significance ofall metacharacters,\ n\ enclose the pattern in double
or single quotes.\ n\

To edit the set of themes, invoke ‘Data ⇒ Themes’.

To apply changes you made to the themes, click on ‘Apply ’. To revert the themes to the last
saved, click on ‘Reset ’.

7.3.5.4 Writing Data Themes

You can write your own data themes, customizing the display to match your need. Seesection
“Top” in Writing DDD Themes, for details.
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7.3.5.5 Display Resources

You can use these resources to control display appearance:

ResourceautoCloseDataWindow (class AutoClose)
If this is ‘on ’ (default) andddd is in stacked window mode, deleting the last display auto-
matically closes the data window. If this is ‘off ’, the data window stays open even after
deleting the last display.

ResourcebumpDisplays (class BumpDisplays)
If some displayd changes size and this resource is ‘on ’ (default),ddd assigns new positions
to displays below and on the right ofd such that the distance between displays remains
constant. If this is ‘off ’, other displays are not rearranged.

ResourceclusterDisplays (class ClusterDisplays)
If ‘ on ’, new independent data displays will automatically be clustered. Default is ‘off ’,
meaning to leave new displays unclustered.

ResourcehideInactiveDisplays (class HideInactiveDisplays)
If some display gets out of scope and this resource is ‘on ’ (default),ddd removes it from the
data display. If this is ‘off ’, it is simply disabled.

ResourceshowBaseDisplayTitles(class ShowDisplayTitles)
Whether to assign titles to base (independent) displays or not. Default is ‘on ’.

ResourceshowDependentDisplayTitles(class ShowDisplayTitles)
Whether to assign titles to dependent displays or not. Default is ‘off ’.

ResourcesuppressTheme(class Theme)
The theme to apply when selecting ‘Undisp ’ on a data value. Default is ‘suppress.vsl ’.

Resourcethemes (class Themes)
A newline-separated list of themes. Each theme has the formatname, tabulator character,
pattern.

7.3.5.6 VSL Resources

The following resources control thevsl interpreter:

ResourcevslBaseDefs(class VSLDefs)
A string with additionalvsl definitions that are appended to the builtinvsl library. This
resource is prepended to the ‘vslDefs ’ resource below and set in theddd application
defaults file; don’t change it.
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ResourcevslDefs (class VSLDefs)
A string with additionalvsl definitions that are appended to the builtinvsl library. The
default value is an empty string. This resource can be used to override specificvsl definitions
that affect the data display. The preferred method, though, is to write a specific data theme
(seeSection 7.3.5.4 [Writing Data Themes], page 127).

ResourcevslLibrary (class VSLLibrary)
Thevsl library to use. ‘builtin ’ (default) means to use the built-in library, any other value
is used as file name.

ResourcevslPath (class VSLPath)
A colon-separated list of directories to search forvsl include files. The following directory
names are special:

• The special directory name ‘user_themes ’ stands for your individual theme direc-
tory, typically ‘~/.ddd/themes/ ’.

• The special directory name ‘ddd_themes ’ stands for the installed theme directory,
typically ‘/usr/local/share/ddd-3.3.9/themes/ ’.

Default is ‘user_themes:ddd_themes:. ’, which means thatddd first searches your
theme directory, followed by the system directory and the current directory.

If your ddd source distribution is installed in ‘/opt/src ’, you can use the following settings
to read thevsl library from ‘/home/joe/ddd.vsl ’:

Ddd*vslLibrary: /home/joe/ddd.vsl
Ddd*vslPath: user_themes:.:/opt/src/ddd/ddd:/opt/src/ddd/vsllib

vsl include files referenced by ‘/home/joe/ddd.vsl ’ are searched first in the current
directory ‘. ’, then in your theme directory, then in ‘/opt/src/ddd/ddd/ ’, and then in
‘ /opt/src/ddd/vsllib/ ’.

Instead of supplying anothervsl library, it is often easier to specify some minor changes to the
built-in library (seeSection 7.3.5.4 [Writing Data Themes], page 127).

7.3.6 Layouting the Graph

If you have several displays at once, you may wish to arrange them according to your personal
preferences. This section tells you how you can do this.

7.3.6.1 Moving Displays

From time to time, you may wish to move displays at another place in the data window. You
can move a single display by pressing and holdingmouse button 1on the display title. Moving the
pointer while holding the button causes all selected displays to move along with the pointer.

Edge hints can be selected and moved around like other displays. If an arc goes through the edge
hint, you can change the shape of the arc by moving the edge hint around.

For fine-grain movements, selected displays may also be moved using the arrow keys. Pressing
〈Shift〉 and an arrow key moves displays by single pixels. Pressing〈Ctrl〉 and arrow keys moves
displays by grid positions.
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7.3.6.2 Scrolling Data

If the data window becomes too small to hold all displays, scroll bars are created. If yourddd is
set up to usepannersinstead, a panner is created in the lower right edge. When the panner is moved
around, the window view follows the position of the panner.

To change from scroll bars to panners, use ‘Edit ⇒ Startup ⇒ Data Scrolling ’ and
choose either ‘Panner ’ or ‘ Scrollbars ’.

This setting is tied to the following resource:

ResourcepannedGraphEditor (class PannedGraphEditor)
The control to scroll the graph.

• If this is ‘on ’, an Athena panner is used (a kind of two-directional scrollbar).

• If this is ‘off ’ (default), two M*tif scrollbars are used.

See Section 2.1.2 [Options], page 16, for the ‘--scrolled-graph-editor ’ and
‘ --panned-graph-editor ’ options.

7.3.6.3 Aligning Displays

You can align all displays on the nearest grid position by selecting ‘Data ⇒ Align on Grid ’.
This is useful for keeping edges strictly horizontal or vertical.

You can enforce alignment by selecting ‘Edit ⇒ Preferences ⇒ Data ⇒ Auto-align
Displays on Nearest Grid Point ’. If this feature is enabled, displays can be moved on grid
positions only.

7.3.6.4 Automatic Layout

You can layout the entire graph as a tree by selecting ‘Data ⇒ Layout Graph ’. The layout
direction is determined from the display placement (seeSection 7.3.1.8 [Placement], page 113) and
from the last rotation (seeSection 7.3.6.5 [Rotating the Graph], page 131).
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A Layouted Graph (with Compact Layout)

Layouting the graph may introduceedge hints; that is, edges are no more straight lines, but lead
to an edge hint and from there to their destination. Edge hints can be moved around like arbitrary
displays.

To enable a more compact layout, you can set the ‘Edit ⇒ Preferences ⇒ Data ⇒
Compact Layout ’ option. This realizes an alternate layout algorithm, where successors are
placed next to their parents. This algorithm is suitable for homogeneous data structures only.

You can enforce layout by setting ‘Edit ⇒ Preferences ⇒ Data ⇒ Automatic
Layout ’. If automatic layout is enabled, the graph is layouted after each change.

7.3.6.5 Rotating the Graph

You can rotate the entire graph clockwise by 90 degrees by selecting ‘Data ⇒ Rotate
Graph ’. You may need to layout the graph after rotating it; SeeSection 7.3.6.4 [Automatic
Layout], page 130, for details.

7.3.7 Printing the Graph

ddd allows for printing the graph picture on PostScript printers or into files. This is useful for
documenting program states.
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Printing displays

Enter print command

Select paper size

Click to print

To print the graph on a PostScript printer, select ‘File ⇒ Print Graph ’. Enter the printing
command in the ‘Print Command ’ field. Click on the ‘OK’ or the ‘Apply ’ button to start printing.

As an alternative, you may also print the graph in a file. Click on the ‘File ’ button and enter
the file name in the ‘File Name ’ field. Click on the ‘Print ’ button to create the file.

When the graph is printed in a file, two formats are available:

• ‘PostScript ’—suitable for enclosing the graph in another document;

• ‘FIG ’—suitable for post-processing, using thexfig graphic editor, or for conversion into
other formats (among others,ibmgl, TEX, pic), using thetransfig or fig2dev programs.

*() next next

next

self self self

5: list
(List *) 0x804af30

value = 86
self  = 0x804af40
next  = 0x804af50

value = 87
self  = 0x804af50
next  = 0x804af30

value = 85
self  = 0x804af30
next  = 0x804af40

Output of the ‘Print Graph’ Command

Please note the followingcaveatsrelated to printing graphs:

• If any displays were selected when invoking the ‘Print ’ dialog, the option ‘Selected
Only ’ is set. This makesddd print only the selected displays.
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• The ‘Color ’, ‘ Orientation ’, and ‘Paper Size ’ options are meaningful for PostScript
only.

These settings are tied to the following resources:

ResourceprintCommand (class PrintCommand)
The command to print a PostScript file. Usually ‘lp ’ or ‘ lpr ’.

ResourcepaperSize (class PaperSize)
The paper size used for printing, in format ‘width x height ’. The default is ISO A4 format,
or ‘210mm x 297mm’.

7.4 Plotting Values

If you have huge amounts of numerical data to examine, a picture often says more than a thou-
sand numbers. Therefore,ddd allows you to draw numerical values in nice 2-D and 3-D plots.

7.4.1 Plotting Arrays

Basically,ddd can plot two types of numerical values:

• One-dimensional arrays. These are drawn in a 2-Dx/y space, wherex denotes the array index,
andy the element value.

• Two-dimensional arrays. These are drawn in a 3-Dx/y/z space, wherex andy denote the
array indexes, andz the element value.

To plot a fixed-size array, select its name by clickingmouse button 1on an occurrence. The
array name is copied to the argument field. By clicking the ‘Plot ’ button, a new display is created
in the data window, followed by a new top-level window containing the value plot.

To plot a dynamically sized array, you must use an array slice (seeSection 7.3.2.1 [Array Slices],
page 117). In the argument field, enter

array[ first ]@nelems

wherearray is the name of the array to display,first is the index of the first element, andnelems is
the number of elements to display. Then, click on ‘Plot ’ to start the plot.

To plot a value, you can also enter a command at the debugger prompt:

graph plot expr

works like ‘graph display expr ’ (and takes the same arguments; seeSection 7.3.1.1 [Creating
Single Displays], page 107), but the value is additionally shown in the plot window.

Each time the value changes during program execution, the plot is updated to reflect the current
values. The plot window remains active until you close it (via ‘File ⇒ Close ’) or until the
associated display is deleted.



134 Debugging with DDD

7.4.2 Changing the Plot Appearance

The actual drawing is not done byddd itself. Instead,ddd relies on an externalgnuplot
program to create the drawing.

ddd adds a menu bar to the Gnuplot plot window that lets you influence the appearance of the
plot:

• The ‘View ’ menu toggles optional parts of the plot, such as border lines or a background grid.

• The ‘Plot ’ menu changes theplotting style. The ‘3-D Lines ’ option is useful for plotting
two-dimensional arrays.

• The ‘Scale ’ menu allows you to enable logarithmic scaling and to enable or disable the scale
tics.

• The ‘Contour ’ menu adds contour lines to 3-D plots.

In a 3-D plot, you can use the scroll bars to change your view position. The horizontal scroll bar
rotates the plot around thez axis, that is, to the left and right. The vertical scroll bar rotates the plot
around they axis, that is, up and down.

Plotting 1−D and 2−D Arrays

Rotate View

Change Style

A 2−D Array

A 1−D Array

You can also resize the plot window as desired.

7.4.3 Plotting Scalars and Composites

Besides plotting arrays,ddd also allows you to plot scalars (simple numerical values). This
works just like plotting arrays—you select the numerical variable, click on ‘Plot ’, and here comes
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the plot. However, plotting a scalar is not very exciting. A plot that contains nothing but a scalar
simply draws the scalar’s value as ay constant—that is, a horizontal line.

So why care about scalars at all?ddd allows you to combinemultiple values into one plot.The
basic idea is: if you want to plot something that is neither an array nor a scalar,ddd takes all numer-
ical sub-values it can find and plots them all together in one window. For instance, you can plot all
local variables by selecting ‘Data ⇒ Display Local Variables ’, followed by ‘Plot ’. This
will create a plot containing all numerical values as found in the current local variables. Likewise,
you can plot all numeric members contained in a structure by selecting it, followed by ‘Plot ’.

If you want more control about what to include in a plot and what not, you can usedisplay clus-
ters (seeSection 7.3.1.9 [Clustering], page 114). A common scenario is to plot a one-dimensional
array together with the current index position. This is done in three steps:

1. Display the array and the index, using ‘Display ’.

2. Cluster both displays: select them and choose ‘Undisp ⇒ Cluster () ’.

3. Plot the cluster by pressing ‘Plot ’.

Scalars that are displayed together with arrays can be displayed either as vertical lines or hori-
zontal lines. By default, scalars are plotted as horizontal lines. However, if a scalar is a valid index
for an array that was previously plotted, it is shown as a vertical line. You can change this initial
orientation by selecting the scalar display, followed by ‘Rotate ’.

7.4.4 Plotting Display Histories

At each program stop,ddd records the values of all displayed variables, such that you can
“undo” program execution (seeSection 6.8 [Undoing Program Execution], page 100). Thesedisplay
historiescan be plotted, too. The menu item ‘Plot ⇒ Plot history of () ’ creates a plot that
shows all previously recorded values of the selected display.

7.4.5 Printing Plots

If you want to print the plot, select ‘File ⇒ Print Plot ’. This pops up theddd printing
dialog, set up for printing plots. Just as when printing graphs, you have the choice between printing
to a printer or a file and setting up appropriate options.

The actual printing is also performed by Gnuplot, using the appropriate driver. Please note the
following caveatsrelated to printing:

• Creating ‘FIG ’ files requires an appropriate driver built into Gnuplot. Your Gnuplot program
may not contain such a driver. In this case, you will have to recompile Gnuplot, including the
line ‘#define FIG ’ in the Gnuplot ‘term.h ’ file.

• The ‘Portrait ’ option generates aneps file useful for inclusion in other documents. The
‘Landscape ’ option makesddd print the plot in the size specified in the ‘Paper Size ’
option; this is useful for printing on a printer. In ‘Portrait ’ mode, the ‘Paper Size ’
option is ignored.

• The Gnuplot device drivers for PostScript and X11 each have their own set of colors, such that
the printed colors may differ from the displayed colors.

• The ‘Selected Only ’ option is set by default, such that only the currently selected plot is
printed. (If you select multiple plots to be printed, the respective outputs will all be concate-
nated, which may not be what you desire.)
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7.4.6 Entering Plotting Commands

Via ‘File ⇒ Command’, you can enter Gnuplot commands directly. Each command entered
at the ‘gnuplot> ’ prompt is passed to Gnuplot, followed by a Gnuplot ‘replot ’ command to
update the view. This is useful for advanced Gnuplot tasks.

Here’s a simple example. The Gnuplot command

set xrange [ xmin: xmax]

sets the horizontal range that will be displayed toxmin . . .xmax. To plot only the elements 10 to
20, enter:

gnuplot> set xrange [10:20]
gnuplot> _

After each command entered,ddd adds areplot command, such that the plot is updated
automatically.

Here’s a more complex example. The following sequence of Gnuplot commands saves the plot
in TEX format:

gnuplot> set output " plot.tex " # Set the output filename
gnuplot> set term latex # Set the output format
gnuplot> set term x11 # Show original picture again
gnuplot> _

Due to the implicitreplot command, the output is automatically written to ‘plot.tex ’ after
theset term latex command.

The dialog keeps track of the commands entered; use the arrow keys to restore previous com-
mands. Gnuplot error messages (if any) are also shown in the history area.

The interaction betweenddd and Gnuplot is logged in the file ‘~/.ddd/log ’ (see
Section B.5.1 [Logging], page 170). Theddd ‘ --trace ’ option logs this interaction on standard
output.

7.4.7 Exporting Plot Data

If you want some external program to process the plot data (a stand-alone Gnuplot program or
thexmgr program, for instance), you can save the plot data in a file, using ‘File ⇒ Save Data
As’. This pops up a dialog that lets you choose a data file to save the plotted data in.

The generated file starts with a few comment lines. The actual data follows in X/Y or X/Y/Z
format. It is the same file as processed by Gnuplot.

7.4.8 Animating Plots

If you want to see how your data evolves in time, you can set a breakpoint whose command
sequence ends in acont command (seeSection 5.1.8 [Breakpoint Commands], page 85. Each
time this “continue” breakpoint is reached, the program stops andddd updates the displayed values,
including the plots. Then,ddd executes the breakpoint command sequence, resuming execution.

This way, you can set a “continue” breakpoint at some decisive point within an array-processing
algorithm and haveddd display the progress graphically. When your program has stopped for good,
you can use ‘Undo’ and ‘Redo’ to redisplay and examine previous program states. SeeSection 6.8
[Undoing Program Execution], page 100, for details.
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7.4.9 Customizing Plots

You can customize the Gnuplot program to invoke, as well as a number of basic settings.

7.4.9.1 Gnuplot Invocation

Using ‘Edit ⇒ Preferences ⇒ Helpers ⇒ Plot ’, you can choose the Gnuplot pro-
gram to invoke. This is tied to the following resource:

ResourceplotCommand (class PlotCommand)
The name of a Gnuplot executable. Default is ‘gnuplot ’, followed by some options to set
up colors and the initial geometry.

Using ‘Edit ⇒ Preferences ⇒ Helpers ⇒ Plot Window ’, you can choose whether
to use the Gnuplot plot window (‘External ’) or to use the plot window supplied byddd
(‘builtin ’). This is tied to the following resource:

ResourceplotTermType (class PlotTermType)
The Gnuplot terminal type. Can have one of two values:

• If this is ‘x11 ’, ddd “swallows” theexternalGnuplot output window into its own user
interface. Some window managers, notablymwm, have trouble with swallowing tech-
niques.

• Setting this resource to ‘xlib ’ (default) makesddd provide abuiltin plot windowin-
stead. In this mode, plots work well with any window manager, but are less customizable
(Gnuplot resources are not understood).

You can further control interaction with the external plot window:

ResourceplotWindowClass (class PlotWindowClass)
The class of the Gnuplot output window. When invoking Gnuplot,ddd waits for a window
with this class and incorporates it into its own user interface (unless ‘plotTermType ’ is
‘xlib ’; see above). Default is ‘Gnuplot ’.

ResourceplotWindowDelay (class WindowDelay)
The time (in ms) to wait for the creation of the Gnuplot window. Before this delay,ddd
looks at each newly created window to see whether this is the plot window to swallow. This
is cheap, but unfortunately, some window managers do not pass the creation event toddd.
If this delay has passed, andddd has not found the plot window,ddd searchesall existing
windows, which is pretty expensive. Default time is2000 .

7.4.9.2 Gnuplot Settings

To change Gnuplot settings, use these resources:

ResourceplotInitCommands (class PlotInitCommands)
The initial Gnuplot commands issued byddd. Default is:
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set parametric
set urange [0:1]
set vrange [0:1]
set trange [0:1]

The ‘parametric ’ setting is required to make Gnuplot understand the data files as gener-
atedddd. The range commands are used to plot scalars.

See the Gnuplot documentation for additional commands.

Resourceplot2dSettings (class PlotSettings)
Additional initial settings for 2-D plots. Default is ‘set noborder ’. Feel free to customize
these settings as desired.

Resourceplot3dSettings (class PlotSettings)
Additional initial settings for 3-D plots. Default is ‘set border ’. Feel free to customize
these settings as desired.

7.5 Examining Memory

Usinggdb or dbx, you can examine memory in any of several formats, independently of your
program’s data types. The item ‘Data ⇒ Memory’ pops up a panel where you can choose the
format to be shown.

Examining Memory

Click here to print...

... in the GDB console

Enter address here

Memory Dump
as Status Display
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In the panel, you can enter

• arepeat count, a decimal integer that specifies how much memory (counting by units) to display

• a display format—one of

‘octal ’ Print as integer in octal

‘hex ’ Regard the bits of the value as an integer, and print the integer in hexadecimal.

‘decimal ’
Print as integer in signed decimal.

‘unsigned ’
Print as integer in unsigned decimal.

‘binary ’ Print as integer in binary.

‘ float ’ Regard the bits of the value as a floating point number and print using typical
floating point syntax.

‘address ’
Print as an address, both absolute in hexadecimal and as an offset from the nearest
preceding symbol.

‘ instruction ’
Print as machine instructions. The unit size is ignored for this display format.

‘char ’ Regard as an integer and print it as a character constant.

‘string ’ Print as null-terminated string. The unit size is ignored for this display format.

• a unit size—one of

‘bytes ’ Bytes.

‘halfwords ’
Halfwords (two bytes).

‘words ’ Words (four bytes).

‘giants ’ Giant words (eight bytes).

• anaddress—the starting display address. The expression need not have a pointer value (though
it may); it is always interpreted as an integer address of a byte of memory.

There are two ways to examine the values:

• You can dump the memory in the debugger console (using ‘Print ’). If you repeat the resulting
‘x ’ command by pressing〈Return〉 in the debugger console (seeSection 10.1.2 [Command
History], page 148), the following area of memory is shown.

• You can also display the memory dump in the data window (using ‘Display ’). If you choose
to display the values, the values will be updated automatically each time the program stop.
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8 Machine-Level Debugging

Sometimes, it is desirable to examine a program not only at the source level, but also at the
machine level.ddd provides special machine code and register windows for this task.

8.1 Examining Machine Code

To enable machine-level support, select ‘Source ⇒ Display Machine Code ’. With ma-
chine code enabled, an additionalmachine code windowshows up, displaying the machine code of
the current function.1 By moving the sash at the right of the separating line between source and
machine code, you can resize the source and machine code windows.

Showing Machine Code

Assembler instructions

Step one instruction

The machine code window works very much like the source window. You can set, clear, and
change breakpoints by selecting the address and pressing a ‘Break ’ or ‘ Clear ’ button; the usual
popup menus are also available. Breakpoints and the current execution position are displayed si-
multaneously in both source and machine code.

The ‘Lookup ’ button can be used to look up the machine code for a specific function—or the
function for a specific address. Just click on the location in one window and press ‘Lookup ’ to see
the corresponding code in the other window.

If source code is not available, only the machine code window is updated.

You can customize various aspects of the disassembling window. SeeSection 8.4 [Customizing
Machine Code], page 143, for details.

1 The machine code window is available withgdb and somedbx variants only.
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8.2 Machine Code Execution

All execution facilities available in the source code window are available in the machine code
window as well. Two special facilities are convenient for machine-level debugging:

To execute just one machine instruction, click on the ‘Stepi ’ button or select ‘Program ⇒
Step Instruction ’.

To continue to the next instruction in the current function, click on the ‘Nexti ’ button select
‘Program ⇒ Next Instruction ’.. This is similar to ‘Stepi ’, but any subroutine calls are
executed without stopping.

Usinggdb, it is often useful to do

graph display /i $pc

when stepping by machine instructions. This makesddd automatically display the next instruction
to be executed, each time your program stops.

8.3 Examining Registers

ddd provides aregister windowshowing the machine register values after each program stop.
To enable the register window, select ‘Status ⇒ Registers ’.2

Displaying Register Values

Select register

is copied to ()
The register name

By selecting one of the registers, its name is copied to the argument field. You can use it as value
for ‘Display ’, for instance, to have its value displayed in the data window.

2 The machine code window is available withgdb and somedbx variants only.
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8.4 Customizing Machine Code

Enabling machine code via ‘Source ⇒ Display Machine Code ’ (see Section 8.1 [Ma-
chine Code], page 141) toggles the following resource:

Resourcedisassemble(class Disassemble)
If this is ‘on ’, the source code is automatically disassembled. The default is ‘off ’. See
Section 2.1.2 [Options], page 16, for the ‘--disassemble ’ and ‘--no-disassemble ’
options.

You can keep disassembled code in memory, using ‘Edit ⇒ Preferences ⇒ Source ⇒
Cache Machine Code ’:

ResourcecacheMachineCode(class CacheMachineCode)
Whether to cache disassembled machine code (‘on ’, default) or not (‘off ’). Caching ma-
chine code requires more memory, but makesddd run faster.

You can control the indentation of machine code, using ‘Edit ⇒ Preferences ⇒ Source
⇒ Machine Code Indentation ’:

ResourceindentCode (class Indent)
The number of columns to indent the machine code, such that there is enough place to display
breakpoint locations. Default:4.

The ‘maxDisassemble ’ resource controls how much is to be disassembled. If
‘maxDisassemble ’ is set to 256 (default) and the current function is larger than 256
bytes,ddd only disassembles the first 256 bytes below the current location. You can set the
‘maxDisassemble ’ resource to a larger value if you prefer to have a larger machine code view.

ResourcemaxDisassemble(class MaxDisassemble)
Maximum number of bytes to disassemble (default:256 ). If this is zero, the entire current
function is disassembled.
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9 Changing the Program

ddd offers some basic facilities to edit and recompile the source code, as well as patching
executables and core files.

9.1 Editing Source Code

In ddd itself, you cannot change the source file currently displayed. Instead,ddd allows you to
invoke atext editor. To invoke a text editor for the current source file, select the ‘Edit ’ button or
‘Source ⇒ Edit Source ’.

By default,ddd tries a number of common editors. You can customizeddd to use your favorite
editor; SeeSection 9.1.1 [Customizing Editing], page 145, for details.

After the editor has exited, the source code shown is automatically updated.

If you haveddd and an editor running in parallel, you can also update the source code manually
via ‘Source ⇒ Reload Source ’. This reloads the source code shown from the source file.
Sinceddd automatically reloads the source code if the debugged program has been recompiled,
this should seldom be necessary.

9.1.1 Customizing Editing

You can customize the editor to be used via ‘Edit ⇒ Preferences ⇒ Helpers ⇒ Edit
Sources ’. This is tied to the following resource:

ResourceeditCommand (class EditCommand)
A command string to invoke an editor on the specific file. ‘@LINE@’ is replaced by the
current line number, ‘@FILE@’ by the file name. The default is to invoke$XEDITORfirst,
then$EDITOR, thenvi :

Ddd*editCommand: \
${XEDITOR-false} +@LINE@ @FILE@ || \
xterm -e ${EDITOR-vi} +@LINE@ @FILE@

This ‘~/.ddd/init ’ setting invokes an editing session for an XEmacs editor running
gnuserv :

Ddd*editCommand: gnuclient +@LINE@ @FILE@

This ‘~/.ddd/init ’ setting invokes an editing session for an Emacs editor running
emacsserver :

Ddd*editCommand: emacsclient +@LINE@ @FILE@

9.1.2 In-Place Editing

This resource is experimental:

ResourcesourceEditing (class SourceEditing)
If this is ‘on ’, the displayed source code becomes editable. This is an experimental feature;
Default is ‘off ’.
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9.2 Recompiling

To recompile the source code usingmake, you can select ‘File ⇒ Make’. This pops up a
dialog where you can enter aMake Target—typically the name of the executable. Clicking on the
‘Make’ button invokes themake program with the given target.

The ‘Make’ button on the command tool re-invokesmake with the most recently given argu-
ments.

9.3 Patching

Usinggdb, you can open your program’s executable code (and the core file) for both reading
and writing. This allows alterations to machine code, such that you can intentionally patch your
program’s binary. For example, you might want to turn on internal debugging flags, or even to make
emergency repairs.

Note that depending on your operating system, special preparation steps, such as setting permis-
sions, may be needed before you can change executable files.

To patch the binary, enable ‘Edit ⇒ gdb Settings ⇒Writing into executable
and core files ’. This makesgdb open executable and core files for both reading and writing.
If you have already loaded a file, you must load it again (using ‘Edit ⇒ Open File ’ or ‘ Edit
⇒ Open Core ’), for your new setting to take effect.

Be sure to turn off ‘Writing into executable and core files ’ as soon as possible, to
prevent accidental alterations to machine code.
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10 The Command-Line Interface

All the buttons you click withinddd get eventually translated into some debugger command,
shown in the debugger console. You can also type in and edit these commands directly.

10.1 Entering Commands

In the debugger console, you can interact with the command interface of the inferior debug-
ger. Enter commands at thedebugger prompt—that is, ‘(gdb) ’ for gdb, ‘(dbx) ’ for dbx,
‘ (ladebug) ’ for Ladebug, ‘>’ for xdb, ‘>’ and ‘thread [ depth ] ’ for jdb, or ‘(Pydb) ’ for
pydb, or ‘DB<>’ for Perl, or ‘bashdb<> ’ for Bash. You can use arbitrary debugger commands;
use the〈Return〉 key to enter them.

10.1.1 Command Completion

When usinggdb or Perl, you can use the〈TAB〉 key for completingcommands and arguments.
This works in the debugger console as well as in all other text windows.

gdb can fill in the rest of a word in a command for you, if there is only one possibility; it can
also show you what the valid possibilities are for the next word in a command, at any time. This
works forgdb commands,gdb subcommands, and the names of symbols in your program.

Press the〈TAB〉 key whenever you wantgdb to fill out the rest of a word. If there is only one
possibility,gdb fills in the word, and waits for you to finish the command (or press〈RET〉 to enter
it). For example, if you type

(gdb) info bre_ 〈TAB〉

gdb fills in the rest of the word ‘breakpoints ’, since that is the onlyinfo subcommand begin-
ning with ‘bre ’:

(gdb) info breakpoints

You can either press〈RET〉 at this point, to run theinfo breakpoints command, or backspace
and enter something else, if ‘breakpoints ’ does not look like the command you expected. (If you
were sure you wantedinfo breakpoints in the first place, you might as well just type〈RET〉
immediately after ‘info bre ’, to exploit command abbreviations rather than command comple-
tion).

If there is more than one possibility for the next word when you press〈TAB〉, ddd sounds a bell.
You can either supply more characters and try again, or just press〈TAB〉 a second time;gdb displays
all the possible completions for that word. For example, you might want to set a breakpoint on a
subroutine whose name begins with ‘make_’, but when you typeb make_〈TAB〉, ddd just sounds
the bell. Typing〈TAB〉 again displays all the function names in your program that begin with those
characters. If you type〈TAB〉 again, you cycle through the list of completions, for example:

(gdb) b make_ 〈TAB〉
ddd sounds bell; press〈TAB〉 again, to see:

make_a_section_from_file make_environ
make_abs_section make_function_type
make_blockvector make_pointer_type
make_cleanup make_reference_type
make_command make_symbol_completion_list
(gdb) b make_ 〈TAB〉
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ddd presents one expansion after the other:
(gdb) b make_a_section_from_file 〈TAB〉
(gdb) b make_abs_section 〈TAB〉
(gdb) b make_blockvector 〈TAB〉

After displaying the available possibilities,gdb copies your partial input (‘b make_’ in the ex-
ample) so you can finish the command—by pressing〈TAB〉 again, or by entering the remainder
manually.

Sometimes the string you need, while logically a “word”, may contain parentheses or other
characters thatgdb normally excludes from its notion of a word. To permit word completion to
work in this situation, you may enclose words in’ (single quote marks) ingdb commands.

The most likely situation where you might need this is in typing the name of a C++ function.
This is because C++ allows function overloading (multiple definitions of the same function, dis-
tinguished by argument type). For example, when you want to set a breakpoint you may need to
distinguish whether you mean the version ofname that takes anint parameter,name(int) , or
the version that takes afloat parameter,name(float) . To use the word-completion facili-
ties in this situation, type a single quote’ at the beginning of the function name. This alertsgdb
that it may need to consider more information than usual when you press〈TAB〉 to request word
completion:

(gdb) b ’bubble( _〈TAB〉
bubble(double,double) bubble(int,int)
(gdb) b ’bubble( _

In some cases,ddd can tell that completing a name requires using quotes. When this happens,
ddd inserts the quote for you (while completing as much as it can) if you do not type the quote in
the first place:

(gdb) b bub _〈TAB〉
ddd alters your input line to the following, and rings a bell:

(gdb) b ’bubble( _

In general,ddd can tell that a quote is needed (and inserts it) if you have not yet started typing the
argument list when you ask for completion on an overloaded symbol.

If you prefer to use the〈TAB〉 key for switching between items, unset ‘Edit ⇒ Preferences
⇒ General ⇒ TAB Key completes in All Windows ’. This is useful if you have pointer-
driven keyboard focus (see below) and no special usage for the〈TAB〉 key. If the option is set, the
〈TAB〉 key completes in the debugger console only.

This option is tied to the following resource:

ResourceglobalTabCompletion (class GlobalTabCompletion)
If this is ‘on ’ (default), the〈TAB〉 key completes arguments in all windows. If this is ‘off ’,
the〈TAB〉 key completes arguments in the debugger console only.

10.1.2 Command History

You canrepeatprevious and next commands by pressing the〈Up〉 and 〈Down〉 arrow keys, re-
spectively. This presents you previous and later commands on the command line; use〈Return〉 to
apply the current command.

If you enter an empty line (just use〈Return〉 at the debugger prompt), the last command is repeated
as well.
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‘Commands⇒ Command History ’ shows the command history.

Command Apply Selected CommandSearch String

Position in History

Searching with Ctrl+B in the Command History

You cansearchfor previous commands by pressing〈Ctrl+B〉. This invokesincremental search
mode,where you can enter a string to be searched in previous commands. Press〈Ctrl+B〉 again to
repeat the search, or〈Ctrl+F〉 to search in the reverse direction. To return to normal mode, press
〈ESC〉, or use any cursor command.

The command history is automatically saved when exitingddd. You can turn off this feature by
setting the following resource to ‘off ’:

ResourcesaveHistoryOnExit (class SaveOnExit)
If ‘ on ’ (default), the command history is automatically saved whenddd exits.

10.1.3 Typing in the Source Window

As a special convenience, anything you type into the source window is automatically forwarded
to the debugger console. Thus, you don’t have to change the keyboard focus explicitly in order to
enter commands.

You can change this behaviour using the following resource:

ResourceconsoleHasFocus(class ConsoleHasFocus)
If ‘ on ’ (default), all keyboard events in the source window are automatically forwarded to
the debugger console. If ‘off ’, keyboard events are not forwarded. If ‘auto ’, keyboard
events forwarded only if the debugger console is open.
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10.2 Entering Commands at the TTY

Rather than entering commands at the debugger console, you may prefer to enter commands at
the terminal windowddd was invoked from.

Whenddd is invoked using the ‘--tty ’ option, it enables itstty interface, taking additional
debugger commands from standard input and forwarding debugger output to standard output, just
as if the inferior debugger had been invoked directly. All remainingddd functionality stays un-
changed.

By default, the debugger console remains closed ifddd is invoked using the ‘--tty ’ option.
Use ‘View ⇒ Debugger Console ’ to open it.

ddd can be configured to use the ‘readline ’ library for reading in commands from standard
input. Thisgnu library provides consistent behavior for programs which provide a command line
interface to the user. Advantages aregnu Emacs-style orvi-style inline editing of commands,csh -
like history substitution, and a storage and recall of command history across debugging sessions.
Seesection “Command Line Editing” inDebugging with gdb, for details on command-line editing
via thetty interface.

10.3 Integrating DDD

You can runddd as an inferior debugger in other debugger front-ends, combining their special
abilities with those ofddd.

To haveddd run as an inferior debugger in other front-ends, the general idea is to set up your
debugger front-end such that ‘ddd --tty ’ is invoked instead of the inferior debugger. When
ddd is invoked using the ‘--tty ’ option, it enables itstty interface, taking additional debugger
commands from standard input and forwarding debugger output to standard output, just as if the
inferior debugger had been invoked directly. All remainingddd functionality stays unchanged.

In case your debugger front-end uses thegdb ‘ -fullname ’ option to havegdb report source
code positions, the ‘--tty ’ option is not required.ddd recognizes the ‘-fullname ’ option, finds
that it has been invoked from a debugger front-end and automatically enables thetty interface.

If ddd is invoked with the ‘-fullname ’ option, the debugger console and the source window
are initially disabled, as their facilities are supposed to be provided by the integrating front-end. In
case of need, you can use the ‘View ’ menu to re-enable these windows.

10.3.1 Using DDD with Emacs

To integrateddd with Emacs, useM-x gdb or M-x dbx in Emacs to start a debugging session.
At the prompt, enterddd --tty (followed by ‘--dbx ’ or ‘ --gdb ’, if required), and the name of
the program to be debugged. Proceed as usual.

10.3.2 Using DDD with XEmacs

To integrateddd with XEmacs, set the variablegdb-command-name to ‘"ddd" ’, by insert-
ing the following line in your ‘~/.emacs ’ file:

(setq gdb-command-name "ddd")

You can also evaluate this expression by pressing〈ESC〉 〈:〉 and entering it directly (〈ESC〉 〈ESC〉
for XEmacs 19.13 and earlier).
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To start addd debugging session in XEmacs, use ‘M-x gdb ’ or ‘ M-x gdbsrc ’. Proceed as
usual.

10.3.3 Using DDD withxxgdb

To integrateddd with xxgdb, invokexxgdb as

xxgdb -db_name ddd -db_prompt ’(gdb) ’

10.4 Defining Buttons

To facilitate interaction, you can add own command buttons toddd. These buttons can be added
below the debugger console (‘Console Buttons ’), the source window (‘Source Buttons ’),
or the data window (‘Data Buttons ’).

To define individual buttons, use theButton Editor, invoked via ‘Commands⇒ Edit
Buttons ’. The button editor displays a text, where each line contains the command for exactly
one button. Clicking on ‘OK’ creates the appropriate buttons from the text. If the text is empty (the
default), no button is created.

As a simple example, assume you want to create a ‘print i ’ button. Invoke ‘Commands
⇒ Edit Buttons ’ and enter a line saying ‘print i ’ in the button editor. Then click on ‘OK’.
A button named ‘Print i ’ will now appear below the debugger console—try it! To remove the
button, reopen the button editor, clear the ‘print i ’ line and press ‘OK’ again.

If a button command contains ‘() ’, the string ‘() ’ will automatically be replaced by the contents
of the argument field. For instance, a button named ‘return () ’ will execute thegdb ‘ return ’
command with the current content of the argument field as argument.

By default,ddd disables buttons whose commands are not supported by the inferior debugger.
To enable such buttons, unset the ‘Enable supported buttons only ’ toggle in the button
editor.
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Defining individual buttons

... to create these buttons.
Enter text here...

ddd also allows you to specify control sequences and special labels for user-defined buttons.
SeeSection 10.4.1 [Customizing Buttons], page 152, for details.

10.4.1 Customizing Buttons

ddd allows defining additional command buttons; SeeSection 10.4 [Defining Buttons],
page 151, for doing this interactively. This section describes the resources that control user-defined
buttons.

ResourceconsoleButtons(class Buttons)
A newline-separated list of buttons to be added under the debugger console. Each button
issues the command given by its name.

The following characters have special meanings:

• Commands ending with... insert their name, followed by a space, in the debugger
console.

• Commands ending with a control character (that is, ‘^ ’ followed by a letter or ‘?’) insert
the given control character.

• The string ‘() ’ is replaced by the current contents of the argument field ‘() ’.

• The string specified in the ‘labelDelimiter ’ resource (usually ‘// ’) separates the
command name from the button label. If no button label is specified, the capitalized
command will be used as button label.

The following button names are reserved:

‘Apply ’ Send the given command to the debugger.
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‘Back ’ Lookup previously selected source position.

‘Clear ’ Clear current command

‘Complete ’
Complete current command.

‘Edit ’ Edit current source file.

‘Forward ’
Lookup next selected source position.

‘Make’ Invoke the ‘make’ program, using the most recently given arguments.

‘Next ’ Show next command

‘No’ Answer current debugger prompt with ‘no ’. This button is visible only if the
debugger asks a yes/no question.

‘Prev ’ Show previous command

‘Reload ’ Reload source file.

‘Yes ’ Answer current debugger prompt with ‘yes ’. This button is visible only if the
debugger asks a yes/no question.

The default resource value is empty—no console buttons are created.

Here are some examples to insert into your ‘~/.ddd/init ’ file. These are the settings of
ddd 1.x:

Ddd*consoleButtons: Yes\nNo\nbreak^C

This setting creates some more buttons:
Ddd*consoleButtons: \
Yes\nNo\nrun\nClear\nPrev\nNext\nApply\nbreak^C

See also the ‘dataButtons ’, ‘ sourceButtons ’ and ‘toolButtons ’ resources.

ResourcedataButtons (class Buttons)
A newline-separated list of buttons to be added under the data display. Each button issues the
command given by its name. See the ‘consoleButtons ’ resource, above, for details on
button syntax.

The default resource value is empty—no source buttons are created.

ResourcesourceButtons (class Buttons)
A newline-separated list of buttons to be added under the debugger console. Each button
issues the command given by its name. See the ‘consoleButtons ’ resource, above, for
details on button syntax.

The default resource value is empty—no source buttons are created.

Here are some example to insert into your ‘~/.ddd/init ’ file. These are the settings of
ddd 1.x:

Ddd*sourceButtons: \
run\nstep\nnext\nstepi\nnexti\ncont\n\
finish\nkill\nup\ndown\n\
Back\nForward\nEdit\ninterrupt^C

This setting creates some buttons which are not found on the command tool:
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Ddd*sourceButtons: \
print *()\ngraph display *()\nprint /x ()\n\
whatis ()\nptype ()\nwatch ()\nuntil\nshell

An even more professional setting uses customized button labels.

Ddd*sourceButtons: \
print *(()) // Print *()\n\
graph display *(()) // Display *()\n\
print /x ()\n\
whatis () // What is ()\n\
ptype ()\n\
watch ()\n\
until\n\
shell

See also the ‘consoleButtons ’ and ‘dataButtons ’ resources, above, and the
‘ toolButtons ’ resource, below.

ResourcetoolButtons (class Buttons)
A newline-separated list of buttons to be included in the command tool or the command tool
bar (seeSection 3.3.1.1 [Disabling the Command Tool], page 57). Each button issues the
command given by its name. SeeSection 10.4 [Defining Buttons], page 151, for details on
button syntax.

The default resource value is

Ddd*toolButtons: \
run\nbreak^C\nstep\nstepi\nnext\nnexti\n\
until\nfinish\ncont\n\kill\n\
up\ndown\nBack\nForward\nEdit\nMake

For each button, its location in the command tool must be specified using ‘XmForm’ con-
straint resources. See the ‘Ddd’ application defaults file for instructions.

If the ‘toolButtons ’ resource value is empty, the command tool is not created.

The following resources set up button details:

ResourcelabelDelimiter (class LabelDelimiter)
The string used to separate labels from commands and shortcuts. Default is ‘// ’.

ResourceverifyButtons (class VerifyButtons)
If ‘ on ’ (default), verify for each button whether its command is actually supported by the
inferior debugger. If the command is unknown, the button is disabled. If this resource is
‘off ’, no checking is done: all commands are accepted “as is”.

10.5 Defining Commands

Aside from breakpoint commands (seeSection 5.1.8 [Breakpoint Commands], page 85), ddd
also allows you to define user-defined commands. Auser-defined commandis a sequence of com-
mands to which you assign a new name as a command. This new command can be entered at the
debugger prompt or invoked via a button.
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10.5.1 Defining Simple Commands using GDB

Aside from breakpoint commands (see ‘Breakpoint commands ’, above),ddd also allows
you to store sequences of commands as a user-definedgdb command. Auser-defined commandis
a sequence ofgdb commands to which you assign a new name as a command. Usingddd, this is
done via theCommand Editor, invoked via ‘Commands⇒ Define Command ’.

A gdb command is created in five steps:

1. Enter the name of the command in the ‘Command’ field. Use the drop-down list on the right
to select from already defined commands.

2. Click on ‘Record ’ to begin the recording of the command sequence.

3. Now interact withddd. While recording,ddd does not execute commands, but simply records
them to be executed when the breakpoint is hit. The recorded debugger commands are shown
in the debugger console.

4. To stop the recording, click on ‘End’ or enter ‘end ’ at thegdb prompt. Tocancelthe record-
ing, click on ‘Interrupt ’ or press〈ESC〉.

5. Click on ‘Edit >> ’ to edit the recorded commands. When done with editing, click on ‘Edit
<<’ to close the commands editor.

After the command is defined, you can enter it at thegdb prompt. You may also click on
‘Execute ’ to test the given user-defined command.

For convenience, you can assign a button to the defined command. Enabling one of the
‘Button ’ locations will add a button with the given command to the specified location. If you
want to edit the button, select ‘Commands⇒ Edit Buttons ’. See Section 10.4 [Defining
Buttons], page 151, for a discussion.

Command Name Command Definition

If enabled, use argument field symbolically

Defining GDB Commands

Start Recording Assign Button
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When user-definedgdb commands are executed, the commands of the definition are not printed.
An error in any command stops execution of the user-defined command.1

If used interactively, commands that would ask for confirmation proceed without asking when
used inside a user-defined command. Manygdb commands that normally print messages to say
what they are doing omit the messages when used in a user-defined command.

Command definitions are saved acrossddd sessions.

10.5.2 Defining Argument Commands using GDB

If you want to pass arguments to user-defined commands, you can enable the ‘() ’ toggle button
in the Command Editor. Enabling ‘() ’ has two effects:

• While recording commands, all references to the argument field are takensymbolicallyinstead
of literally. The argument field value is frozen to ‘$arg0 ’, which is howgdb denotes the argu-
ment of a user-defined command. Whengdb executes the command, it will replace ‘$arg0 ’
by the current command argument.

• When assigning a button to the command, the command will be suffixed by the current contents
of the argument field.

While defining a command, you can toggle the ‘() ’ button as you wish to switch between using
the argument field symbolically and literally.

As an example, let us define a commandcontuntil that will set a breakpoint in the given
argument and continue execution.

1. Enter ‘contuntil ’ in the ‘Command’ field.

2. Enable the ‘() ’ toggle button.

3. Now click on ‘Record ’ to start recording. Note that the contents of the argument field change
to ‘$arg0 ’.

4. Click on ‘Break at () ’ to create a breakpoint. Note that the recorded breakpoint command
refers to ‘$arg0 ’.

5. Click on ‘Cont ’ to continue execution.

6. Click on ‘End’ to end recording. Note that the argument field is restored to its original value.

7. Finally, click on one of the ‘Button ’ locations. This creates a ‘Contuntil () ’ button
where ‘() ’ will be replaced by the current contents of the argument field—and thus passed to
the ‘contuntil ’ command.

8. You can now either use the ‘Contuntil () ’ button or enter a ‘contuntil ’ command at
thegdb prompt. (If you plan to use the command frequently, you may wish to define a ‘cu ’
command, which again calls ‘contuntil ’ with its argument. This is a nice exercise.)

There is a little drawback with argument commands: a user-defined command ingdb has no
means to access the argument list as a whole; only the first argument (up to whitespace) is processed.
This may change in futuregdb releases.

1 If you useddd commands within command definitions, or if you include debugger commands that re-
sume execution, these commands will be realized transparently asauto-commands—that is, they won’t
be executed directly by the inferior debugger, but result in a command string being sent toddd. This
command string is then interpreted byddd and sent back to the inferior debugger, possibly prefixed by
some other commands such thatddd can update its state. SeeSection 10.5.3 [Commands with Other
Debuggers], page 157, for a discussion.
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10.5.3 Defining Commands using Other Debuggers

If your inferior debugger allows you to define own command sequences, you can also use these
user-defined commands withinddd; just enter them at the debugger prompt.

However, you may encounter some problems:

• In contrast to the well-documented commands of the inferior debugger,ddd does not know
what a user-defined command does. This may lead to inconsistencies betweenddd and the
inferior debugger. For instance, if your the user-defined command ‘bp ’ sets a breakpoint,ddd
may not display it immediately, becauseddd does not know that ‘bp ’ changes the breakpoint
state.

• You cannot useddd ‘graph ’ commands within user-defined commands. This is only natural,
because user-defined commands are interpreted by the inferior debugger, which does not know
aboutddd commands.

As a solution,ddd provides a simple facility calledauto-commands. If ddd receives any output
from the inferior debugger in the form ‘prefix command ’, it will interpret command as if it had
been entered at the debugger prompt.prefix is a user-defined string, for example ‘ddd: ’.

Suppose you want to define a commandgd that serves as abbreviation forgraph display .
All the commandgd has to do is to issue a string

ddd: graph display argument
whereargument is the argument given togd . Usinggdb, this can be achieved using theecho

command. In your ‘~/.gdbinit ’ file, insert the lines

define gd
echo ddd: graph display $arg0\n

end

To complete the setting, you must also set the ‘autoCommandPrefix ’ resource to the ‘ddd:
’ prefix you gave in your command. In ‘~/.ddd/init ’, write:

Ddd*autoCommandPrefix: ddd:\

(Be sure to leave a space after the trailing backslash.)

Enteringgd foo will now have the same effect as enteringgraph display foo at the de-
bugger prompt.

Please note: In your commands, you should choose some other prefix than ‘ddd: ’. This is
because auto-commands raise a security problem, since arbitrary commands can be executed. Just
imagine some malicious program issuing a string like ‘prefix shell rm -fr ~ ’ when being de-
bugged! As a consequence, be sure to choose your ownprefix; it must be at least three characters
long.
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Appendix A Application Defaults

Like any good X citizen,ddd comes with a large application-defaults file named ‘Ddd’. This
appendix documents the actions and images referenced in ‘Ddd’, such that you can easily modify
them.

A.1 Actions

The followingddd actions may be used in translation tables.

A.1.1 General Actions

Actionddd-get-focus ()
Assign focus to the element that just received input.

Actionddd-next-tab-group ()
Assign focus to the next tab group.

Actionddd-prev-tab-group ()
Assign focus to the previous tab group.

Actionddd-previous-tab-group ()
Assign focus to the previous tab group.

A.1.2 Data Display Actions

These actions are used in theddd graph editor.

Actionend ()
End the action initiated byselect . Bound to a button up event.

Actionextend ()
Extend the current selection. Bound to a button down event.

Actionextend-or-move ()
Extend the current selection. Bound to a button down event. If the pointer is dragged, move
the selection.

Actionfollow ()
Continue the action initiated byselect . Bound to a pointer motion event.

Actiongraph-select ()
Equivalent toselect , but also updates the current argument.

Actiongraph-select-or-move()
Equivalent toselect-or-move , but also updates the current argument.
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Actiongraph-extend ()
Equivalent toextend , but also updates the current argument.

Actiongraph-extend-or-move ()
Equivalent toextend-or-move , but also updates the current argument.

Actiongraph-toggle ()
Equivalent totoggle , but also updates the current argument.

Actiongraph-toggle-or-move ()
Equivalent totoggle-or-move , but also updates the current argument.

Actiongraph-popup-menu ([graph|node|shortcut ])
Pops up a menu.graph pops up a menu with global graph operations,node pops up a
menu with node operations, andshortcut pops up a menu with display shortcuts.

If no argument is given, pops up a menu depending on the context: when pointing on a node
with the〈Shift〉 key pressed, behaves likeshortcut ; when pointing on a without the〈Shift〉
key pressed, behaves likenode ; otherwise, behaves as ifgraph was given.

Actiongraph-dereference ()
Dereference the selected display.

Actiongraph-detail ()
Show or hide detail of the selected display.

Actiongraph-rotate ()
Rotate the selected display.

Actiongraph-dependent ()
Pop up a dialog to create a dependent display.

Actionhide-edges([any|both|from|to ])
Hide some edges.any means to process all edges where either source or target node are
selected.both means to process all edges where both nodes are selected.from means to
process all edges where at least the source node is selected.to means to process all edges
where at least the target node is selected. Default isany .

Actionlayout ([regular|compact ], [[+|- ] degrees])
Layout the graph.regular means to use the regular layout algorithm;compact uses
an alternate layout algorithm, where successors are placed next to their parents. Default is
regular . degrees indicates in which direction the graph should be layouted. Default is the
current graph direction.

Actionmove-selected(x-offset, y-offset)
Move all selected nodes in the direction given byx-offset andy-offset. x-offset andy-offset
is either given as a numeric pixel value, or as ‘+grid ’, or ‘ -grid ’, meaning the current
grid size.
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Actionnormalize ()
Place all nodes on their positions and redraw the graph.

Actionrotate ([[+|- ]degrees])
Rotate the graph arounddegrees degrees.degrees must be a multiple of 90. Default is+90 .

Actionselect ()
Select the node pointed at. Clear all other selections. Bound to a button down event.

Actionselect-all ()
Select all nodes in the graph.

Actionselect-first ()
Select the first node in the graph.

Actionselect-next ()
Select the next node in the graph.

Actionselect-or-move()
Select the node pointed at. Clear all other selections. Bound to a button down event. If the
pointer is dragged, move the selected node.

Actionselect-prev ()
Select the previous node in the graph.

Actionshow-edges([any|both|from|to ])
Show some edges.any means to process all edges where either source or target node are
selected.both means to process all edges where both nodes are selected.from means to
process all edges where at least the source node is selected.to means to process all edges
where at least the target node is selected. Default isany .

Actionsnap-to-grid ()
Place all nodes on the nearest grid position.

Actiontoggle ()
Toggle the current selection—if the node pointed at is selected, it will be unselected, and vice
versa. Bound to a button down event.

Actiontoggle-or-move ()
Toggle the current selection—if the node pointed at is selected, it will be unselected, and vice
versa. Bound to a button down event. If the pointer is dragged, move the selection.

Actionunselect-all ()
Clear the selection.
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A.1.3 Debugger Console Actions

These actions are used in the debugger console and other text fields.

Actiongdb-backward-character ()
Move one character to the left. Bound toLeft .

Actiongdb-beginning-of-line ()
Move cursor to the beginning of the current line, after the prompt. Bound toHOME.

Actiongdb-control (control-character)
Send the givencontrol-character to the inferior debugger.control-character must be specified
in the form ‘̂ X ’, whereX is an upper-case letter, or ‘?’.

Actiongdb-command (command)
Executecommand in the debugger console. The following replacements are performed on
command :

• If command has the form ‘name... ’, insertname, followed by a space, in the debugger
console.

• All occurrences of ‘() ’ are replaced by the current contents of the argument field ‘() ’.

Actiongdb-complete-arg (command)
Complete current argument as ifcommand was prepended. Bound to〈Ctrl+T〉.

Actiongdb-complete-command()
Complete current command line in the debugger console. Bound to〈TAB〉.

Actiongdb-complete-tab (command)
If global 〈TAB〉 completion is enabled, complete current argument as ifcommand was
prepended. Otherwise, proceed as if the〈TAB〉 key was hit. Bound to〈TAB〉.

Actiongdb-delete-or-control (control-character)
Like gdb-control , but effective only if the cursor is at the end of a line. Otherwise,
control-character is ignored and the character following the cursor is deleted. Bound to
〈Ctrl+D〉.

Actiongdb-end-of-line ()
Move cursor to the end of the current line. Bound toEnd.

Actiongdb-forward-character ()
Move one character to the right. Bound toRight .

Actiongdb-insert-graph-arg ()
Insert the contents of the data display argument field ‘() ’.
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Actiongdb-insert-source-arg ()
Insert the contents of the source argument field ‘() ’.

Actiongdb-interrupt ()
If ddd is in incremental search mode, exit it; otherwise callgdb-control(^C) .

Actiongdb-isearch-prev ()
Enter reverse incremental search mode. Bound to〈Ctrl+B〉.

Actiongdb-isearch-next ()
Enter incremental search mode. Bound to〈Ctrl+F〉.

Actiongdb-isearch-exit ()
Exit incremental search mode. Bound to〈ESC〉.

Actiongdb-next-history ()
Recall next command from history. Bound toDown.

Actiongdb-prev-history ()
Recall previous command from history. Bound toUp.

Actiongdb-previous-history ()
Recall previous command from history. Bound toUp.

Actiongdb-process([action [, args. . . ]] )
Process the given event in the debugger console. Bound to key events in the source and data
window. If this action is bound to the source window, and the source window is editable,
perform action( args...) on the source window instead; ifaction is not given, perform
‘self-insert() ’.

Actiongdb-select-all ()
If the ‘selectAllBindings ’ resource is set toMotif , perform ‘beginning-of-line ’.
Otherwise, perform ‘select-all ’. Bound to〈Ctrl+A〉.

Actiongdb-set-line (value)
Set the current line tovalue. Bound to〈Ctrl+U〉.

A.1.4 Source Window Actions

These actions are used in the source and code windows.

Actionsource-delete-glyph()
Delete the breakpoint related to the glyph at cursor position.
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Actionsource-double-click ([text-action [, line-action [, function-action]]] )
The double-click action in the source window.

• If this action is taken on a breakpoint glyph, edit the breakpoint properties.

• If this action is taken in the breakpoint area, invoke ‘gdb-command( line-action) ’. If
line-action is not given, it defaults to ‘break () ’.

• If this action is taken in the source text, and the next character following the current
selection is ‘( ’, invoke ‘gdb-command( function-action) ’. If function-action is not
given, it defaults to ‘list () ’.

• Otherwise, invoke ‘gdb-command( text-action) ’. If text-action is not given, it de-
faults to ‘graph display () ’.

Actionsource-drag-glyph ()
Initiate a drag on the glyph at cursor position.

Actionsource-drop-glyph ([action])
Drop the dragged glyph at cursor position.action is either ‘move’, meaning to move the
dragged glyph, or ‘copy ’, meaning to copy the dragged glyph. If noaction is given, ‘move’
is assumed.

Actionsource-end-select-word()
End selecting a word.

Actionsource-follow-glyph ()
Continue a drag on the glyph at cursor position. Usually bound to some motion event.

Actionsource-popup-menu()
Pop up a menu, depending on the location.

Actionsource-set-arg()
Set the argument field to the current selection. Typically bound to some selection operation.

Actionsource-start-select-word()
Start selecting a word.

Actionsource-update-glyphs()
Update all visible glyphs. Usually invoked after a scrolling operation.

A.2 Images

ddd installs a number of images that may be used as pixmap resources, simply by giving a
symbolic name. For button images, three variants are installed as well:

• The suffix ‘-hi ’ indicates a highlighted variant (Button is entered).

• The suffix ‘-arm ’ indicates an armed variant (Button is pushed).

• The suffix ‘-xx ’ indicates a disabled (insensitive) variant.
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Imagebreak at
‘Break at () ’ button.

Imageclear at
‘Clear at () ’ button.

Imageddd
ddd icon.

Imagedelete
‘Delete () ’ button.

Imagedisable
‘Disable ’ button.

Imagedispref
‘Display * () ’ button.

Imagedisplay
‘Display () ’ button.

Imagedrag arrow
The execution pointer (being dragged).

Imagedrag cond
A conditional breakpoint (being dragged).

Imagedrag stop
A breakpoint (being dragged).

Imagedrag temp
A temporary breakpoint (being dragged).

Imageenable
‘Enable ’ button.

Imagefind forward
‘Find>> () ’ button.

Imagefind backward
‘Find<< () ’ button.

Imagegrey arrow
The execution pointer (not in lowest frame).
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Imagegrey cond
A conditional breakpoint (disabled).

Imagegrey stop
A breakpoint (disabled).

Imagegrey temp
A temporary breakpoint (disabled).

Imagehide
‘Hide () ’ button.

Imagelookup
‘Lookup () ’ button.

Imagemaketemp
‘Make Temporary ’ button.

Imagenew break
‘New Breakpoint ’ button.

Imagenew display
‘New Display ’ button.

Imagenew watch
‘New Watchpoint ’ button.

Imageplain arrow
The execution pointer.

Imageplain cond
A conditional breakpoint (enabled).

Imageplain stop
A breakpoint (enabled).

Imageplain temp
A temporary breakpoint (enabled).

Imageprint
‘Print () ’ button.

Imageproperties
‘Properties ’ button.



Appendix A: Application Defaults 167

Imagerotate
‘Rotate () ’ button.

Imageset
‘Set () ’ button.

Imageshow
‘Show () ’ button.

Imagesignal arrow
The execution pointer (stopped by signal).

Imageundisplay
‘Undisplay () ’ button.

Imageunwatch
‘Unwatch () ’ button.

Imagewatch
‘Watch () ’ button.
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Appendix B Bugs and How To Report Them

Sometimes you will encounter a bug inddd. Although we cannot promise we can or will fix
the bug, and we might not even agree that it is a bug, we want to hear about bugs you encounter in
case we do want to fix them.

To make it possible for us to fix a bug, you must report it. In order to do so effectively, you must
know when and how to do it.

B.1 Where to Send Bug Reports

Send bug reports forddd via electronic mail to

bug-ddd@gnu.org

B.2 Is it a DDD Bug?

Before sending in a bug report, try to find out whether the problem cause really lies withinddd.
A common cause of problems are incomplete or missing X or M*tif installations, for instance, or
bugs in the X server or M*tif itself. Runningddd as

$ ddd --check-configuration

checks for common problems and gives hints on how to repair them.

Another potential cause of problems is the inferior debugger; occasionally, they show bugs, too.
To find out whether a bug was caused by the inferior debugger, runddd as

$ ddd --trace

This shows the interaction betweenddd and the inferior debugger on standard error whileddd
is running. (If ‘--trace ’ is not given, this interaction is logged in the file ‘~/.ddd/log ’;
seeSection B.5.1 [Logging], page 170) Compare the debugger output to the output ofddd and
determine which one is wrong.

B.3 How to Report Bugs

Here are some guidelines for bug reports:

• The fundamental principle of reporting bugs usefully is this:report all the facts. If you are
not sure whether to state a fact or leave it out, state it!

• Keep in mind that the purpose of a bug report is to enable someone to fix the bug if it is not
known. It is not very important what happens if the bug is already known. Therefore, always
write your bug reports on the assumption that the bug is not known.

• Your bug report should be self-contained. Do not refer to information sent in previous mails;
your previous mail may have been forwarded to somebody else.

• Please report each bug in a separate message. This makes it easier for us to track which bugs
have been fixed and to forward your bugs reports to the appropriate maintainer.

• Please report bugs in English; this increases the chances of finding someone who can fix the
bug. Do not assume one particular person will receive your bug report.

mailto:bug-ddd@gnu.org


170 Debugging with DDD

B.4 What to Include in a Bug Report

To enable us to fix addd bug, youmustinclude the following information:

• Your ddd configuration. Invokeddd as

$ ddd --configuration

to get the configuration information. If this does not work, please include at least theddd
version, the type of machine you are using, and its operating system name and version number.

• The debugger you are using and its version (e.g., ‘gdb-4.17 ’ or ‘ dbx as shipped with
Solaris 2.6 ’).

• The compiler you used to compileddd and its version (e.g., ‘gcc-2.8.1 ’).

• A description of what behavior you observe that you believe is incorrect. For example, “ddd
gets a fatal signal” or “ddd exits immediately after attempting to create the data window“.

• A log file showing the interaction betweenddd and the inferior debugger. By default, this
interaction is logged in the file ‘~/.ddd/log ’. Include all trace output from theddd invo-
cation up to the first bug occurrence; insert own comments where necessary.

• If you wish to suggest changes to theddd source, send us context diffs. If you even discuss
something in theddd source, refer to it by context,neverby line number.

Be sure to include this information ineverysingle bug report.

B.5 Getting Diagnostics

B.5.1 Logging

If things go wrong, the first and most important information source is theddd log file. This file,
created in ‘~/.ddd/log ’ (‘ ~’ stands for your home directory), records the following information:

• Your ddd configuration (at the top)

• All programs invoked byddd, shown as ‘$ program args... ’

• All ddd messages, shown as ‘# message ’.

• All information sent fromddd to the inferior debugger, shown as ‘-> text ’.

• All information sent from the inferior debugger standard output toddd, shown as ‘<- text ’.

• All information sent from the inferior debugger standard error toddd, shown as ‘<= text ’.1

• All information sent fromddd to Gnuplot, shown as ‘>> text ’.

• All information sent from Gnuplot standard output toddd, shown as ‘<< text ’.

• All information sent from Gnuplot standard error toddd, shown as ‘<= text ’.

• If ddd crashes, agdb backtrace of theddd core dump is included at the end.

This information, all in one place, should give you (and anyone maintainingddd) a first insight
of what’s going wrong.

1 Since the inferior debugger is invoked through a virtualtty, standard error is normally redirected to
standard output, soddd never receives standard error from the inferior debugger.
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B.5.1.1 Disabling Logging

The log files created byddd can become quite large, so you might want to turn off logging.
There is no explicitddd feature that allows you to do that. However, you can easily create a
symbolic linkfrom ‘~/.ddd/log ’ to ‘ /dev/null ’, such that logging information is lost. Enter
the following commands at the shell prompt:

$ cd
$ rm .ddd/log
$ ln -s /dev/null .ddd/log
$ _

Be aware, though, that having logging turned off makes diagnostics much more difficult; in case
of trouble, it may be hard to reproduce the error.

B.5.2 Debugging DDD

As long asddd is compiled with ‘-g ’ (seeSection 4.1 [Compiling for Debugging], page 73),
you can invoke a debugger onddd—evenddd itself, if you wish. From withinddd, a special
‘Maintenance ’ menu is provided that invokesgdb on the runningddd process. SeeSec-
tion 3.1.9 [Maintenance Menu], page 49, for details.

The ddd distribution comes with a ‘.gdbinit ’ file that is suitable for debuggingddd.
Among others, this defines a ‘ddd ’ command that sets up an environment for debuggingddd
and a ‘string ’ command that lets you print the contents ofddd ‘string ’ variables; just use
‘print var ’ followed by ‘string ’.

You can causeddd to dump core at any time by sending it aSIGUSR1signal. ddd resumes
execution while you can examine the core file withgdb.

When debuggingddd, it can be useful to makeddd not catch fatal errors. This can be achieved
by setting the environment variableDDD_NO_SIGNAL_HANDLERSbefore invokingddd.

B.5.3 Customizing Diagnostics

You can use these additional resources to obtain diagnostics aboutddd. Most of them are tied
to a particular invocation option.

ResourceappDefaultsVersion (class Version)
The version of theddd app-defaults file. If this string does not match the version of the
currentddd executable,ddd issues a warning.

ResourcecheckConfiguration (class CheckConfiguration)
If ‘ on ’, check the ddd environment (in particular, the X configuration), report any
possible problem causes and exit. SeeSection 2.1.2 [Options], page 16, for the
‘ --check-configuration ’ option.

ResourcedddinitVersion (class Version)
The version of theddd executable that last wrote the ‘~/.ddd/init ’ file. If this string
does not match the version of the currentddd executable,ddd issues a warning.
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ResourcedebugCoreDumps (class DebugCoreDumps)
If ‘ on ’, ddd invokes a debugger on itself when receiving a fatal signal. SeeSection 3.1.9
[Maintenance Menu], page 49, for setting this resource.

ResourcedumpCore (class DumpCore)
If ‘ on ’ (default),ddd dumps core when receiving a fatal signal. SeeSection 3.1.9 [Mainte-
nance Menu], page 49, for setting this resource.

Resourcemaintenance (class Maintenance)
If ‘ on ’, enables the top-level ‘Maintenance ’ menu (seeSection 3.1.9 [Maintenance
Menu], page 49) with additional options. SeeSection 2.1.2 [Options], page 16, for the
‘ --maintenance ’ option.

ResourceshowConfiguration (class ShowConfiguration)
If ‘ on ’, show theddd configuration on standard output and exit. SeeSection 2.1.2 [Options],
page 16, for the ‘--configuration ’ option.

ResourceshowFonts (class ShowFonts)
If ‘ on ’, show theddd font definitions on standard output and exit. SeeSection 2.1.2 [Op-
tions], page 16, for the ‘--fonts ’ option.

ResourceshowInvocation (class ShowInvocation)
If ‘ on ’, show theddd invocation options on standard output and exit. SeeSection 2.1.2
[Options], page 16, for the ‘--help ’ option.

ResourceshowLicense(class ShowLicense)
If ‘ on ’, show theddd license on standard output and exit. SeeSection 2.1.2 [Options],
page 16, for the ‘--license ’ option.

ResourceshowManual (class ShowManual)
If ‘ on ’, show thisddd manual page on standard output and exit. If the standard output is a
terminal, the manual page is shown in a pager ($PAGER, less or more ). SeeSection 2.1.2
[Options], page 16, for the ‘--manual ’ option.

ResourceshowNews(class ShowNews)
If ‘ on ’, show theddd news on standard output and exit. SeeSection 2.1.2 [Options], page 16,
for the ‘--news ’ option.

ResourceshowVersion (class ShowVersion)
If ‘ on ’, show theddd version on standard output and exit. SeeSection 2.1.2 [Options],
page 16, for the ‘--version ’ option.

ResourcesuppressWarnings (class SuppressWarnings)
If ‘ on ’, X warnings are suppressed. This is sometimes useful for executables that were built
on a machine with a different X or M*tif configuration. By default, this is ‘off ’. See
Section 2.1.6 [X Warnings], page 28, for details.
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Resourcetrace (class Trace)
If ‘ on ’, show the dialog betweenddd and the inferior debugger on standard output. Default
is ‘off ’. SeeSection 2.1.2 [Options], page 16, for the ‘--trace ’ option.
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Appendix C Configuration Notes

C.1 Using DDD with GDB

Somegdb settings are essential forddd to work correctly. These settings with their correct
values are:

set height 0
set width 0
set verbose off
set annotate 1
set prompt (gdb)

ddd sets these values automatically when invokinggdb; if these values are changed, there may
be some malfunctions, especially in the data display.

When debugging at the machine level withgdb 4.12 and earlier as inferior debugger, use a
‘display /x $pc ’ command to ensure the program counter value is updated correctly at each
stop. You may also enter the command in ‘~/.gdbinit ’ or (better yet) upgrade to the most
recentgdb version.

C.1.1 Using DDD with WDB

HP’s WildeBeest (wdb) is essentially a variant ofgdb. To startddd with wdb as inferior
debugger, use

ddd --wdb program

SeeSection C.1 [GDB], page 175, for further configuration notes.

C.1.2 Using DDD with WindRiver GDB (Tornado)

ddd now supports WindRiver’s version ofgdb.1 ddd can be integrated into the ‘Launch ’
window by placing the ‘launch.tcl ’ script (see below) into the the directory ‘~/.wind ’.

Currently,ddd only supports the PowerPC and has been only tested on a Solaris 2.6 host.

ddd launches the version ofgdb that is either in the current path, or the one specified on the
command line using the ‘--debugger ’ command.

Normally, the Tornado environment is set up by sourcing a script file which, among other things,
sets up the PATH variable.

It is suggested that a soft link for the version ofgdb used for the target (i.e. ‘gdbppc ’) be made
in the same directory:

bin> ls -l gdb*
39 Mar 6 16:14 gdb -> /usr/wind/host/sun4-solaris2/bin/gdbppc*
1619212 Mar 11 1997 gdbppc*
bin>_

This wayddd will start the correct version ofgdb automatically.

1 This section was contributed by Gary Cliff from Computing Devices Canada Ltd.,
gary.cliff@cdott.com .

mailto:gary.cliff@cdott.com
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It is also suggested that you useddd’s execution window to facilitate parsing ofgdb output.
SeeSection 2.5.3 [Debugger Communication], page 38, for details.

Tornado reads the default TCL scripts first, then the ones in the users ‘.wind ’ directory. The
following procedures can be cut and pasted into the user’s ‘launch.tcl ’ file:

� �
# Launch.tcl - Launch application Tcl user customization file.
#

######
#
# setupDDD - sets up DDD for use by the launcher
#
# This routine adds the DDD to the application bar
#
# SYNOPSIS:
# setupDDD
#
# PARAMETERS: N/A
#
# RETURNS: N/A
#
# ERRORS: N/A
#

proc setupDDD {} {
# Add to the default application bar
objectCreate app ddd DDD {launchDDD}

}
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######
#
# launchDDD - launch the DDD debugger
#
# SYNOPSIS:
# launchDDD
#
# PARAMETERS: N/A
#
# RETURNS: N/A
#
# ERRORS: N/A
#

proc launchDDD {} {

global tgtsvr_selected
global tgtsvr_cpuid

if {$tgtsvr_selected == "" || $tgtsvr_cpuid == 0} {
noticePost error "Select an attached target first."
return

}

set startFileName /tmp/dddstartup.[pid]

if [catch {open $startFileName w} file] {
# couldn’t create a startup file. Oh, well.
exec ddd --gdb &

}
else
{

# write out a little /tmp file that attaches to the
# selected target server and then deletes itself.
puts $file "set wtx-tool-name ddd"
puts $file "target wtx $tgtsvr_selected"
puts $file "tcl exec rm $startFileName"
close $file
exec ddd --gdb --command=$startFileName &

}
}
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######
#
# Launch.tcl - Initialization
#
# The user’s resource file sourced from the initial Launch.tcl
#

# Add DDD to the laucher
setupDDD
 	

In order forddd to automatically display the source of a previously loaded file, the entry point
must be named either ‘vxworks_main ’ or ‘ main_vxworks ’.

SeeSection C.1 [GDB], page 175, for further configuration notes.

C.2 Using DDD with DBX

When used for debugging Pascal-like programs,ddd does not infer correct array subscripts and
always starts to count with 1.

With somedbx versions (notably Solarisdbx), ddd strips C-style and C++-style comments
from thedbx output in order to interpret it properly. This also affects the output of the debugged
program when sent to the debugger console. Using the separate execution window avoids these
problems.

In somedbx versions (notably DECdbx and AIX dbx), there is no automatic data display.
As an alternative,ddd uses thedbx ‘print ’ command to access data values. This means that
variable names are interpreted according to the current frame; variables outside the current frame
cannot be displayed.

C.3 Using DDD with Ladebug

All dbx limitations (seeSection C.2 [DBX], page 178) apply to Ladebug as well.

C.4 Using DDD with XDB

There is no automatic data display inxdb. As a workaround,ddd uses the ‘p’ command to
access data values. This means that variable names are interpreted according to the current frame;
variables outside the current frame cannot be displayed.

C.5 Using DDD with JDB

There is no automatic data display injdb. As a workaround,ddd uses the ‘dump’ command to
access data values. This means that variable names are interpreted according to the current frame;
variables outside the current frame cannot be displayed.

In jdb 1.1, the ‘dump’ and ‘print ’ commands do not support expression evaluation. Hence,
you cannot display arbitrary expressions.

Parsing ofjdb output is quite CPU-intensive, due to the recognition of asynchronous prompts
(any thread may output anything at any time, including prompts). Hence, a program producing
much console output is likely to slow downddd considerably. In such a case, have the program run
with ‘ -debug ’ in a separate window and attachjdb to it using the ‘-passwd ’ option.
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C.6 Using DDD with Perl

There is no automatic data display in Perl. As a workaround,ddd uses the ‘x ’ command to
access data values. This means that variable names are interpreted according to the current frame;
variables outside the current frame cannot be displayed.

C.7 Using DDD with Bash

bash support is rather new. As a programming language,bash is not feature rich: there are no
record structures or hash tables (yet), no pointers, package variable scoping or methods. So much
of the data display and visualization features of DDD are disabled.

As with any scripting or interpreted language like Perl, stepping a machine-language instructions
(commands Stepi/Nexti) doesn’t exist.

Somebash settings are essential forddd to work correctly. These settings with their correct
values are:

set annotate 1
set prompt set prompt bashdb$_Dbg_less$_Dbg_greater$_Dbg_space

ddd sets these values automatically when invokingbash; if these values are changed, there
may be some malfunctions.

Pay special attention when the prompt has extra angle brackets (a nested shell) or has any paren-
thesis (is in a subshell). Quitting may merely exit out of one of these nested (sub)shells rather than
leave the program.

C.8 Using DDD with LessTif

ddd includes a number of hacks that makeddd run with LessTif,a free M*tif library with-
out loss of functionality. Since addd binary may be dynamically bound and used with either an
OSF/Motif or LessTif library, theselesstif hackscan be enabled and disabled at run time.

Whether the lesstif hacks are included at run-time depends on the setting of the
‘ lessTifVersion ’ resource:

ResourcelessTifVersion (class LessTifVersion)
Indicates the LessTif versionddd is running against. For LessTif versionx.y, the value isx
multiplied by 1000 plusy—for instance, the value79 stands for LessTif 0.79 and the value
1005 stands for LessTif 1.5.

If the value of this resource is less than 1000, indicating LessTif 0.99 or earlier,ddd enables
version-specific hacks to makeddd work around LessTif bugs and deficiencies.

If ddd was compiled against LessTif, the default value is the value of the
‘LessTifVersion ’ macro in ‘<Xm/Xm.h> ’. If ddd was compiled against OSF/Motif,
the default value is1000 , disabling all LessTif-specific hacks.

To set the ‘lessTifVersion ’ resource atddd invocation and to specify the version number
of the LessTif library, you can also use the option ‘--lesstif-version ’ version.

The default value of the ‘lessTifVersion ’ resource is derived from the LessTif libraryddd
was compiled against (or1000 when compiled against OSF/Motif). Hence, you normally don’t
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need to worry about the value of this resource. However, if you use a dynamically linkedddd
binary with a library other than the oneddd was compiled against, you must specify the version
number of the library using this resource. (Unfortunately,ddd cannot detect this at run-time.)

Here are a few scenarios to illustrate this scheme:

• Yourddd binary was compiled against OSF/Motif, but you use a LessTif 0.88 dynamic library
instead. Invokeddd with ‘ --lesstif-version 88 ’.

• Your ddd binary was compiled against LessTif, but you use a OSF/Motif dynamic library
instead. Invokeddd with ‘ --lesstif-version 1000 ’.

• Your ddd binary was compiled against LessTif 0.85, and you have upgraded to LessTif 0.90.
Invokeddd with ‘ --lesstif-version 90 ’.

To find out the LessTif or OSF/Motif versionddd was compiled against, invokeddd with the
‘ --configuration ’ option.

In theddd source, LessTif-specific hacks are controlled by the string ‘lesstif_version ’.
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Appendix D Dirty Tricks

Do you miss anything in this manual? Do you have any material that should be added? Please
send any contributions toddd@gnu.org .

mailto:ddd@gnu.org
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Appendix E Extending DDD

If you have any contributions to be incorporated intoddd, please send them toddd@gnu.org .
For suggestions on what might be done, see the file ‘TODO’ in the ddd distribution.

mailto:ddd@gnu.org


184 Debugging with DDD



Appendix F: Frequently Answered Questions 185

Appendix F Frequently Answered Questions

Seetheddd www pagefor frequently answered questions not covered in this manual.

http://www.gnu.org/software/ddd/


186 Debugging with DDD



Appendix G: GNU General Public License 187

Appendix G GNU General Public License

Version 2, June 1991

Copyright c© 1989, 1991 Free Software Foundation, Inc. 675
Mass Ave, Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change
it. By contrast, the GNU General Public License is intended to guarantee your freedom to share
and change free software—to make sure the software is free for all its users. This General Public
License applies to most of the Free Software Foundation’s software and to any other program whose
authors commit to using it. (Some other Free Software Foundation software is covered by the GNU
Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public
Licenses are designed to make sure that you have the freedom to distribute copies of free software
(and charge for this service if you wish), that you receive source code or can get it if you want it,
that you can change the software or use pieces of it in new free programs; and that you know you
can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights
or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you
if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must
give the recipients all the rights that you have. You must make sure that they, too, receive or can get
the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license
which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone understands
that there is no warranty for this free software. If the software is modified by someone else and
passed on, we want its recipients to know that what they have is not the original, so that any problems
introduced by others will not reflect on the original authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the
danger that redistributors of a free program will individually obtain patent licenses, in effect making
the program proprietary. To prevent this, we have made it clear that any patent must be licensed for
everyone’s free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND
MODIFICATION

0. This License applies to any program or other work which contains a notice placed by the copy-
right holder saying it may be distributed under the terms of this General Public License. The
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“Program”, below, refers to any such program or work, and a “work based on the Program”
means either the Program or any derivative work under copyright law: that is to say, a work
containing the Program or a portion of it, either verbatim or with modifications and/or trans-
lated into another language. (Hereinafter, translation is included without limitation in the term
“modification”.) Each licensee is addressed as “you”.

Activities other than copying, distribution and modification are not covered by this License;
they are outside its scope. The act of running the Program is not restricted, and the output from
the Program is covered only if its contents constitute a work based on the Program (independent
of having been made by running the Program). Whether that is true depends on what the
Program does.

1. You may copy and distribute verbatim copies of the Program’s source code as you receive it,
in any medium, provided that you conspicuously and appropriately publish on each copy an
appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to
this License and to the absence of any warranty; and give any other recipients of the Program
a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option
offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work
based on the Program, and copy and distribute such modifications or work under the terms of
Section 1 above, provided that you also meet all of these conditions:

a. You must cause the modified files to carry prominent notices stating that you changed the
files and the date of any change.

b. You must cause any work that you distribute or publish, that in whole or in part contains
or is derived from the Program or any part thereof, to be licensed as a whole at no charge
to all third parties under the terms of this License.

c. If the modified program normally reads commands interactively when run, you must cause
it, when started running for such interactive use in the most ordinary way, to print or dis-
play an announcement including an appropriate copyright notice and a notice that there is
no warranty (or else, saying that you provide a warranty) and that users may redistribute
the program under these conditions, and telling the user how to view a copy of this Li-
cense. (Exception: if the Program itself is interactive but does not normally print such
an announcement, your work based on the Program is not required to print an announce-
ment.)

These requirements apply to the modified work as a whole. If identifiable sections of that work
are not derived from the Program, and can be reasonably considered independent and separate
works in themselves, then this License, and its terms, do not apply to those sections when you
distribute them as separate works. But when you distribute the same sections as part of a whole
which is a work based on the Program, the distribution of the whole must be on the terms of
this License, whose permissions for other licensees extend to the entire whole, and thus to each
and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written
entirely by you; rather, the intent is to exercise the right to control the distribution of derivative
or collective works based on the Program.
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In addition, mere aggregation of another work not based on the Program with the Program (or
with a work based on the Program) on a volume of a storage or distribution medium does not
bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object
code or executable form under the terms of Sections 1 and 2 above provided that you also do
one of the following:

a. Accompany it with the complete corresponding machine-readable source code, which
must be distributed under the terms of Sections 1 and 2 above on a medium customarily
used for software interchange; or,

b. Accompany it with a written offer, valid for at least three years, to give any third party, for
a charge no more than your cost of physically performing source distribution, a complete
machine-readable copy of the corresponding source code, to be distributed under the terms
of Sections 1 and 2 above on a medium customarily used for software interchange; or,

c. Accompany it with the information you received as to the offer to distribute corresponding
source code. (This alternative is allowed only for noncommercial distribution and only if
you received the program in object code or executable form with such an offer, in accord
with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to
it. For an executable work, complete source code means all the source code for all modules
it contains, plus any associated interface definition files, plus the scripts used to control com-
pilation and installation of the executable. However, as a special exception, the source code
distributed need not include anything that is normally distributed (in either source or binary
form) with the major components (compiler, kernel, and so on) of the operating system on
which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated
place, then offering equivalent access to copy the source code from the same place counts as
distribution of the source code, even though third parties are not compelled to copy the source
along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided
under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Pro-
gram is void, and will automatically terminate your rights under this License. However, parties
who have received copies, or rights, from you under this License will not have their licenses
terminated so long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it. However, nothing
else grants you permission to modify or distribute the Program or its derivative works. These
actions are prohibited by law if you do not accept this License. Therefore, by modifying or
distributing the Program (or any work based on the Program), you indicate your acceptance of
this License to do so, and all its terms and conditions for copying, distributing or modifying
the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient
automatically receives a license from the original licensor to copy, distribute or modify the
Program subject to these terms and conditions. You may not impose any further restrictions
on the recipients’ exercise of the rights granted herein. You are not responsible for enforcing
compliance by third parties to this License.
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7. If, as a consequence of a court judgment or allegation of patent infringement or for any other
reason (not limited to patent issues), conditions are imposed on you (whether by court order,
agreement or otherwise) that contradict the conditions of this License, they do not excuse you
from the conditions of this License. If you cannot distribute so as to satisfy simultaneously
your obligations under this License and any other pertinent obligations, then as a consequence
you may not distribute the Program at all. For example, if a patent license would not permit
royalty-free redistribution of the Program by all those who receive copies directly or indirectly
through you, then the only way you could satisfy both it and this License would be to refrain
entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance,
the balance of the section is intended to apply and the section as a whole is intended to apply
in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right
claims or to contest validity of any such claims; this section has the sole purpose of protecting
the integrity of the free software distribution system, which is implemented by public license
practices. Many people have made generous contributions to the wide range of software dis-
tributed through that system in reliance on consistent application of that system; it is up to the
author/donor to decide if he or she is willing to distribute software through any other system
and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the
rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents
or by copyrighted interfaces, the original copyright holder who places the Program under this
License may add an explicit geographical distribution limitation excluding those countries, so
that distribution is permitted only in or among countries not thus excluded. In such case, this
License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public
License from time to time. Such new versions will be similar in spirit to the present version,
but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version
number of this License which applies to it and “any later version”, you have the option of
following the terms and conditions either of that version or of any later version published
by the Free Software Foundation. If the Program does not specify a version number of this
License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution
conditions are different, write to the author to ask for permission. For software which is copy-
righted by the Free Software Foundation, write to the Free Software Foundation; we sometimes
make exceptions for this. Our decision will be guided by the two goals of preserving the free
status of all derivatives of our free software and of promoting the sharing and reuse of software
generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO
WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE
LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT
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HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT
NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY
AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM
PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRIT-
ING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MOD-
IFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE
TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR
CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE
THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BE-
ING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES
OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS),
EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBIL-
ITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS
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How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public,
the best way to achieve this is to make it free software which everyone can redistribute and change
under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of
each source file to most effectively convey the exclusion of warranty; and each file should have at
least the “copyright” line and a pointer to where the full notice is found.

one line to give the program’s name and an idea of what it does.
Copyright (C) 19 yy name of author

This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive
mode:

Gnomovision version 69, Copyright (C) 19 yy name of author
Gnomovision comes with ABSOLUTELY NO WARRANTY; for details
type ‘show w’. This is free software, and you are welcome
to redistribute it under certain conditions; type ‘show c’
for details.

The hypothetical commands ‘show w’ and ‘show c ’ should show the appropriate parts of the
General Public License. Of course, the commands you use may be called something other than
‘show w’ and ‘show c ’; they could even be mouse-clicks or menu items—whatever suits your
program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign
a “copyright disclaimer” for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright
interest in the program ‘Gnomovision’
(which makes passes at compilers) written
by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary pro-
grams. If your program is a subroutine library, you may consider it more useful to permit linking
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proprietary applications with the library. If this is what you want to do, use the GNU Library
General Public License instead of this License.
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Appendix H Help and Assistance

We have set up amailing list for generalddd discussions. If you need help and assistance for
solving addd problem, you find the right people here.

Send message to all receivers of the mailing list to:

ddd@gnu.org

This mailing list is also the place where newddd releases are announced. If you want to
subscribe the list, or get more information, send a mail to

ddd-request@gnu.org

See alsotheddd www pagefor recent announcements and other news related toddd.

mailto:ddd@gnu.org
mailto:ddd-request@gnu.org
http://www.gnu.org/software/ddd/
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Appendix I GNU Free Documentation License

Version 1.1, March 2000
Copyright (C) 2000 Free Software Foundation, Inc.
59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

0. PREAMBLE

The purpose of this License is to make a manual, textbook, or other written document “free”
in the sense of freedom: to assure everyone the effective freedom to copy and redistribute
it, with or without modifying it, either commercially or noncommercially. Secondarily, this
License preserves for the author and publisher a way to get credit for their work, while not
being considered responsible for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must
themselves be free in the same sense. It complements the GNU General Public License, which
is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free
software needs free documentation: a free program should come with manuals providing the
same freedoms that the software does. But this License is not limited to software manuals; it
can be used for any textual work, regardless of subject matter or whether it is published as a
printed book. We recommend this License principally for works whose purpose is instruction
or reference.

1. APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work that contains a notice placed by the copyright
holder saying it can be distributed under the terms of this License. The “Document”, below,
refers to any such manual or work. Any member of the public is a licensee, and is addressed
as “you”.

A “Modified Version” of the Document means any work containing the Document or a portion
of it, either copied verbatim, or with modifications and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that
deals exclusively with the relationship of the publishers or authors of the Document to the
Document’s overall subject (or to related matters) and contains nothing that could fall directly
within that overall subject. (For example, if the Document is in part a textbook of mathe-
matics, a Secondary Section may not explain any mathematics.) The relationship could be a
matter of historical connection with the subject or with related matters, or of legal, commercial,
philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being
those of Invariant Sections, in the notice that says that the Document is released under this
License.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or
Back-Cover Texts, in the notice that says that the Document is released under this License.

A “Transparent” copy of the Document means a machine-readable copy, represented in a for-
mat whose specification is available to the general public, whose contents can be viewed and
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edited directly and straightforwardly with generic text editors or (for images composed of pix-
els) generic paint programs or (for drawings) some widely available drawing editor, and that
is suitable for input to text formatters or for automatic translation to a variety of formats suit-
able for input to text formatters. A copy made in an otherwise Transparent file format whose
markup has been designed to thwart or discourage subsequent modification by readers is not
Transparent. A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup,
Texinfo input format, LaTeX input format, SGML or XML using a publicly available DTD,
and standard-conforming simple HTML designed for human modification. Opaque formats
include PostScript, PDF, proprietary formats that can be read and edited only by proprietary
word processors, SGML or XML for which the DTD and/or processing tools are not generally
available, and the machine-generated HTML produced by some word processors for output
purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as
are needed to hold, legibly, the material this License requires to appear in the title page. For
works in formats which do not have any title page as such, “Title Page” means the text near the
most prominent appearance of the work’s title, preceding the beginning of the body of the text.

2. VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or noncom-
mercially, provided that this License, the copyright notices, and the license notice saying this
License applies to the Document are reproduced in all copies, and that you add no other con-
ditions whatsoever to those of this License. You may not use technical measures to obstruct or
control the reading or further copying of the copies you make or distribute. However, you may
accept compensation in exchange for copies. If you distribute a large enough number of copies
you must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly
display copies.

3. COPYING IN QUANTITY

If you publish printed copies of the Document numbering more than 100, and the Document’s
license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly
and legibly, all these Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts
on the back cover. Both covers must also clearly and legibly identify you as the publisher
of these copies. The front cover must present the full title with all words of the title equally
prominent and visible. You may add other material on the covers in addition. Copying with
changes limited to the covers, as long as they preserve the title of the Document and satisfy
these conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first
ones listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent
pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you
must either include a machine-readable Transparent copy along with each Opaque copy, or
state in or with each Opaque copy a publicly-accessible computer-network location contain-
ing a complete Transparent copy of the Document, free of added material, which the general
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network-using public has access to download anonymously at no charge using public-standard
network protocols. If you use the latter option, you must take reasonably prudent steps, when
you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will
remain thus accessible at the stated location until at least one year after the last time you dis-
tribute an Opaque copy (directly or through your agents or retailers) of that edition to the
public.

It is requested, but not required, that you contact the authors of the Document well before
redistributing any large number of copies, to give them a chance to provide you with an updated
version of the Document.

4. MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of
sections 2 and 3 above, provided that you release the Modified Version under precisely this
License, with the Modified Version filling the role of the Document, thus licensing distribution
and modification of the Modified Version to whoever possesses a copy of it. In addition, you
must do these things in the Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document,
and from those of previous versions (which should, if there were any, be listed in the History
section of the Document). You may use the same title as a previous version if the original
publisher of that version gives permission.
B. List on the Title Page, as authors, one or more persons or entities responsible for authorship
of the modifications in the Modified Version, together with at least five of the principal authors
of the Document (all of its principal authors, if it has less than five).
C. State on the Title page the name of the publisher of the Modified Version, as the publisher.
D. Preserve all the copyright notices of the Document.
E. Add an appropriate copyright notice for your modifications adjacent to the other copyright
notices.
F. Include, immediately after the copyright notices, a license notice giving the public permis-
sion to use the Modified Version under the terms of this License, in the form shown in the
Addendum below.
G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts
given in the Document’s license notice.
H. Include an unaltered copy of this License.
I. Preserve the section entitled “History”, and its title, and add to it an item stating at least the
title, year, new authors, and publisher of the Modified Version as given on the Title Page. If
there is no section entitled “History” in the Document, create one stating the title, year, au-
thors, and publisher of the Document as given on its Title Page, then add an item describing
the Modified Version as stated in the previous sentence.
J. Preserve the network location, if any, given in the Document for public access to a Trans-
parent copy of the Document, and likewise the network locations given in the Document for
previous versions it was based on. These may be placed in the “History” section. You may
omit a network location for a work that was published at least four years before the Document
itself, or if the original publisher of the version it refers to gives permission.
K. In any section entitled “Acknowledgements” or “Dedications”, preserve the section’s title,
and preserve in the section all the substance and tone of each of the contributor acknowledge-
ments and/or dedications given therein.
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L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles.
Section numbers or the equivalent are not considered part of the section titles.
M. Delete any section entitled “Endorsements”. Such a section may not be included in the
Modified Version.
N. Do not retitle any existing section as “Endorsements” or to conflict in title with any Invariant
Section.

If the Modified Version includes new front-matter sections or appendices that qualify as Sec-
ondary Sections and contain no material copied from the Document, you may at your option
designate some or all of these sections as invariant. To do this, add their titles to the list of
Invariant Sections in the Modified Version’s license notice. These titles must be distinct from
any other section titles.

You may add a section entitled “Endorsements”, provided it contains nothing but endorsements
of your Modified Version by various parties–for example, statements of peer review or that the
text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25
words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only
one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through
arrangements made by) any one entity. If the Document already includes a cover text for the
same cover, previously added by you or by arrangement made by the same entity you are acting
on behalf of, you may not add another; but you may replace the old one, on explicit permission
from the previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use
their names for publicity for or to assert or imply endorsement of any Modified Version.

5. COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under
the terms defined in section 4 above for modified versions, provided that you include in the
combination all of the Invariant Sections of all of the original documents, unmodified, and list
them all as Invariant Sections of your combined work in its license notice.

The combined work need only contain one copy of this License, and multiple identical Invariant
Sections may be replaced with a single copy. If there are multiple Invariant Sections with the
same name but different contents, make the title of each such section unique by adding at the
end of it, in parentheses, the name of the original author or publisher of that section if known,
or else a unique number. Make the same adjustment to the section titles in the list of Invariant
Sections in the license notice of the combined work.

In the combination, you must combine any sections entitled “History” in the various original
documents, forming one section entitled “History”; likewise combine any sections entitled
“Acknowledgements”, and any sections entitled “Dedications”. You must delete all sections
entitled “Endorsements.”

6. COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under
this License, and replace the individual copies of this License in the various documents with a
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single copy that is included in the collection, provided that you follow the rules of this License
for verbatim copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under
this License, provided you insert a copy of this License into the extracted document, and follow
this License in all other respects regarding verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent docu-
ments or works, in or on a volume of a storage or distribution medium, does not as a whole
count as a Modified Version of the Document, provided no compilation copyright is claimed
for the compilation. Such a compilation is called an “aggregate”, and this License does not
apply to the other self-contained works thus compiled with the Document, on account of their
being thus compiled, if they are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then
if the Document is less than one quarter of the entire aggregate, the Document’s Cover Texts
may be placed on covers that surround only the Document within the aggregate. Otherwise
they must appear on covers around the whole aggregate.

8. TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the
Document under the terms of section 4. Replacing Invariant Sections with translations requires
special permission from their copyright holders, but you may include translations of some or
all Invariant Sections in addition to the original versions of these Invariant Sections. You may
include a translation of this License provided that you also include the original English version
of this License. In case of a disagreement between the translation and the original English
version of this License, the original English version will prevail.

9. TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly pro-
vided for under this License. Any other attempt to copy, modify, sublicense or distribute the
Document is void, and will automatically terminate your rights under this License. However,
parties who have received copies, or rights, from you under this License will not have their
licenses terminated so long as such parties remain in full compliance.

10. FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free
Documentation License from time to time. Such new versions will be similar in spirit to
the present version, but may differ in detail to address new problems or concerns. See
http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies
that a particular numbered version of this License “or any later version” applies to it, you have
the option of following the terms and conditions either of that specified version or of any
later version that has been published (not as a draft) by the Free Software Foundation. If the
Document does not specify a version number of this License, you may choose any version ever
published (not as a draft) by the Free Software Foundation.
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ADDENDUM: How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the docu-
ment and put the following copyright and license notices just after the title page:

Copyright (C) year your name.
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.1
or any later version published by the Free Software Foundation;
with the Invariant Sections being list their titles, with the
Front-Cover Texts being list, and with the Back-Cover Texts be-

ing list.
A copy of the license is included in the section entitled ‘‘GNU
Free Documentation License’’.

If you have no Invariant Sections, write “with no Invariant Sections” instead of saying which
ones are invariant. If you have no Front-Cover Texts, write “no Front-Cover Texts” instead of
“Front-Cover Texts beinglist”; likewise for Back-Cover Texts.

If your document contains nontrivial examples of program code, we recommend releasing these
examples in parallel under your choice of free software license, such as the GNU General Public
License, to permit their use in free software.
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